Video Screencast Help

EV10 Index Upgrade / Rebuild Not Working

Created: 17 May 2012 • Updated: 17 May 2012 | 4 comments
Mark_Solutions's picture
This issue has been solved. See solution.

I have a customer who have upgraded from EV9.0.2 to EV10.0.1 using the Migration Wizard and all went fine and is working as it should.

They wanted to convert indexes from 32 bit to 64 bit so as a test just tried it for a couple of users

It fails almost immediately every time for a convert or rebuild

Firewall and UAC turned off

Have followed advice on DCOM config rights, poisonpill and site level re-try errors.

It gives event 41352 (Index Volumes Processor)

The details in the event are:

Reason:Undefined

Event Type: Non Critical

Description: Retrieving the COM class factory for remote component with CLSID {3A92686F-E5E8-4505-ABB5-49E5F725617A} from machine evserver.ourdomain.com due to the following error: 800700005

A registry check shows this to be the Storage Crawler Service - have checked DCOM setting and set as per previsous advice (Everyone and anonymous have full control)

The task log shows it setting current live index to read only etc., estimating how manyitems to index, creating new hidden index, allocating the new index (I can see that the folder exists on the file system but has just a state.dat file in it of 1kb - nothing useful in it as far as i can see)

It then says adding items to the new index and immediately pauses due to an error - retries, pasuses, fails and gives the same details as in the event logs.

Any ideas please - thanks

 

Comments 4 CommentsJump to latest comment

Percy Vere's picture

Have you see this technote?  http://www.symantec.com/docs/TECH185042

Mark_Solutions's picture

Saw that one but no similarity to the event description or logs that we have

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Mark_Solutions's picture

Ok - this has been cracked and may help others in the future with similar issues when using the EV Migrator to move from EV9 to EV10 on a new server.

We found a lot of DCOM 10016 errors in the System Event Logs (one or more per second) relating to the NT AUTHORITY\ANONYMOUS LOGON

Although EV seemed pretty happy it was clearly having issues in the background with COM / DCOM issues.

This all came down to the SPNs were still set to the original server name that EV was migrated from.

So to resolve it, from a DC as a domain admin, run:

setspn /l oldservername

This shows that is has the ev server and evsite alias against it.

To remove it use:

setspn -D HOST/evalias oldservername

repeat for each alias

Next run:

setspn -A HOST/evalias newservername

repeat for each alais (ev server and ev site - short and fqdn depending on the results of you /l above)

Finally reboot the ev server for it to pick up the correct SPN setting

No more DCOM errors and Index conversions working - happy all around!

Hope this helps others

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
AndrewB's picture

good catch

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com