Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

EV9 - No new items for public folder archiving?

Created: 22 May 2013 | 21 comments
Patrick Böhm's picture

Hi there,

a customer have a problem that since a few weeks new items in public folder will not be archived. When I run the archiving task in report mode it shows me no items to archive. How can I troubleshoot this issue? When I start Outlook with EV System Mailbox I cant see the Public Folders (permissions were not changed so I dont think there are any folderpermissions necessary or?)

Kind regards
Patrick

Discussion Filed Under:

Comments 21 CommentsJump to latest comment

Patrick Böhm's picture

Hi Rob,

Policy was not changed, archiving after 0 days (= immediatly).

Thanks

Rob.Wilcox's picture

I would ...

a/ Check the task isn't configured to be in report-mode

b/ grab and post a screenshot of that policy...  and include the messages class tab (remember that PF's often have different message classes in them, because you can POST and you can EMAIL) them

c/ Do a dtrace of the PF task

Advisor's picture

Do you have multiple policies? You said report mode says no items to archive, does it mean your task is able to scan the PF for new items? But not considering them for archiving for now? You can confirm this by using dtrace log.

Any events logged on EV Server for PF task run?

Patrick Böhm's picture

Hi,

@Rob: Task is not running in report-mode and I already checked the message classes, seems to be ok. Screenshots are requested and I will upload them when the customer sends them to me. How can I dtrace the PF task? I dont see any PF category when creating a new trace, just mailbox archiving categories or what category should i choose?

@Advisor: There is only one PF Archiving Policy. Task is able to scan, no errors in eventlog that the scan is not possible, I dont get any events about PF Archiving except of pf-task start. After starting the task it is completed instantly.

Thanks for you help
Patrick

Patrick Böhm's picture

Hi,

I don't have a category like PublicFolderTask (see attached screenshot).

dtrace.png

Patrick Böhm's picture

Ah, nice tipp :) 

Customer will run a dtrace and send it to me afterwards.

Attached are the screenshots of the public folder archiving policy. Seems to be fine for me.

Thanks

General.pngArchiving Rules.pngArchiving Actions.pngShortcut Content.pngMessage Classes.pngAdvanced.pngTargets.pngShortcut Deletion.png

Patrick Böhm's picture

Hi there,

I got the dtrace logfile from the customer and I found the following errors for every public folder.

Should I contact the support or does anyone know what that means? Cant find anything with the error code.

Thanks

410 10:38:20.977 [3472] (PublicFolderTask) <7644> EV:L {CMAPISession::CreateMapiSession:#430} MailUser 'PR_EMAIL_ADDRESS' MAPI property = /o=customer/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=ev_s90mx9005a6
411 10:38:20.977 [3472] (PublicFolderTask) <7644> EV:L {CMAPISession::CreateMapiSession:#436} Getting IExchangeManageStore object from the privileged mbx
412 10:38:20.977 [3472] (PublicFolderTask) <7644> EV:L {CMAPISession::CreateMapiSession} (Exit) Status: [Success]
413 10:38:20.977 [3472] (PublicFolderTask) <7644> EV:L {CMAPISession::GetMapiSessionFromPoolEx} (Exit) Status: [Success]
414 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
415 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:L {CTargetStateList::SetState} (Entry)
416 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:L {CTargetStateList::SetState} (Exit) Status: [Success]
417 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:L {CTargetStateList::AllEntriesFalse} (Entry)
418 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:L {CTargetStateList::AllEntriesFalse} (Exit) Status: [Success]
419 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:M CArchivingAgent::MainProcessPublicFolders - Error Processing Target Path [\rootfolder1\subfolder1] [0xC0040BE7]
420 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:M CArchivingAgent::MainProcessPublicFolders - Proceeding to post a ProcessPublicFolder message [\rootfolder1\subfolder2]
421 10:38:21.024 [3472] (PublicFolderTask) <7644> EV:M :CArchivingAgent::MainProcessPublicFolders() |Getting MAPI session from pool |
 
 
Rob.Wilcox's picture

Does it do the same for EVERY public folder?  Towards the bottom of that trace the task appears to start to move on to the next folder.

Have you checked tha Vault Service account permissions on the folder?

Patrick Böhm's picture

Yes, I can find every public folder in the dtrace logfile with the error.

Interessting question, which permissions does the account need for Public Folders? I dont find any explicit public folder permissions in the installation guide? I thought the PF permissions are given by adding the service account to the Organization Management group?

Thanks

Rob.Wilcox's picture

It _used to be_ that the VSA needed 'owner' rights on the Public Folder.  But before going down that route...

What permission does the Vautl Service Account have on one, or two, of those folders?

Patrick Böhm's picture

I dont think the VSA has any specific permissions at the public folders right now. Is it written anywhere (documentation) that it needs any permissions like ownership? I told the customer to give the VSA (not the system mailbox) owner-permission at one of the public folder and test if this works. I will let you know when I get an answer.

Thanks,
Patrick

Rob.Wilcox's picture

I haven't been able to find an article ... and I don't really have time to set this up in my lab right now. I'd suggest either:

a/ Try it in your own lab.

b/ Contact Symantec Support.

In some ways when you think about the Vault Service Account needs to be able to access the public folder to be able to read items, archive them, and replace the item with a shortcut. On top of that it will want to add a hidden message to the folder to indicate the archiving settings ...  so to me that (largely) means 'owner' rights on the folder.

If I get chance later in the week then I may be able to try it, but it's not looking likely as it is a short work-week in the UK this week.

Michael Bilsborough's picture

Hi,

Just to let you know I'm seeing exactl the same issue on lab box.  It is 10 sp3 that I'm running with.  It's a newly added public folders so I can't say whether it's ever worked.

In the dtrace below it states a mailbox "srv-ev7ee".  I'm not at all sure where it's getting that from, as that's not the service account mailbox I've specified.  I'll go and investigate that...

For what it's worth there is definately one defect at least here because EV doesn't go and log an event log entry for this.  So you get no outward sign of failure what so ever. I only saw an error in the dtrace

:37:03.805  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::CreateMapiSession:#383} Getting privileged mbx owner (MAPI property PR_MAILBOX_OWNER_ENTRYID)
238 13:37:03.807  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::CreateMapiSession:#388} Opening privileged mailbox's owner MailUser object
239 13:37:03.811  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::CreateMapiSession:#399} Reading MailUser 'PR_EMAIL_ADDRESS' MAPI property
240 13:37:03.814  [5084] (PublicFolderTask) <6456> EV:L {UnEncodeCurlyBraces:#5854} String: /o=TVSQA-ORG/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=srv-ev7ee
241 13:37:03.814  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::CreateMapiSession:#407} MailUser 'PR_EMAIL_ADDRESS' MAPI property = /o=TVSQA-ORG/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=srv-ev7ee
242 13:37:03.814  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::CreateMapiSession:#413} Getting IExchangeManageStore object from the privileged mbx
243 13:37:03.814  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::CreateMapiSession} (Exit) Status: [Success]
244 13:37:03.814  [5084] (PublicFolderTask) <6456> EV:L {CMAPISession::GetMapiSessionFromPoolEx} (Exit) Status: [Success]
245 13:37:04.016  [5084] (PublicFolderTask) <6456> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
246 13:37:04.021  [5084] (PublicFolderTask) <6456> EV:L {CTargetStateList::SetState} (Entry)
247 1

Rob.Wilcox's picture

So, as it's a lab .. can you share the permissions via a screenshot? And try explicitly adding the Vault Service Account?

Patrick Böhm's picture

Hi,

customer changed the permissions to owner für all public folders but nothing changed (still no items to archiv in reports).

Rob.Wilcox's picture

Just so that you know it's nothing something odd with 10.0.3 :

2013-06-10_09h16_36.png

And this is a new PF, with new items copied to it, and then the new PF task run against it with a 0 day policy:

2013-06-10_09h17_09.png

Not sure whether this has been asked already ...

- What version of Exchange is this?

- Is there any replica PF's involved or is this a non-replicated public folder?

- If you create an Outlook profile for the Vault Service Account on the EV server, and open Outlook, can you browse to your PF target, and open items?

- What sort of permissions does the Vault Service Account have on the top level of the PF hierarchy?  For me, using Exchange 2003, I have to check this with Exchange System Manager on the EV server.  [And my Vault Service Account has full control]