Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

EVault Outlook Client Crashes 8 SP3 : Windows 7 x64

Created: 22 Feb 2010 • Updated: 18 Aug 2010 | 41 comments
This issue has been solved. See solution.

Guys,

When I use the Outlook Client, EV8 SP3, and click the change button to change the retention policy Outlook Crashes and places the following error in my event log:

Log Name:      Application
Source:        Application Error
Date:          2/22/2010 8:38:39 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      something.on.a.domain.com
Description:
Faulting application name: OUTLOOK.EXE, version: 12.0.6514.5000, time stamp: 0x4a89dc70
Faulting module name: Valkyrie.dll, version: 8.0.3.1845, time stamp: 0x4aef4dc4
Exception code: 0xc0000005
Fault offset: 0x00067f30
Faulting process id: 0xbcc
Faulting application start time: 0x01cab428c1584b09
Faulting application path: C:\Program Files (x86)\Microsoft Office\Office12\OUTLOOK.EXE
Faulting module path: C:\Program Files (x86)\Enterprise Vault\EVClient\Valkyrie.dll
Report Id: 2a0f92c9-201c-11df-8855-18a905de2ce8
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2010-02-23T01:38:39.000000000Z" />
    <EventRecordID>3811</EventRecordID>
    <Channel>Application</Channel>
    <Computer>something.on.a.domain.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>OUTLOOK.EXE</Data>
    <Data>12.0.6514.5000</Data>
    <Data>4a89dc70</Data>
    <Data>Valkyrie.dll</Data>
    <Data>8.0.3.1845</Data>
    <Data>4aef4dc4</Data>
    <Data>c0000005</Data>
    <Data>00067f30</Data>
    <Data>bcc</Data>
    <Data>01cab428c1584b09</Data>
    <Data>C:\Program Files (x86)\Microsoft Office\Office12\OUTLOOK.EXE</Data>
    <Data>C:\Program Files (x86)\Enterprise Vault\EVClient\Valkyrie.dll</Data>
    <Data>2a0f92c9-201c-11df-8855-18a905de2ce8</Data>
  </EventData>
</Event>

Comments 41 CommentsJump to latest comment

JesusWept3's picture

Known issue fixed in EV8 SP4, workaround is to use non cached mode

Chris242's picture

When is SP4 coming out?  Is there no hotfix for this?  Do you have a KB article or something? 

Rob.Wilcox's picture

 Are you doing this on a regular folder?  Top of the Information Store?

Chris242's picture

 Hi Rob, good to see you on this thread!  :)

This happens on any folder, ie. Inbox or one that I have created under an Exchanged Managed folder on just within the mailbox itself.

JesusWept3's picture

I have the same problem and waiting for the same fix

Rob.Wilcox's picture

 Yep, but isn't the problem you've got JW2, when you right click properties on the TOP OF THE INFORMATION STORE, and click "Change".. not just a random, regular, other folder?

Chris242's picture

 Right, this happens every time I click the Change Button.  No other time.

JesusWept3's picture

i would put money on that its the same problem

Rob.Wilcox's picture

You're avoiding the question ;-)

The bug/crash that you reported only happens when you right click on the mailbox/top-of-the-information-store, go to properties, and click change, with the particular MS hotfix.  It doesn't happen on regular folders, eg Inbox etc.

JesusWept3's picture

either way its irrelevant for the fact that windows 7 isn't supported until EV8 SP4

Chris242's picture

 JW2, have you heard any time frames on release dates?

TonySterling's picture

So back to Chris, are you clicking on the Top of the Information Store or a lower level folder?

If it is a lower level folder it could be a new issue for QA to look at to make sure it doesn't exist in sp4.

Regards,

Chris242's picture

 If I click where it says: Mailbox - Chris and click the Enterprise Vault tab, it does not crash.

It only crashes when I click a folder, either managed by exchange or an unmanaged folder that I have created and click the change button on the Enterprise Vault tab.

The problem does not happen on my 32 Bit, 2008 Citrix Servers.

Rob.Wilcox's picture

I will check wih the certification team if they have done on x64 testing with Windows 7 yet.

The bug that JW2 reported is "different" in that the crash was happening when you clicked on the top-of-the-information-store, went to properties, then the EV tab, then clicked on Change.

That was on a regular XP/Vista/Windows 7 machine.

The fix for that issue (currently scheduled in 8 SP 4) may also resolve the one you are referring to Chris.  I will see if I can setup a machine tomorrow and reproduce it with the particular hotfix (from MIcrosoft) that causes us the issue.

For reference, if you uninstall Microsoft hotfix : 972363

Does the problem go away?

Chris242's picture

Rob, thanks for the quick reply.  I did have KB972363 installed.  I have uninstalled it, rebooted, and retryed.  Outlook still seems to crash.

Is there anything else I can test at the moment or any type of debug or trace logs you would like to see?

455_eric's picture

I'm receiving the same error and Outlook 2007 crashes on both a Windows 7 and XP pc when I click the Change button.  I installed the 8.0.3.1845 update today and that's when the error began.  I am connected to the network in both cases.  I do have update 972363 for Outlook 2007 installed on both pcs as well.

Chris242's picture

Seems like when I turn cached mode off it works just fine.  The problem with this is Virtual Vault or Vault Cache properties are no longer present.  Any other ideas or suggestions?  I haven't rolled out Symantec EV just yet, but I would like to with SP3 or greater.

JesusWept3's picture

yeah uninstall Microsoft office outlook security update KB972363 and you'll be alright

Chris242's picture

I did.  No dice.  Seems like only removing cached mode works.

Rob.Wilcox's picture

 It's sounding then more like a DIFFERENT issue that the one JW2 had.

I'm trying to find out what is happening with regards to Windows 7 x64 testing, and certification.

To summarise :-

Chris your issue is that when you're in cached mode with Windows 7 x64, Outlook 2007 SP 2 + hotfixes, right clicking on regular folders, going to properties, then the EV tab, and clicking change, crashes Outlook.  Top of the information store doesn't cause a crash...  out of cached mode doesn't cause a crash... other clients (ie other OS's) doesn't cause a crash.

JW2 your issue is that on a regular OS, with Outlook 2007 SP 2 + hotfixes (including 972363) right clicking on the top of the information store, going to properties then the EV tab, and then clicking Change crashes Outlook.  This is regardless of cached mode, and happens on all OS's.  Other folders are fine.  Uninstall 972363 resolves the issue for you.

I'm hoping I can get the repro setup today... and I will then create some userdumps for analysis. 

Rob.Wilcox's picture

 We are unable to reproduce the issue in house.

Can we try a few things on your environment?

Firstly, what happens if you close Outlook, locate the .OST file and delete it.  Next time Outlook opens you'll end up with a new OST.  Does the crash still occur then?

Secondly, can you enable full client logging, and post the snippet out of it with regards to system information, it is this bit :-

24/02/2010 08:40:39.955[1196]: Environment:
24/02/2010 08:40:39.955[1196]:     Enterprise Vault Client 8.0.4.1951.0 (HTTP)
24/02/2010 08:40:39.955[1196]:     Professional  (Build 7600)
24/02/2010 08:40:39.956[1196]:     Genuine Intel(R) CPU           T2600  @ 2.16GHz x86 Family 6 Model 14 Stepping 8;
24/02/2010 08:40:39.956[1196]:     Microsoft Outlook 2007
24/02/2010 08:40:39.957[1196]:         [Exchange connection mode: Cached disconnected (6)]
24/02/2010 08:40:39.957[1196]:         [RPC over HTTP not enabled]
24/02/2010 08:40:39.957[1196]:     Microsoft Internet Explorer 8.0.7600.16385
24/02/2010 08:40:39.958[1196]:     Computer name: l3-af782
24/02/2010 08:40:39.958[1196]: 
24/02/2010 08:40:39.959[1196]: Contents of Desktop Settings:
24/02/2010 08:40:39.959[1196]:     ;SERVER; = DUB2XCHEMBPIN01
24/02/2010 08:40:39.959[1196]:     ADDALLEVSERVERS = 0
24/02/2010 08:40:39.959[1196]:     ADDSERVERTOINTRANETZONE = gpkentvlt1.enterprise.veritas.com;gpkvltstr1.enterprise.veritas.com
24/02/2010 08:40:39.960[1196]:     ALLOWSCRIPTPUBLICFOLDERS = 1
24/02/2010 08:40:39.960[1196]:     ALLOWSCRIPTSHAREDFOLDERS = 1
24/02/2010 08:40:39.961[1196]:     ARCHIVEDELITEMSFOLDER = 1
24/02/2010 08:40:39.961[1196]:     ARCHIVEEXPLORERBTNVISIBLE = 1
24/02/2010 08:40:39.961[1196]:     ARCHIVEMANAGEDFOLDERS = 0
24/02/2010 08:40:39.961[1196]:     ARCHIVEONLYWITHATTACH = 0
24/02/2010 08:40:39.962[1196]:     ARCHIVESETTINGSLOCKED = 0
24/02/2010 08:40:39.962[1196]:     AUTOREENABLE = 2
24/02/2010 08:40:39.962[1196]:     BYPASSLOCALPROXY = 0
24/02/2010 08:40:39.962[1196]:     CANCELBTNVISIBLE = 1
24/02/2010 08:40:39.963[1196]:     DEFAULTARCHIVEID = 1808AE8F4BB654D4B89DC54787C183C051110000GPKENTVLT1.enterprise.veritas.com
24/02/2010 08:40:39.963[1196]:     DEFAULTDOUBLECLICKVIEW = 0
24/02/2010 08:40:39.963[1196]:     DEFAULTRETENTIONCATEGORYID = 1B43EEBDC8786DD4F8F0A0F90C28B36B71b10000GPKENTVLT1.enterprise.veritas.com
24/02/2010 08:40:39.964[1196]:     DEFAULTWEBAPPURL = http://gpkentvlt1.enterprise.veritas.com/EnterpriseVault
24/02/2010 08:40:39.964[1196]:     DELETEORIGINALITEM = 2
24/02/2010 08:40:39.965[1196]:     DEPLOYFORMSLOCALLY = 2
24/02/2010 08:40:39.965[1196]:     EVSERVERS = gpkentvlt1.enterprise.veritas.com;GPKVLTSTR1;
24/02/2010 08:40:39.965[1196]:     EXPIRYREPORTBTNVISIBLE = 1
24/02/2010 08:40:39.965[1196]:     FIXOUTLOOKPREVIEWPANE = 1
24/02/2010 08:40:39.966[1196]:     INACTIVITYPERIOD = 21
24/02/2010 08:40:39.966[1196]:     INACTIVITYPERIODUNITS = 0
24/02/2010 08:40:39.966[1196]:     LARGEITEMSSIZEKB = 512
24/02/2010 08:40:39.967[1196]:     LOCALISEDRESOURCES = C:\Program Files\Enterprise Vault\EVClient\Valkyrie.dll
24/02/2010 08:40:39.967[1196]:     MAILBOXDN = /O=Enterprise/OU=MDH/cn=Recipients/cn=user59259094
24/02/2010 08:40:39.967[1196]:     MAILBOXSTATE = 1
24/02/2010 08:40:39.968[1196]:     MAILBOXTYPE = PrimaryUser
24/02/2010 08:40:39.968[1196]:     MANAGEDFOLDERHANDLING = 0
24/02/2010 08:40:39.968[1196]:     MARKPSTS = 1
24/02/2010 08:40:39.968[1196]:     MAXAUTOREENABLES = 1
24/02/2010 08:40:39.969[1196]:     MINAGEPERIOD = 2
24/02/2010 08:40:39.969[1196]:     MINAGEPERIODUNITS = 0
24/02/2010 08:40:39.969[1196]:     OVDOWNLOADREMINDER = 1
24/02/2010 08:40:39.969[1196]:     OVENABLED = 1
24/02/2010 08:40:39.970[1196]:     OVMESSAGECLASSINCLUDE = REPORT.IPM*;IPM.Schedule*;IPM.Recall*;IPM.Post*;IPM.Note.PangeaICO;IPM.Note.Pangea;IPM.Note*;IPM.Document*;IPM.Appointment*;IPM.Activity*;
24/02/2010 08:40:39.970[1196]:     OVMINAGEPERIOD = 0
24/02/2010 08:40:39.971[1196]:     OVSHOWADVANCEDSETTINGS = 1
24/02/2010 08:40:39.971[1196]:     OVSTARTDOWNLOADBTNVISIBLE = 1
24/02/2010 08:40:39.971[1196]:     OWA2003DELETEMODE = 2
24/02/2010 08:40:39.971[1196]:     OWAWEBAPPURL = http://gpkentvlt1.enterprise.veritas.com/EnterpriseVault
24/02/2010 08:40:39.972[1196]:     PFINACTIVITYPERIOD = 0
24/02/2010 08:40:39.972[1196]:     PFINACTIVITYPERIODUNITS = 0
24/02/2010 08:40:39.972[1196]:     PFLARGEITEMSSIZEKB = 10240
24/02/2010 08:40:39.973[1196]:     PFMINAGEPERIOD = 0
24/02/2010 08:40:39.973[1196]:     PFMINAGEPERIODUNITS = 0
24/02/2010 08:40:39.973[1196]:     PFUSELARGEITEMSSIZE = 0
24/02/2010 08:40:39.974[1196]:     POLICYENTRYID = 181A09C5350531443AD9C91765E488DC71012700GPKENTVLT1.enterprise.veritas.com
24/02/2010 08:40:39.974[1196]:     PSTIMPORTENABLED = 0
24/02/2010 08:40:39.975[1196]:     PSTPOLICYENTRYID = 1BA6A88BF2466684180F21CA08A0846BE1012700GPKENTVLT1.enterprise.veritas.com
24/02/2010 08:40:39.975[1196]:     RPCOVERHTTPRESTRICTIONS = 0
24/02/2010 08:40:39.975[1196]:     SERVERVERSION = 8.03
24/02/2010 08:40:39.976[1196]:     SETFORCEFORMRELOAD = 0
24/02/2010 08:40:39.976[1196]:     SITEENTRYID = 1BF98D9016121434A81DDEE85B6ECC9231d10000GPKENTVLT1.enterprise.veritas.com
24/02/2010 08:40:39.976[1196]:     SYSTEMMAILBOX = SMTP:zzDUB2XCHEMBPIN01@symantec.com
24/02/2010 08:40:39.977[1196]:     USEINACTIVITYPERIOD = 1
24/02/2010 08:40:39.977[1196]:     USELARGEITEMSSIZE = 1
24/02/2010 08:40:39.977[1196]:     USEQUOTALIMIT = 1
24/02/2010 08:40:39.977[1196]:     USERSCANDELETEITEMS = 1
24/02/2010 08:40:39.978[1196]:     USESELFINSTALLFUNCT = 1
24/02/2010 08:40:39.978[1196]:     VVALLOWINTRASTORECOPY = 1
24/02/2010 08:40:39.978[1196]:     VVENABLED = 1
 

Thirdly, can you download and install the debugging tools for Windows (the 32 bit version, I think... as my x64 system isn't working yet I can't confirm).  We want to install that, then we want to run a command like this :-

cscript adplus.vbs -quiet -crash -pn outlook.exe -o c:\dumpfiles

The steps being :-

Open Outlook
Run the above command
Reproduce the error

We should get a crash dump created in the dumpfiles folder.  If we do, I can give you more information on how to get that to me.

Chris242's picture

 I have the dump files.  They are about 220Meg zipped.  Let me know where you want me to put them.

Chris242's picture

 Rob,

Looks like deleting the .OST file works; however, I don't want to delete an OST on 2K machines, 1/4 of which are remote.  Is there another approach?

Also do you want me to pull the log files?

Rob.Wilcox's picture

 Chris, I would suspect that for some reason that OST was corrupt...  Try 1-5 other machines, I doubt you will have the issue on those machines.

Chris242's picture

Rob, it is like this on every machine that I visit.   Do you have any direction I should take?  I wouldn't mind scripting deleting the OST file, but alot of my users are remote sales users so there is really no way I can do this.  Is there any way to do something with the vault server itself?

Rob.Wilcox's picture

Hmm very odd.

I would suggest first of all going down option 2, and 3 routes, in my long post above.  And if you get a good userdump, I can take a look at it, to see if there is anything obvious.

There isn't that you can do from the vault server no. 

Chris242's picture

Rob, one other thing.  When I was working with ADPlus and Outlook crashed and restarted I received  a dialog box that told me Outlook couldn't access Outlook.ost.

I don't know if that is of any help, but I thought I would pass it along.  Thanks again for all of your help! 

Chris242's picture

Rob, Okay, will do.  I'm I have to leave here shortly, but I'm going to do your steps either tonight or first thing in the morning.  I'll post back asap.

TonySterling's picture

@chris

To make the post not go down so far I added your client trace to the first post.  You can add attachments to the first post as well.

Cheers,

Chris242's picture

Where should I add my  dump files?  They are about 220Meg zipped.

TonySterling's picture

The limit for the forum is 150 mb so probably not. :)

Also, since Rob is the only that really needs to see those send him a PM and he can set you up a place to load those to. 

Rob.Wilcox's picture

 Chris, please send me a PM with your email address..  We can carry on from that.  There are a bunch of things in your client log, that you didn't mention ;-)

Rob.Wilcox's picture

Just for final wrap up, I've worked with Chris outside of the forums, and the issue is resolved in 8 SP 4.

SOLUTION
Rob.Wilcox's picture

Well Alex.... it was different enough from your issue for me to be "concerned", hence investigation, and in the end it is the same issue as yours (but this happening on every folder)

Kariii's picture

Hi Rob, do you have any news?
I'm also facing this problem and disabled cache mode on my Xp 32bit.

Rob.Wilcox's picture

If it is the same issue then I proved with Chris that this is fixed with the change we have made in the EV 8 SP 4 client (that will be available very soon)

Chris242's picture

Where can we check for the press release on this, Rob?

Are you allowed to comment on if it is going to bed days, weeks, or a few months out?

Rob.Wilcox's picture

It's days...  8 SP 4 has been released from Engineering it just has to go through all the pipeline to get it on the web and so on.