Video Screencast Help

Event 3139 errors occur enabling mailboxes Error 0x80040115

Created: 04 Oct 2012 • Updated: 04 Oct 2012 | 6 comments
This issue has been solved. See solution.

Our environment is currently EV 9 SP2.  At some point in the last weeks or so, enterprise vault stopped automatically enabling mailboxes for EV.  The event log gives the following error for every new user that it tries to enable.  Manually trying to enable a mailbox gives the same error and result.  Existing users continue to work fine.  I can't find anything that has changed that anyone is aware of.

Event ID: 3139 An non-specific error has occurred whilst enabling archiving for the mailbox <MailboxName> Error: <0x80040115> 

I verified that the vault service account is ok and the mailbox for the exchange server can create profiles in outlook on the server.  I tried a dtrace on the Agent Client Broker and pulled a small section of the log below where the error occurred.  I'm not sure what my next steps should be to track down the cause of this.  ClosestGC registry key is already set.  I've looked at things per other forum posts like homeMTA and they look ok as well.  Any help or directly would be greatly appreciated.  Thanks!

 

 

1269 14:46:03.849 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - ProfileName=VaultMbxAgent-MBX-9832-1349203563-0-849-0
1270 14:46:03.849 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - CreateProfile
1271 14:46:03.849 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - CreateMsgService
1272 14:46:03.864 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - GetMsgServiceTable
1273 14:46:03.864 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - QueryAllRows
1274 14:46:03.864 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - ConfigureMsgService
1275 14:46:03.864 [5096] (AgentClientBroker) <9832> EV:M ConfigureMsgServiceAttempt - Trying ConfigureMsgService using PR_PROFILE_UNRESOLVED_SERVER=[MBX], Attempt=[1]
1276 14:46:04.083 [5096] (AgentClientBroker) <9832> EV:M ConfigureMsgServiceAttempt - ConfigureMsgService successful
1277 14:46:04.083 [5096] (AgentClientBroker) <9832> EV:M ConfigureMsgServiceAttempt - Exiting [0x00000000]
1278 14:46:04.083 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CPAS() - MAPILogonEx(2)
1279 14:46:04.161 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::CreateProfileAndSession(VaultMbxAgent-MBX-9832-1349203563-0-849-0) - Profile successfully created
1280 14:46:04.161 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CreateMapiSession - Calling OpenMailbox
1281 14:46:04.161 [5096] (AgentClientBroker) <9832> EV:L {CMailboxHelper::OpenMailbox:#421} Opening primary mailbox associated with MAPI session. Getting list of message stores...
1282 14:46:04.161 [5096] (AgentClientBroker) <9832> EV:L {CMailboxHelper::OpenMailbox:#429} Reading message store table...
1283 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:L {CMailboxHelper::OpenMailbox:#468} Opened message store.
1284 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CreateMapiSession - Calling GetExchangeServerDnFromSession
1285 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::GetExchangeServerDnFromSession - Entry
1286 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::GetExchangeServerDnFromSession - opening entry
1287 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::GetExchangeServerDnFromSession - opened entry (ST)
1288 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CreateMapiSession - Release Mutex(2)
1289 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::ClearProfileCache()
1290 14:46:04.224 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CloseMapiSession - Entry
1291 14:46:04.255 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CloseMapiSession - [1]
1292 14:46:04.255 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CloseMapiSession - [2]
1293 14:46:04.255 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::CloseMapiSession - [3]
1294 14:46:04.271 [5096] (AgentClientBroker) <9832> EV:M CMailboxHelper::DeleteProfile(VaultMbxAgent-MBX-9832-1349203563-0-849-0): 0x0
1295 14:46:04.271 [5096] (AgentClientBroker) <9832> EV:M CMAPISession::GetMapiSessionFromPoolEx: Exit status: 0x80040115
1296 14:46:04.271 [5096] (AgentClientBroker) <9832> EV:H CAgentExchSynch::EnableMailboxCommonV9 - HRXEX fn trace : Returning error 0x80040115, .\AgentExchSynch.cpp [lines {5103,5325}], built Mar 14 10:54:47 2011.
1297 14:46:04.286 [5096] (AgentClientBroker) <9832> EV~E Event ID: 3139 An non-specific error has occurred whilst enabling archiving for the mailbox /o=Salisbury/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=DAGOODYEAR |Error: <0x80040115> |
1298 14:46:04.286 [5096] (AgentClientBroker) <9832> EV:M CArchivingAgentQueue::EnableMailboxV9 - exiting due to error
1299 14:46:04.286 [5096] (AgentClientBroker) <9832> EV:L {CImpersonate::~CImpersonate} (Entry)
1300 14:46:04.286 [5096] (AgentClientBroker) <9832> EV:L {CImpersonate::StopImpersonation} (Entry)
1301 14:46:04.286 [5096] (AgentClientBroker) <9832> EV:L {CImpersonate::StopImpersonation} (Exit) Status: [Success]
1302 14:46:04.286 [5096] (AgentClientBroker) <9832> EV:L {CImpersonate::~CImpersonate} (Exit) Status: [Success]
1303 14:46:04.599 [5096] (AgentClientBroker) <2920> EV:L {CSecurityWrapper::CSecurityWrapper:#118} Creating security wrapper. Role checks required: [True]
1304 14:46:04.599 [5096] (AgentClientBroker) <2920> EV:L {CSecurityWrapper::HasServerClientGotPermission:#458} Checking role access for admin operation [53]...
1305 14:46:04.599 [5096] (AgentClientBroker) <2920> EV:L {CSecurityWrapper::IsServerClientTheVSA:#674} Checking if server client is VSA...
1306 14:46:04.599 [5096] (AgentClientBroker) <2920> EV:L {CSecurityWrapper::IsServerClientTheVSA:#704} Client server is running as VSA: [True] (in a client COM call: [True]).
1307 14:46:04.599 [5096] (AgentClientBroker) <2920> EV:L {CSecurityWrapper::HasServerClientGotPermission:#476} Client is VSA. Access granted.

Comments 6 CommentsJump to latest comment

TonySterling's picture

In the past this was caused by temporary mapi profile on the EV server.

You could try stopping the archive task and cleaning up any temp mapi profiles then try again.

JesusWept3's picture

Other reasons can be permissions, throttling policies and/or the system mailbox being on a different Exchange Server than you're targeting

For instance if you have evSysMailbox-Exch1@myDomain.com and it gets moved from Exch1 to Exch2, that would cause very similar errors, if not the exact same ones.

Others can be issues with CAS Arrays and load balancers causing MAPI issues

ManishN's picture

CMAPISession::GetMapiSessionFromPoolEx: Exit status: 0x80040115

we have a problem at this stage

0x80040115 means MAPI_E_NETWORK_ERROR; when we are trying to get the sessions PR_EMS_AB_HOME_MTA_W attribute

So i believe two possibilities

1 HomeMTA attribute for the EV system mailbox is missing
or
2 HomeMTA attribute for the EV system mailbox is invalid

you can validate by using ldp logs

If you are not able to fix, then probably creating a new system mailbox can sometime also reslove the issue

 

 

Regards,

MN

SOLUTION
dgoodyear's picture

It looks like homemta may be the source of the issue.  I checked the system mailbox and it's homemta is referencing the deleted objects container. 

dgoodyear's picture

Fixing the homemta value has corrected the problem.  I'm not able to enable mailboxes once more.  Thanks for the help!

TonySterling's picture

I think you mean *now* able to enable mailboxes once more.  wink