Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Event ID 41123: Could not switch EnterpriseVaultMonitoring database to single user mode

Created: 29 Jul 2013 • Updated: 30 Jul 2013 | 7 comments
SHI-CRO's picture
This issue has been solved. See solution.

After moving the EV servers from Windows 2003 servers to Windows 2008R2 servers, we're getting this warning in the EV event logs:

 

-------------

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Date:          7/29/2013 9:14:56 AM
Event ID:      41123
Task Category: Monitoring Configuration Utility
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      EVComputer
Description:
Monitoring Configuration Utility reported error: Could not switch EnterpriseVaultMonitoring database to single user mode.

For more information, see Help and Support Center at http://evevent.symantec.com/rosetta/showevent.asp?...
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Enterprise Vault " />
    <EventID Qualifiers="0">41123</EventID>
    <Level>3</Level>
    <Task>118</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-07-29T13:14:56.000000000Z" />
    <EventRecordID>2898</EventRecordID>
    <Channel>Symantec Enterprise Vault</Channel>
    <Computer>EVComputer</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Monitoring Configuration Utility reported error: Could not switch EnterpriseVaultMonitoring database to single user mode.</Data>
  </EventData>
</Event>

--------

 

Anyone have any ideas of how to fix this without recreating the monitoring database?

 

Operating Systems:

Comments 7 CommentsJump to latest comment

Nate.D's picture

Can you try just switching the database out of single user mode from the SQL console.

 

Go into SQL, find the database in question, right click > properties > options page > switch 'restrict access' to 'MULTI_USER'. Its the very bottom option in that window.

 

It may be that it got switched somehow, and vault is not able to force it to switch back. I would check that first, please let us know if SQL is reporting the db in a state other than 'SINGLE_USER'

If I was helpful in solving your issue please mark my post with a thumbs up or a solution!  Have a great day :)

GabeV's picture

Do you know the name of the SQL server database? I have seen this issue when the database has spaces on its name. What version of Enterprise Vault are you running?

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

Pradeep_Papnai's picture

Did you try the steps mention as per TN http://www.symantec.com/docs/TECH63976, the only difference is, it discuss about EVFSAReporting database.

Resolution step
------------------
1. Stop the Enterprise Vault services on all EV servers.
2. Open the SQL log on the SQL server to determine the reason the database could not be set to single user mode.  

Note: Restarting the SQL server will often resolve this issue.

3. Once this issue is corrected, verify the database can be placed in single user mode using the following query for either SQL 2000 or SQL 2005:

ALTER DATABASE EnterpriseVaultMonitoring

SET Single_User

4. Once the database can successfully be placed in single user mode, place the database into multi user mode using the following command:

ALTER DATABASE EnterpriseVaultFSAReporting

SET Multi_User

5. Restart all Enterprise Vault services on all EV servers.

6. Open the Enterprise Vault Event Log and verify Event ID 41121 is recorded:

 

Advisor's picture

Yes, you should try changing the mode from SQL first, if that does not help, then its more of SQL issue.

 

SHI-CRO's picture

We did change it to multi-user mode manually on the SQL server, but the errors persisted.

 

However, the errors went away when we changed the compatibility of the monitoring database from SQL2005 to SQL2008 (we had moved the DBs from a SQL 2005 server).

SOLUTION
Advisor's picture

So it was the issue with SQL binaries which were used by Stored procedure? Compatibility level guides SP's to use those DLL/binaries versions. Thats great, finally you were able to resolve this issue without creating a new database :)

SHI-CRO's picture

It seems that manually switching this DB to single user mode wasn't a good idea either.  We had to change it back to multi user mode to resolve some warnings in the EV server event logs.  I suspect part of the process to send the performance counters to the monitoring DB makes the switch from multi user mode to single user mode while it writes the data and then switches it back.