Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

event id:8390 web application error

Created: 22 Jun 2013 • Updated: 28 Jun 2013 | 13 comments
This issue has been solved. See solution.

Hi,

When ever i access enterprise vault server through internet explrorer from client system error is writing on event viewer on EV server.

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Date:          6/21/2013 5:36:33 PM
Event ID:      8390
Task Category: Web Application (WP)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      INMUM01EVAPP01.internal.testing.com
Description:
The EnterpriseVault.DirectoryConnection object reported an error.
 
Unspecified error

Internal references:
Error [0x80004005]
{CDirectoryConnectionObject::GetNonDeletableArchivesByVaultStore} [.\DirectoryConnectionObject.cpp, lines {1036,1044}, built Dec 11 16:18:57 2012]

For more information, see Help and Support Center at http://entced.symantec.com/entt?product=ev&language=english&version=10.0.3.0&build=10.0.3.1090&error=V-437-8390

please help to resolve the above error

Operating Systems:

Comments 13 CommentsJump to latest comment

TonySterling's picture

I would start here:

Enterprise Vault Event 8390 Errors - Troubleshooting

Article:HOWTO83884  |  Created: 2013-03-01  |  Updated: 2013-05-01  |  Article URL http://www.symantec.com/docs/HOWTO83884

Which based on your error code will lead you to this:

Event 8390 - Unspecified error - 0x80004005

Article:TECH203126  |  Created: 2013-02-22  |  Updated: 2013-03-14  |  Article URL http://www.symantec.com/docs/TECH203126
mathilakathh's picture

i already applied the details mentioned in the tech note. still not resolved.

TonySterling's picture

Do you have the dtrace you could attach here?

  • For more information about Symantec Enterprise Vault’s Dtrace Utility please see HOWTO57893
  • Dtrace the process W3WP for no less than 5 minutes while re-creating the issue
mathilakathh's picture

Please find below the dtrace log:

DTrace trace log for server: INMUM01EVAPP01.internal.testing.com
[Opened: 2013/06/21 16:48:14]

Windows version: 6.1.7600 (Windows Server 2008 R2)

Time zone: India Standard Time
Time difference to UTC: +5:30

-----

Enabled Trace options

Id    Name                                     Detail     Include Events

-----

Display Filter:
  Include strings:
    EV-
    EV:
    EV~

  Exclude strings:
    DBFramework
    DirectoryConnection
-----

Current File Rollover Settings: 100Mb

-----

Running in Terminal Services session...
  Monitoring debug output from processes running in the console session
  Monitoring debug output from processes running in the current Terminal Services session

31 16:48:43.383  [7676] (w3wp) <3956> EV:L CIndexSearch2::Reset
32 16:48:43.383  [7676] (w3wp) <3956> EV:L CIndexSearch2::FinalRelease
33 16:48:43.383  [7676] (w3wp) <3956> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0
34 16:48:43.383  [7676] (w3wp) <3956> EV:H Calling GenAuthString
37 16:48:43.383  [7676] (w3wp) <3956> EV:M ClientAuthHelperImpl::GenAuthString Authentication Type: Currently impersonated user Client:(null) ==> AuthToken:10.74.30.91 kzZE*****
39 16:48:43.414  [7676] (w3wp) <3956> EV:L CBaseDirectoryServiceWrapper::CreateDirectoryService() - Entry [m_nNumTries = 40]
40 16:48:43.414  [7676] (w3wp) <3956> EV:L CBaseDirectoryServiceWrapper::CreateDirectoryService() - Successfully communicated with an EV Directory Service on the local machine
41 16:48:43.477  [7676] (w3wp) <3956> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 11621064
43 16:48:43.477  [7676] (w3wp) <3956> EV:L CBaseDirectoryServiceWrapper::CreateDirectoryService() - Entry [m_nNumTries = 40]
44 16:48:43.477  [7676] (w3wp) <3956> EV:L CBaseDirectoryServiceWrapper::CreateDirectoryService() - Successfully communicated with an EV Directory Service on the local machine
45 16:48:43.492  [7676] (w3wp) <3956> EV:L {VaultCoCreateInstanceEx} CLSID [{4EC6FF76-C97A-11D1-90E0-0000F879BE6A}] Server Name [(null)] Used Server Name [(null)] Num of attempts [1] Total elapsed [0.000s] Result [Success  (0)]
46 16:48:43.508  [7676] (w3wp) <3956> EV:L Currently shopping for: VF-ROOT\in-vf-svc-evadmin |
49 16:48:51.651  [7676] (w3wp) <3956> EV:L Currently shopping for: VF-ROOT\in-vf-svc-evadmin |
102 16:49:13.755  [7676] (w3wp) <9252> EV-L {Slot.Page_Load} Slot.Page_Load
103 16:49:13.817  [7676] (w3wp) <9252> EV-L {Slot.GetSyncSlot} Slot.GetSyncSlot - VEID:1C1AF7E0096F3704F8203B0E8AFD682801110000evserver01, TimeOut:0
104 16:49:13.864  [7676] (w3wp) <9252> EV:L {CAutoJournalAccessor::GetSyncSlot} (Entry)
106 16:49:13.864  [7676] (w3wp) <9252> EV:L CBaseDirectoryServiceWrapper::CreateDirectoryService() - Entry [m_nNumTries = 40]
107 16:49:13.864  [7676] (w3wp) <9252> EV:M CBaseDirectoryServiceWrapper::CreateDirectoryService() - Could not communicate with a local EV Directory Service [0x80004005]
108 16:49:13.864  [7676] (w3wp) <9252> EV:L CBaseDirectoryServiceWrapper::CreateDirectoryService() - Will try to connect to EV Directory Service on EVSERVER01
109 16:49:13.895  [7676] (w3wp) <9252> EV:L {VaultCoCreateInstanceEx} Attempt [1] to create COM object failed. CLSID [{F4D3EB5B-C7C5-11D1-90DB-0000F879BE6A}] Server Name [EVSERVER01] Elapsed [0.030s] Result [Unspecified error  (0x80004005)]
110 16:49:14.098  [7676] (w3wp) <9252> EV:L Attempting to open WinSock session.
111 16:49:14.098  [7676] (w3wp) <9252> EV:L Successfully opened WinSock session.
112 16:49:14.098  [7676] (w3wp) <9252> EV:L CHostNameHelper: IsLocalMachineExtendedCheck returned [False] for server [EVSERVER01].
113 16:49:14.098  [7676] (w3wp) <9252> EV:L {VaultCoCreateInstanceEx} Attempt [2] to create COM object failed. CLSID [{F4D3EB5B-C7C5-11D1-90DB-0000F879BE6A}] Server Name [10.74.30.91] Elapsed [0.001s] Result [Unspecified error  (0x80004005)]
114 16:49:14.504  [7676] (w3wp) <9252> EV:L {VaultCoCreateInstanceEx} Attempt [3] to create COM object failed. CLSID [{F4D3EB5B-C7C5-11D1-90DB-0000F879BE6A}] Server Name [10.74.30.91] Elapsed [0.001s] Result [Unspecified error  (0x80004005)]
115 16:49:15.112  [7676] (w3wp) <9252> EV:L {VaultCoCreateInstanceEx} Attempt [4] to create COM object failed. CLSID [{F4D3EB5B-C7C5-11D1-90DB-0000F879BE6A}] Server Name [10.74.30.91] Elapsed [0.001s] Result [Unspecified error  (0x80004005)]
116 16:49:15.923  [7676] (w3wp) <9252> EV:L {VaultCoCreateInstanceEx} Attempt [5] to create COM object failed. CLSID [{F4D3EB5B-C7C5-11D1-90DB-0000F879BE6A}] Server Name [10.74.30.91] Elapsed [0.001s] Result [Unspecified error  (0x80004005)]
117 16:49:16.657  [7676] (w3wp) <8352> EV:L CIndexSearch2::Reset
118 16:49:16.657  [7676] (w3wp) <8352> EV:L CIndexSearch2::FinalRelease
119 16:49:16.657  [7676] (w3wp) <8352> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0
120 16:49:16.657  [7676] (w3wp) <8352> EV:H Calling GenAuthString
121 16:49:16.657  [7676] (w3wp) <8352> EV:H ClientAuthHelperImpl::GenAuthString Unable to register by impersonated user. hr=Unspecified error  (0x80004005)
122 16:49:16.657  [7676] (w3wp) <8352> EV:H CClientAuthenticate::GenAuthString exception raised!
124 16:49:16.657  [7676] (w3wp) <8352> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0
128 16:49:16.937  [7676] (w3wp) <9252> EV:H {VaultCoCreateInstanceEx} CLSID [{F4D3EB5B-C7C5-11D1-90DB-0000F879BE6A}] Server Name [EVSERVER01] Used Server Name [10.74.30.91] Num of attempts [6] Total elapsed [3.061s] Result [Unspecified error  (0x80004005)]
129 16:49:16.937  [7676] (w3wp) <9252> EV:M CBaseDirectoryServiceWrapper::CreateDirectoryService() failed.|Hr: 0x80004005|Retries: 6|TryLocal: true|Directory Name: EVSERVER01|
130 16:49:16.937  [7676] (w3wp) <9252> EV:H {CBaseDirectoryServiceWrapper::GetInterface} HRXEX fn trace : Error [0x80004005], ref(1): [EVSERVER01], [.\DirectoryServiceWrapper.cpp, lines {630,657,681}, built Dec 11 16:18:57 2012].
133 16:49:16.937  [7676] (w3wp) <9252> EV:H {CAutoJournalAccessor::GetSyncSlot:#54} _com_error exception: [Unspecified error  (0x80004005)]
134 16:49:16.937  [7676] (w3wp) <9252> EV:H {CAutoJournalAccessor::GetSyncSlot} (Exit) Status: [Unspecified error  (0x80004005)]
135 16:49:16.953  [7676] (w3wp) <9252> EV-H {Common.DTraceExceptionAndVEID} Exception: Error HRESULT E_FAIL has been returned from a call to a COM component. Info:VEID:1C1AF7E0096F3704F8203B0E8AFD682801110000evserver01 Diag:HRESULT: 80004005 Type:System.Runtime.InteropServices.COMException ST:   at KVS.EnterpriseVault.Interop.AutoJournalAccessorClass.GetSyncSlot(String auth, String archiveID, UInt32& timeOut)|   at DesktopClientCacheWeb.Slot.GetSyncSlot(String archiveVEID, UInt32 timeOut)|   at DesktopClientCacheWeb.Slot.Page_Load(Object sender, EventArgs args) Inner:None
136 16:49:18.825  [7676] (w3wp) <9252> EV-L {ClientDiagnostics.Page_Load} ClientDiagnostics called
137 16:49:18.825  [7676] (w3wp) <9252> EV-H {ClientDiagnostics.Page_Load} AUTH_USER string: .
138 16:49:18.887  [7676] (w3wp) <9252> EV:H Calling GenAuthString
139 16:49:18.887  [7676] (w3wp) <9252> EV:H ClientAuthHelperImpl::GenAuthString Unable to register by impersonated user. hr=Unspecified error  (0x80004005)
140 16:49:18.887  [7676] (w3wp) <9252> EV:H CClientAuthenticate::GenAuthString exception raised!
141 16:49:18.887  [7676] (w3wp) <9252> EV-L {ClientDiagnostics.PostDiagnosticValues} Exception: Error HRESULT E_FAIL has been returned from a call to a COM component. Info:ClientDiagnostics PostDiagnosticValues failed Diag:HRESULT: 80004005 Type:System.Runtime.InteropServices.COMException ST:   at KVS.EnterpriseVault.Interop.ClientAuthenticateClass.GenAuthString(String reserved, Int32 flags, Int32& cancelid, String& authstring)|   at DesktopWeb.ClientDiagnostics.GetNewAuthString()|   at DesktopWeb.ClientDiagnostics.PostDiagnosticValues(NameValueCollection queryStringParams) Inner:None
142 16:49:25.267  [7676] (w3wp) <8352> EV:L CIndexSearch2::Reset
143 16:49:25.267  [7676] (w3wp) <8352> EV:L CIndexSearch2::FinalRelease
144 16:49:25.267  [7676] (w3wp) <8352> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0
145 16:49:25.267  [7676] (w3wp) <8352> EV:H Calling GenAuthString
146 16:49:25.267  [7676] (w3wp) <8352> EV:H ClientAuthHelperImpl::GenAuthString Unable to register by impersonated user. hr=Unspecified error  (0x80004005)
147 16:49:25.267  [7676] (w3wp) <8352> EV:H CClientAuthenticate::GenAuthString exception raised!
149 16:49:25.267  [7676] (w3wp) <8352> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0
171 16:49:37.061  [7676] (w3wp) <8352> EV:L CIndexSearch2::Reset
172 16:49:37.061  [7676] (w3wp) <8352> EV:L CIndexSearch2::FinalRelease
173 16:49:37.061  [7676] (w3wp) <8352> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0
174 16:49:37.061  [7676] (w3wp) <8352> EV:H Calling GenAuthString
175 16:49:37.061  [7676] (w3wp) <8352> EV:H ClientAuthHelperImpl::GenAuthString Unable to register by impersonated user. hr=Unspecified error  (0x80004005)
176 16:49:37.061  [7676] (w3wp) <8352> EV:H CClientAuthenticate::GenAuthString exception raised!
178 16:49:37.061  [7676] (w3wp) <8352> EV:L CAuthHelper::Reset Cancel registration? True CancelId: 0

TonySterling's picture

So you see DCOM errors in the System Log?

Also, can you share what version of EV and Server OS?

mathilakathh's picture

EV version : 10.0.3

operating system: windows 2008 r2

JesusWept3's picture

Can you ping this server btw? EVSERVER01 from the EV Server thats throwing those errors?
but yeah tony is right, its probably just that you're getting DCOM errors in the background, in this case its the Directory Service

So if i were you i would do the following

1. Browse to your EV install folder (i.e. C:\Program Files (x86)\Enterprise Vault\
2. Run "FileReRegister.bat" and let that re-register all the binaries and DLL files etc
3. Restart your EV Services
4. Open up the Vault Admin Console
5. Go to the properties of your Directory at the top
6. Go to the Service Account tab and re-enter your EV Admin password
7. Restart EV Services once more

This will then have refreshed every DCOM object in the environment as well as re-registering all the binaries and DLL's that you'd see on a regular install

Of course none of this matters if you cannot resolve the Servername through netbios as it would still fail, it could also be firewall etc

mathilakathh's picture

i could manage to ping servers, let me try by re-registiring binaries and starting services. i will update once the above mentioned process done.

mathilakathh's picture

from the affected server admin tool , component services, enable dcom for this computer is not selected, if i tried to manually select that option and click ok mmc is getting crashed.

JesusWept3's picture

Then you should probably open a case with Microsoft at that point

Merv's picture

I came across 2 related technotes which cause the 8390 access denied errors:

http://www.symantec.com/business/support/index?pag...

Does this problem happen intermittently or resolved after a reboot?

And if you have the latest 10.0.3 CHF 2 installed ( and not properly installed )

http://www.symantec.com/business/support/index?page=content&id=TECH206012

Lastly DCOM related issues

http://www.symantec.com/business/support/index?pag...

SOLUTION
mathilakathh's picture

DCOM issues have been resolved now. But again from the client if i browse ev server, error message showing near symantec logo and archive explorerui.asp throwing 500 error. Mean while the tech note which you mentioned, already performed those steps.... still no luck.event viewer throwing vault service account dont have launch local permission and remote launch permission on few application id. and those application ids pointing towards directory service and enterprise task service..