Video Screencast Help

Exchange 2007 Backup Issue

Created: 04 Mar 2013 | 13 comments

Hi All,

Could do with some help with an issue I've been trying to solve for a few weeks now.

We're getting this error when trying to backup our Exchange 2007 error -

---------------

Backup- 'ServerName'V-79-57344-34070 - AOFO: Initialization failure on: "\\Server_Name\Microsoft Information Store\First Storage Group". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).

Snapshot provider error (0xE0008516): Resources specified for snapshot do not have any valid data on them. Check if files were deleted or renamed.

Check the Windows Event Viewer for details.

---------------

If I uninstall the BackupExec Agent software from the Exchange server and re-push it from the Backup server the backup will work once and then fail again with above error when re-run.

'Vssadmin list writers' shows to 'Microsoft Exchange Writers' both of which are stable with 'No errors'. On occiasion though the first has displayed 're-tryable error' but even then the backup has worked once.

Does anyone have any idea? Or even why the re-installation of the agent fixes the backup initially? I have not been restarting the server at the same time.

Any pointers would be appreciated.

Environment :

Backup
BackupExec 2010 R3 (Patched up to Hotfix 195395)
OS - Win 2008 SP2 (Fully patched)

Exchange
Exchange 2007 SP3 (Latest patches)
OS - Win 2008 SP2 (Fully Patched)

 

 

 

 

 

 

 

 

 

 

Operating Systems:

Comments 13 CommentsJump to latest comment

pkh's picture

Check that you have properly installed the Exchange agent licence

http://www.symantec.com/docs/TECH140368

and also try this solution

http://www.symantec.com/docs/TECH63845

RJKWC's picture

Hi Pkh,

Thanks for the links

Re. http://www.symantec.com/docs/TECH140368 - This server has been in place for several years with the exchange agent installed. Unless there is someway the license can just corrupt I dont think this is valid.

Re. http://www.symantec.com/docs/TECH63845 - I've already worked through these possibilites - other than call Symantec support direct which I'm trying to avoid. This is our core exchange server and I can't be rebooting it constantly. That said, I have restarted on several occasions and the error re-appears. The 'list VSSadmin writers' has at no stage not displayed the Exchange writer.

I'm trying to understand how re-installing the agent enables the backup to work once. Also, once the backup has run succesfully, if I try to browse the Exchange server using the BackupExec it takes around 30 minutes to display the Exchange server resources and they do NOT include the Exchange 'Information Store' details. It's as if it has lost the abiltiy to recognise the Exchange resource.

Thanks

 

 

 

 

 

 

pkh's picture

I can appreciate that your Exchange server has been around for a long time,  but maybe you can try uninstalling the Exchange licence from the media server, restart all the BE services and then re-installing the Exchange licence.  It is a long shot but worth trying since this has no impact on your Exchange server.

RJKWC's picture

Yep fair enough  - will give it a go now and re-run the backup. Will let you know.

Thanks

sbora's picture

This issue seems to be matching with issue reported in following technote:

http://www.symantec.com/docs/TECH191085

To confirm you can either check the beremote debug log on Exchange server or restart Backup Exec Remote agent service on Exchange server in between the backups.

If the issue matches then you can either continue with the workaround till the fix for this issue is released OR you can contact support if you want orphan (pre-release version of the fix) fix for this issue.

 

RJKWC's picture

Hi Sbora,

Thanks for that - I've read through the article.

Unfortunately more often than not I've found trying to stop the Backupexec Remote Agent service 'locks' while 'Stopping' after a succesfull backup. It is then impossible to kill the 'beremote.exe' process without restarting the server. If you know a way to kill 'beremote.exe' when standard tools such as  'kill' and 'taskkill' refuse to do so I would be genuinely interested as that would be a great help. The only way I've been able to get the backup to work again is to uninstall on the Exchange server and then re-push installation from the backup server (as I said earlier this doesnt require a restart to work which mystifies me a bit)

I will schedule some downtime for the server and then try restarting the service with debugging enabled again.

Do you know if there is a pre-release version ready if this does turn out to be the issue or when the next fix release will be made available?

Thanks again.

 

 

 

 

sbora's picture

The pre release version of the fix is available with backline support team. You can contact support team, create a case and then have the case escalated to backline team to get the fix.

lmosla's picture

Hi,

Do you have the Microsoft Exchange tools installed on the media server (the updated to the same level as Exchange)? I have seen serveral instances in which backups and restores were working but then failed until this was installed.

Make sure the Volume Shadow Copy service is Stopped and set to Manual on the Exchange server.

Please check Windows Event logs for errors that occur at the time of the Exchange Backup job.

Check out the following document that describes this issue and a solution.

http://www.symantec.com/business/support/index?page=content&id=TECH143084

 

 

RJKWC's picture

Hi LMosla,

Yes the tools are the installed and are the same level.
Yes the VSC service is stopped and set to manual
There's nothing relevant in the event logs.
Not sure how the the link you've suggested describes the issue - as I stated previously at no time does the 'Exchange Writer' not appear and I'm not seeing that error code.

Thanks

 

 

 

RJKWC's picture

Sbora,

Restarted services and re-enabled debugging on the Exchnage server and can see these entries in the debug log -

[6548] 03/05/13 01:27:45 [fsys\shared]        - ese command 22 timed out
[6548] 03/05/13 01:27:45 [fsys\shared]        - SetOptions returned ffffffff -> (timeout)
[6548] 03/05/13 01:27:45 [fsys\shared]        - SetOptions error releasing options 6 -> (null)
[6548] 03/05/13 01:27:45 [fsys\shared]        - ESE07, failed to set options, 0x80004005
[6548] 03/05/13 01:27:45 [fsys\ese]           - AddESE_DLEs( )
[6548] 03/05/13 01:27:45 [fsys\ese]           - AddESE_DLEs for sever name Server_Name.White.com
[6548] 03/05/13 01:27:45 [fsys\shared]        - ESE07 process not ready
[6548] 03/05/13 01:27:45 [fsys\ese]           - E2007 GetStorageGroups failed with hr = 0x80004005 for machine = NULL
[6548] 03/05/13 01:27:45 [fsys\shared]        - Monad RPC timeout 300000
[6548] 03/05/13 01:27:45 [fsys\shared]        - EseProcess::Init: OpenThreadToken successful
[1456] 03/05/13 01:28:47 [fsys\shared]        - ese command 23 timed out
[6548] 03/05/13 01:33:45 [fsys\shared]        - ese command 22 timed out
[6548] 03/05/13 01:33:45 [fsys\shared]        - SetOptions returned ffffffff -> (timeout)
[6548] 03/05/13 01:33:45 [fsys\shared]        - SetOptions error releasing options 6 -> (null)
[6548] 03/05/13 01:33:45 [fsys\shared]        - ESE07, failed to set options, 0x80004005
[6548] 03/05/13 01:33:45 [fsys\ese]           - AddESE_DLEs( )
[6548] 03/05/13 01:33:45 [fsys\ese]           - AddESE_DLEs for sever name Server_Name.White.com
[6548] 03/05/13 01:33:45 [fsys\shared]        - ESE07 process not ready
[6548] 03/05/13 01:33:45 [fsys\ese]           - E2007 GetStorageGroups failed with hr = 0x80004005 for machine = NULL
[6548] 03/05/13 01:33:45 [fsys\spsv3]         - checking for SPS evidence on Server_Name, in Server_Name
[6548] 03/05/13 01:33:45 [fsys\spsv3]         - checking for SPS evidenc: key opened
[6548] 03/05/13 01:33:45 [fsys\spsv3]         - checking for SPS evidenc: ret = 0
[6548] 03/05/13 01:33:45 [fsys\spsv3]         - checking for SPS evidenc: WOW key opened
[6548] 03/05/13 01:33:45 [fsys\spsv3]         - checking for SPS evidenc: ret = 0
[6548] 03/05/13 01:33:45 [beutil]             - Input Error (       0) for Type: (43)

The backup did complete but the issue is there as I cant see Exchange components through BackupExec again.

Based on the link you gave me I guess I need to call Symantec support.

Thanks again for your help with this.

 

 

 

 

sbora's picture

Yes it matches with the issue. Please create a support case so that we can provide you pre release fix. You can email me the case id once created so that I can have it escalated to backline team immediately.

RJKWC's picture

 

Hi Sbora,

Since we raised this issue we have purchased and upgraded to BackupExec 2012. However, the exact same issue remains.

Could  you confirm if there is a hotfix for 2012 too and I will get in contact with support?.

Thanks,

Roy

 

 
sbora's picture

Hello Roy,

Yes this issue is present in BE 2012 as well. Please contact support to get orphan fix (pre-release fix) for this issue.

Thanks,
Sandesh