Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange 2007 Backups fail with BE 2012

Created: 20 Nov 2012 | 4 comments

Hi,

I installed a new Exchange 2007 server and backups fail to a new backup server. Backing up the old Exchange to a old Backup Exec server works. So the issue is with the new exchange and the new Backup Exec server.

All OS, Exchange and BE are fully patched.

BE server has local disks 2Tb and 10Tb. Exchange has 300Gb SAN-disk at the moment.

I receive this error: 

Unable to complete the operation.  The following error was returned when opening the Exchange Database file:  '-546 The log file sector size does not match the sector size of the current volumn. '

I'm aware of article http://www.symantec.com/docs/TECH50820 but the information in it is not clear or my issue is something else.

Article says that Bytes Per Sector need to be identical, and mine are. The article does not talk about any other value.

Disk on BE2012 server:

Bytes Per Sector  :               512
Bytes Per Physical Sector :       4096
Bytes Per Cluster :               65536
Bytes Per FileRecord Segment    : 1024
 
Disk on Exchange 2007:
Bytes Per Sector  :               512
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024
 
However, backing up the Exchange to a temporary BE server with 1.4Tb SAN disk works fine.
Bytes Per Sector  :               512
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024
 
Why is this? The article talks about bytes per sector, not the other values. Temporary BE server and the new Exchange have identical values, but they shouldn't matter according to the article?
 
  1. Is this the same issue as described in the article or somethin else?
  2. Will I have this issue with Exchange 2010/2013, to which I'll be upgrading later?

Thanks,

Petrus

Comments 4 CommentsJump to latest comment

Colin Weaver's picture

If the disk on the BE server that has a 4096 byte per physcial sector size is your Disk Storage target for the Exchange backups then it is possible this could be the cause. This sector size is not officially supported by Microsoft for Windows 2008 R2 and earlier (apparently it is in Windows Server 2012) and they can cause problems with the VFF mount used for GRT operations.

You can sometimes format larger disks with a 512 bytes per sector compatibility mode, it might be worth trying this if it is possible for your disks. Before you do this though I'd suggest getting a USB disk that is 2TB or less, making sure that USB disk is not using the 4096 bytes per sector and is formatted with NTFS and then plugging this into the server and using this disk as disk storage for a test job. If it works it is not Exchange, or Backup Exec but is the current disk storage and will almost certainly prove it is the bytes per sector causing the issue.

Chunda's picture

For info I've been having a similar issue when we switched from backing up to tape to disk when are Exchange 2007 server was running under Hyper-V in a VHD, and the backup would not work to a normal SATA 500Gb drive.

The GRT needs to do some work on the Backup Exec server to perform the GRT process (for tape backups this is done on the exchange server instead, so uses the normal drives, so no issue). To get around this we needed to create a VHD file on the Backup Exec server and mount this, then using the OnHostTemp registry setting as per the aricle we pointed Backup Exec to use this VHD drive, so all the drive parameters would match, and it worked.

Might not be a solution for your problem, but helped out in my case... and I found your problem trying to solve mine.

Cheers
Chunda

Share and enjoy

Gurvinder Rait's picture

Even though the error is different please try below steps from this article : http://www.symantec.com/docs/TECH166840

1) On the Media  Servers, click Start >> Run and type "regedit".  Click OK.

2) In the Registry Editor, navigate to HKLM\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\Exchange.

3) Right click and add a new String Value, "OnHostTemp".

4) Right click and set the value of OnHostTemp to "c:\temp".

5) Restart all the Backup Exec Services and run the backups

If C temp doesnt work, try to provide the other drive path.

CraigV's picture

...a really old post that the poster above you brought up again with a possible solution of his own. No response from the OP in 2 months.....wink

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...