Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange 2007 GRT Catalog Operation Slow

Created: 13 Jun 2012 | 13 comments

The backup job size is 184GB and takes around 8 hours to complete (386.02 MB/min) . The catalog job is the same speed but the size is 320GB or in the case of the current job it is 371GB and growing and has been running for over 24hours.

We have a 5 year old Dell PowerEdge 1850 (Media Server) with network team of two 1Gbps connected to the same switch as a HP D2D StorageWorks Backup System model D2D2503i that is also teamed with a LACP trunk.

Im new to Backup Exec 2012 and i don't recall Backup Exec 2010 creating a seperate backup job and a seperate catalog job for GRT backups?.

Our email server is at a seperate site from the PowerEdge and HP D2D via 100Mbps circuit, but I am not sure if the catalog processing is done locally?

Unfortunately I don't have a great baseline of speed to know if 386.02 MB/min is even that good, as to me it seems pretty slow?

Why is the size of the catalog job so big?

If these questions can be answered and any additional help offered, we would really appreciate it.

Thanks

 

 

 

Comments 13 CommentsJump to latest comment

CraigV's picture

Hi,

 

BE 2012 SP1a is out, so your first port of call is to update to that.

Once done, reboot your media server and try the backup again. Check your AV and make sure that it isn't actively scanning the BE services, and if so, put in exclusions for them.

BE 2012 has changed the way backups are run, and I think that your situation where you have 2 jobs is by design.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Sagar Walambe's picture

Are the transaction log size too large? You can try running a Non-GRT backup of Exchange to flush the transaction logs before re-running the Exchange 2007 GRT job.

http://www.symantec.com/docs/TECH182919

Hope this will Help!

 

CabarrusHealth's picture

Thanks for the two replies. I went ahead and upgraded to Service Pack 1at and restarted the server and updated the email server agent and rebooted the email server and the performance hasn't changed. I also looked over the antivirus and could not see an issue. I don't have a problem running a full backup and then a GRT backup and i tried to do this last night but the logs did not get truncated. For the selection I chose "Microsoft Information Store" which included three storage groups underneath it. For the Microsoft Exchange options I had GRT and Perform a "consistency check" unchecked and the High Availability Server set to the recommended setting. The event I get below which appears to indicate the backup job i performed was not a "Full" backup job, but i don't see an option in Backup Exec 2012 to indicate anything else but a full back for Exchange./ thanks

Log Name:      Application
Source:        MSExchangeIS
Date:          6/15/2012 6:32:41 AM
Event ID:      9781
Task Category: Exchange VSS Writer
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      computername.domain.com
Description:
Exchange VSS Writer (instance 3f3cbd60-c119-42be-9dfc-a70b693e24be:10) has successfully completed the copy or differential backup of storage group 'Second Storage Group'. No logfiles were truncated for this storage group.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchangeIS" />
    <EventID Qualifiers="16425">9781</EventID>
    <Level>4</Level>
    <Task>41</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-06-15T10:32:41.000Z" />
    <EventRecordID>973209</EventRecordID>
    <Channel>Application</Channel>
    <Computer>computername.domain.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>3f3cbd60-c119-42be-9dfc-a70b693e24be:10</Data>
    <Data>Second Storage Group</Data>
    <Binary>436F707900</Binary>
  </EventData>
</Event>

Sagar Walambe's picture

In order for Exchange to commit / flush / truncate the logs, all of the Databases of the Storage Group must be backed up together.

http://www.symantec.com/docs/TECH139647

In BE 2012 the first backup method is full and then incremental is by default,you can eiher remove incremental or add differential to the full backup.

 

CabarrusHealth's picture

thanks for the quick reply. i selected "one time backup" which i assume is incremental by default?

One other question you might know the answer to:

I assume "advanced open file" - Use snapshot technology should be unchecked?

 

 

 

Sagar Walambe's picture

One-time backup is copy backup for exchange databases in BE2012 and will not flush transaction logs. The purpose for one time job is totally different, check out the below technote.

http://www.symantec.com/docs/TECH187838

You will have to create a new backup job for your exchange databases.

 

Sagar Walambe's picture

We use VSS snapshot for taking a exchange database backup anyway, so you may uncheck this option.

CabarrusHealth's picture

The slowness appears to be related to my Storageworks D2D unit. I used a share on Direct Attached Storage on the Media Server and I got 6,127.61MB / Min which is 20 timers faster then the speed i was getting backing up to a CIFS share on the D2D unit. I will contact HP, but if anyone has suggestions, that will be great.

 

thanks

CabarrusHealth's picture

When the HP StorageWorks D2D2503i was originally released it could just function as a Virtual Tape Library and a firmware added NAS functionality. I went ahead and had my Exchange 2007 GRT backup job use the Virtual Tape instead of NAS and I don't see a Catalog job run but it appears I can restore individual items. Could someone verify with me the backup of Exchange via GRT runs a catalog job via back to a CIF share but this seperate job isnt needed when using a tape ?

thanks

Sagar Walambe's picture

If I understand your query correctly then Catalog jobs will not appear in the jobs menu you can check the status in the job history.

Hope the issue is resolved by now.

 

CabarrusHealth's picture

Im still having the issue of backing up our Exchange 2007 with GRT to our HP D2D2503i unit. Our backup job is 201GB and this completes at 504.08 MB/min in under 7 hours but then a catalog job runs which takes a very long time. I attached a screenshot and so far it has been running over 24 hours. I saw this post: https://www-secure.symantec.com/connect/forums/backup-exec-2012-exchange-disk and i am reading that the catalog job allows us to use the search and restore feature. I know when i restore email in a granular fashion I can either simply browse or search so I am wondering if I can force the catalog job to not occur can i then just use the browse function?

Any feedback would be much appreciated. thanks

 

catalog.JPG
CabarrusHealth's picture

Im just following up to see if anyone can help me with this one?

 

thanks

Sagar Walambe's picture

Hi,

I would suggest to select the entire information store and take Non GRT backup first( if possible try it on a disk storage to check the perfomance) and then try the GRT enabled backup.

 http://www.symantec.com/docs/TECH139647

Thanks