Video Screencast Help

Exchange 2010 DAG backup issue

Created: 22 May 2014 | 8 comments

Hello. I've got a strange backup problem (Backup Exec 2012 SP4 with hotfix 215906 and 216746). I do full backup once a week and incremental backups every 6 hours and use GRT. Everything was OK until about 3 weeks ago. Full backup works fine but incremetal backups work only for 3-4 days. After that Backup Exec starts to fail incremetal backup of one database with the error  V-79-57344-862 - The Backup Exec Agent for Microsoft Exchange was not used to create the last full backup of this database.  You must use the Exchange Agent to run a full backup before you run a differential or incremental backup. And another error is 'JET_errDatabaseDirtyShutdown This error is obsolete and has been replaced by JET_errDatabaseDirtyShutdown. ' But there are no problems with the database. It mounts and works OK. The members of the DAG weren't even rebooted. All other databases (the second mailbox database and 2 public folders databases) backup perfectly. If I make full backup again this fixes the issue for another serveral days.

Operating Systems:

Comments 8 CommentsJump to latest comment

VJware's picture

Do ensure AOFO is disabled in the backup job. Is there any other backup application or internal backup being run ? Is the DAG virtualized or physical servers ? (If virtualized, is the VM itself being backed up)

Try recreating the entire backup job. Do run eseutil /mh against the specific DB to check the last backup status (post a failure).

AndrewSkull's picture

1. AOFO was enabled. When this problem started to appear, I've disabled it, but nothing changed.

2. No. Only Backup Exec.

3. Physical servers.

4. I'll try to recreate the backup job.

5. To use eseutil /mh I need to dismount database. I'll try this after the work hours.

VJware's picture

Just one other thing. After disabling AOFO, a full backup needs to be rerun first and not an incremental.

AndrewSkull's picture

Well, after diabling AOFO there were thee full backups.

AndrewSkull's picture

I've dismounted thу database to check the status:

  State: Clean Shutdown
  Log Required: 0-0 (0x0-0x0)
  Log Committed: 0-0 (0x0-0x0)

Previous Full Backup:
        Log Gen: 5020708-5020808 (0x4c9c24-0x4c9c88) - OSSnapshot
           Mark: (0x4C9C89,8,16)
           Mark: 05/21/2014 01:35:37

Previous Incremental Backup:
        Log Gen: 5031792-5032925 (0x4cc770-0x4ccbdd) - OSSnapshot
           Mark: (0x4CCBDE,8,16)
           Mark: 05/22/2014 06:38:02

Everything looks fine. I've made full backup. So we have to wait for incremetal backups.

AndrewSkull's picture

Hello again. The first incremental backup after full failed on that database with the same error. But if I dismount the databese it appears in clean shutdown state.

AndrewSkull's picture

Hello! I've recreated the backup job. Full backup succeeds, incremental fails on the same database with the same error. If I dismount the databse and run eseutil /mh it shown no errors and clean shutdown status. Any ideas? The last thing to do is to crate the new database and migrate users. But this problem can happen again.

VJware's picture

I would recommend to log a formal support case so that we can analyse (via debugging) why the incremental fails on that specific DB. There may be other alternatives to creating a new DB