Video Screencast Help

Exchange 2010 DAG backups don't seem to obey max_jobs

Created: 04 Oct 2012 • Updated: 04 Oct 2012 | 6 comments

Hello All,

I was wondering if anyone could shed any light on what is happening with my Exchange DAG backups. We have two mailbox servers, mbx-1 and mbx-2, in our DAG, which is called staffmbx. Each database is backed up under it's own policy so that I can run ad-hoc backups on a per database basis when necessary.

I was getting a lot of 196 errors and noticed that only one backup was running at a time. I increased the maximum jobs per client for the DAG (./bpclient -client staffmbx -add -max_jobs 2). That certainly allowed two concurrent jobs but it seems to override the max_jobs for each mailbox server such that both jobs can run on one mailbox server whilst the other sits idle; that not what I had intended.

Is there a way to keep the DAG maximum concurrent jobs at 2 whilst limiting it to 1 on each mailbox server whilst keeping each database backup in it's own policy.

Thanks for any help offered.

Regards,

Mark

Comments 6 CommentsJump to latest comment

Mark_Solutions's picture

You have set the max jobs for the DAG to 2 so you could also specifically set the max jobs to each mailbox server to 1 which hopefully will give you what you want

It amy however still get over-ridden by the other setting

I am surprise you have an issue here as many of my customers happily run several at the same time without issue

Hope this helps

Authorised Symantec Consultant . Expert Partner.

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Mark Newall's picture

Thanks for the suggestion. Alas, I have already tried that but with no luck.

Even if I allow more concurrent backups it won't balance the load between the two nodes, i.e. if I set the DAG max_jobs to 4, then all 4 could run on a single node rather than 2 on each.

Regards,

Mark

Mark_Solutions's picture

So just to confirm - if you add mbx-1 to the Master Servers client host properties - client attributes section and set its maximum data streams to 1 it still does more than 1?

Bit naughty that!

Authorised Symantec Consultant . Expert Partner.

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Mark_Solutions's picture

In that case i would raise a case with Symantec then - although you will need to have specified the names exactly as they appear when the jobs runs in activity monitor to make sure the settings run - so it may need a FDQN to properly take the setting

The only  other way is to have just one policy for each mbx server but that is not great if you get a failure or if databases fail over to another node

Keep us updated

Authorised Symantec Consultant . Expert Partner.

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Mark Newall's picture

Just thought I'd update you on progress with Symantec support on this issue.

Basically they said that what I wanted to do wasn't possible. You can only limit the number of jobs on the DAG, this overides the client setting.

On a positive note I am now running multiple jobs on a node simultaneously without any issues.

Regards,

Mark