Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange 2010 granular restore problems in NetBackup 7.5

Created: 08 May 2013 • Updated: 13 May 2013 | 5 comments
This issue has been solved. See solution.

Hi all,

 

I have a problem with exchange 2010 backup.

During this backup, I have the following messages:

 

5/7/2013 6:24:47 PM - Info nbjm(pid=3776) starting backup job (jobid=686) for client exchange01, policy CorreoGranular, schedule Full 

5/7/2013 6:24:48 PM - estimated 1403905 Kbytes needed

5/7/2013 6:24:48 PM - Info nbjm(pid=3776) started backup (backupid=exchange01_1367961887) job for client exchange01, policy CorreoGranular, schedule Full on storage unit DiskBackup

5/7/2013 6:24:48 PM - started process bpbrm (4828)

5/7/2013 6:24:58 PM - Info bpbrm(pid=4828) exchange01 is the host to backup data from    

5/7/2013 6:24:58 PM - Info bpbrm(pid=4828) reading file list from client       

5/7/2013 6:24:58 PM - connecting

5/7/2013 6:25:01 PM - Info bpbrm(pid=4828) starting bpbkar32 on client        

5/7/2013 6:25:01 PM - connected; connect time: 00:00:03

5/7/2013 6:25:06 PM - Info bpbkar32(pid=19672) Backup started          

5/7/2013 6:25:06 PM - Info bptm(pid=5532) start           

5/7/2013 6:25:07 PM - Info bptm(pid=5532) using 262144 data buffer size       

5/7/2013 6:25:07 PM - Info bptm(pid=5532) setting receive network buffer to 1049600 bytes     

5/7/2013 6:25:07 PM - Info bptm(pid=5532) using 30 data buffers        

5/7/2013 6:25:09 PM - Info bptm(pid=5532) start backup          

5/7/2013 6:25:09 PM - Info bptm(pid=5532) backup child process is pid 5996.4924      

5/7/2013 6:25:09 PM - Info bptm(pid=5996) start           

5/7/2013 6:25:09 PM - begin writing

5/7/2013 6:25:10 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Client for NFS service is either not installed or not running.

5/7/2013 6:25:14 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Error encountered while attempting to get additional files for Microsoft Information Store:\Mailbox30MB\Logs_1367961840\

5/7/2013 6:25:14 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Exchange granular restore from this image may not work.

5/7/2013 6:25:30 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Error encountered while attempting to get additional files for Microsoft Information Store:\MailboxIlimitada\Logs_1367961840\

5/7/2013 6:25:30 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Exchange granular restore from this image may not work.

5/7/2013 6:25:53 PM - Info bptm(pid=5532) waited for full buffer 637 times, delayed 1222 times   

5/7/2013 6:25:53 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Error encountered while attempting to get additional files for Microsoft Information Store:\Public Folder Database 0944063635\Logs_1367961840\

5/7/2013 6:25:53 PM - Error bpbrm(pid=4828) from client exchange01: ERR - Exchange granular restore from this image may not work.

5/7/2013 6:25:54 PM - Info bptm(pid=5532) EXITING with status 0 <----------       

5/7/2013 6:25:54 PM - Info bpbrm(pid=4828) validating image for client exchange01       

5/7/2013 6:25:57 PM - end writing; write time: 00:00:48

the requested operation was partially successful(1)

 

The job was successfully completed, but some files may have been

busy or unaccessible. See the problems report or the client's logs for more details.

 

NFS is installed and client for NFS and server for NFS services are disabled in the Netbackup server

I can’t restore individual mailbox

System version:

Exchange 2010 SP3

Windows 2008 R2 (Exchange server)

Windows 2008 R2 (NetBackup server)

NetBackup 7.5.0.5 with last updates

 

Best Regards

 

Alexander

Operating Systems:

Comments 5 CommentsJump to latest comment

Mouse's picture

Probably client for NFS is not running? Did you check firewall settings too? Maybe port used by NFS is blocked?

Marianne's picture

Seems you have standalone Exchange server, not DAG?

Please double-check NFS config.
Also, GRT needs more than just NFS - Correct user account is one of the requirements.

Please go through this checklist:
http://www.symantec.com/docs/HOWTO73076

These videos may also help (choose the one that matches your environment): 
 http://www.symantec.com/docs/HOWTO41825

Hope this helps.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Dyneshia's picture

To manully test NFS , please review and follow : http://www.symantec.com/docs/TECH124810  - How to manually test NetBackup Granular Restore Technology (GRT) NFS connections between media server and client

Ports 111 ( port map) ,  and 7394 (nbfsd )  need to be open.

Client for NFS should be running on all servers in the DAG

Server for NFS should  be listed but not running on the media server.

alexbc's picture

It works

I added the NetBackup services user in “mailbox for message level backup and restore” on the media server.

Moreover, I disabled client for NFS and Server for NFS services on the media server and server NFS service on the exchange server.

 

Thanks to all

Marianne's picture

Please select the post that helped you most and mark as Solution?

This action will close off the discussion, reward the person who pointed you in the right direction, and provide a quick link to other users with similar problems.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links