Video Screencast Help

Exchange 2010 OWA Search Archives displays string of characters instead of page

Created: 11 Jul 2014 • Updated: 11 Jul 2014 | 14 comments

We are currently running EV 9.02 on the server and have Exchange 2007.  We have our separate Exchange 2007 CAS servers that have the OWA extensions for EV installed and everything works well through outlook webmail internally and externally.  Regardless of internal or external location, users are sent directly to the EV server through the same url:  archive.domain.com 

We introduced Exchange 2010 in our environment including Exchange 2010 CAS servers with a CAS array configuration.  The environment while we migrate currently is webmail users hit the Exchange 2010 CAS servers first.  If they are a 2007 user, they are sent automatically over to the 2007 CAS servers as expected by Exchange and all is well.

I've gone through the setup for EV and OWA for 2010.  The extensions are installed on the 2010 CAS servers.  The ip addresses were updated in the Exchangeservers.txt file and the owauser.wsf script run.  I verified the registry to see the correct names and ports and addresses in place. If I log into outlook webmail with an exchange 2010 account, owa opens on the 2010 CAS servers as normal.  I see the see the Archive Explorer link and the Search Archives link.  When I click the Archive Explorer link, I receive a popup that lets me browse my archives.  If I click the Search Archives link, nothing happens the first time.  If I log out of webmail and log back in, then try clicking Search Archives, it opens in the right window pane with a long string of characters and numbers that looks formatted like:

1 DAGOODYEAR@domain.com DAGOODYEAR@domain.com EXMBX01 EXMBX01    V9.0.2.1061 65 0    0 1 1 0 1  14244616FEBED12468E170580BD3B3E191110000archive "archivename that i have access to" 9  1FF8B8091D97C19489DE0FF7894AAF6981110000archive "archive name I have access to" 9  

If I clear my browser cache and try again, the first time the search archives link does nothing.  Once i log out and log back into webmail, i receive the same string of information above.  If I right click on the page with the string above and select properties, it gives me a url that points to our ev server and my archive.  If I copy that url and paste it into a new browser tab, the search vaults page opens up without an issue.

The url is something like: https://archive.domain.com/EnterpriseVault/Searcho...

 

I verified all of the pre-reqs are configured on the Exchange 2010 cas servers.  I tried repairing the EV owa extensions, resetting IIS, and rebooting the servers.  I tried turning on logging in web.config for OWA but nothing stands out in the logs as a problem.  Any thoughts or things to check that I've missed perhaps?  It almost seems like it just can't display the remote url page correctly in the owa 2010 pane.

Operating Systems:

Comments 14 CommentsJump to latest comment

AndrewB's picture

can you enable logging in the owa config file on your exchange server, login with a new session and follow the same steps to recreate the issue, then post the log file here?

http://www.symantec.com/business/support/index?pag...

This will enable diagnostic logging for the Enterprise Vault OWA Extensions per CAS (default false):

<add key="EnterpriseVault_LogEnabled" value="true"/>

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

AndrewB's picture

can you reference this post and share in detail some of the answers to the troubleshooting that they did?

https://www-secure.symantec.com/connect/forums/no-...

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

dgoodyear's picture

I'll reference as much as I can from the other thread.  It's similar but in that case they have Exchange 2003 to 2010.

"the ExchangeServers.txt on the EV server contains all of the IP address of the CAS servers for exchange 2010 servers, frontend and backend exchange servers for exchange 2003?"

I've verified that the ExchangeServers.txt file contains all of the IP's of our CAS servers for Exchange including the ip of the CAS array (F5 appliance that we front some web services with).  EV in OWA for Exchange 2007 is still working fine.

"You have re-run the oawuser.wsf with the change made to ExchangeServers.txt above?"  

Yes, I've rerun this script with the changes and have restarted EV services and resync'ed mailboxes.

"Have you configured the web.config on the CAS servers ok? can you post the <AppSettings> section of the web.copfig? "

As far as I can tell the web.config is configured correctly.  Here is the AppSettings section:

    <appSettings>
        <add key="ConnectionCacheSize" value="100"/>
        <add key="MaximumIdentityArraySize" value="100"/>
        <add key="ShowDebugInformation" value="true"/>
        <add key="EnableEmailReports" value="false"/>
        <add key="PushNotificationsEnabled" value="1"/>
        <add key="PullNotificationsEnabled" value="0"/>
        <add key="MaxItemsInConversationExpansion" value="499"/>
        <add key="MaxItemsInConversationReadingPane" value="100"/>
        <!-- Configurable email address of where to forward ActiveSync log messages-->
        <add key="MailboxLoggingAddress" value="your email administrator"></add>
        <!-- MailTips Settings -->
        <add key="MailTipsMaxClientCacheSize" value="300"/>
        <add key="MailTipsMaxMailboxSourcedRecipientSize" value="300"/>
        <add key="MailTipsClientCacheEntryExpiryInHours" value="2"/>
        <!-- Message Prefetch related settings -->
        <add key="IsMessagePrefetchEnabled" value="true"/>
        <add key="NumberOfMessagesToPrefetch" value="0"/>
        <add key="PrefetchOnlyUnreadMessages" value="false"/>
        <add key="MaxMessagesInCache" value="500"/>
        <add key="MaxCacheSizeInMegaBytes" value="30"/>
        <!-- Client Side Data Collecting settings: (Range:0.0 - 1.0) (Accuracy:1E-5) -->
        <add key="ClientSideDataCollectSamplingProbability" value="1.0"/>
        <!-- RMS Template cache settings -->
        <add key="RmsTemplateCacheSizeInMB" value="10"/>
        <add key="RmsTemplateCacheExpirationInterval" value="01:00:00"/>
        <add key="EnterpriseVault_LogEnabled" value="false"/>
        <add key="EnterpriseVault_ResourceVersion" value="v9.0.2.1061"/>
        </appSettings>

 

"The user that you are testing, is the mailbox on the exchange 2010 mailbox server and is the exchange 2010 mailbox server being targeted for archiving?"

Yes

"Is this for internal OWA access or/and external?"

Both.  Internal and External OWA users are sent to the same url for EV.

"Enable the OWA logging on the CAS server and post the full EV OWA log file."

This was attached to my previous posting.

"for OWA 2010 if you double-click on a shortcut does the messages get retrieved OK?"

If I click Archive Explorer, I can open EV messages ok.  If i browse to old messages in my inbox that are archived, I can click on the "Enterprise Vault Archived Item. Click here to view this item" link and the message opens ok in a popup window.

 

I've been through the Install instructions again, which also include this doc for mixed CAS environments:

http://www.symantec.com/business/support/index?pag...

I also went through this link:

http://www.symantec.com/business/support/index?pag...

 

"Do you have the WebDAV URL set correctly as well? "

I think this is specific to Exchange 2007 and not 2010 per the Setting_Up_Exchange_Server_Archiving.pdf documentation.

 

AndrewB's picture

"for OWA 2010 if you double-click on a shortcut does the messages get retrieved OK?"

If I click Archive Explorer, I can open EV messages ok.  If i browse to old messages in my inbox that are archived, I can click on the "Enterprise Vault Archived Item. Click here to view this item" link and the message opens ok in a popup window.

"Is this for internal OWA access or/and external?"

Both.  Internal and External OWA users are sent to the same url for EV.

 

a couple follow up questions:

1. what happens if you double click on the shortcut instead of clicking on the link to "view this item"?

2. (for our testing purposes lets keep everything internal) the fact that you say that when you right-click on the search archives link in OWA, copy the url, and paste it in a new browser window and it works fine - leads me to wonder if it's something with Internet Explorer settings and not with the OWA config.

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

dgoodyear's picture

1) If I double click on the shortcut, the message opens like any other message, though it takes a few seconds longer, presumeably to restore the message and open it

2) As far as internal and external for webmail, there is not really any differentiation in our environment.  Internal and external users are all sent to the same VIP address.  I can't actually right click on the Search Archives and receive a copy url option.  I can copy shortcut but it is only "https://webmail.domain.com/owa/#" 

If I click on the Search Archives option so that it opens in the right pane of webmail (with the string of text instead of the correct page), I can right click on that string of text page and receive the correct url.  I'll try messing with some IE settings too. 

Merv's picture

Yes i agree with Andy - browser issue here ...looks to me like the integrated search asp page is just returning as text instead of being properly rendered. I've come across this in IE10.
Can you try viewing the page in compatibility mode? Or just add both your EV webapp url and owa to display in compatibility mode.

dgoodyear's picture

It looks like I'm already in compatibility mode as our domain is added as an intranet site and compatibility mode is enabled already for intranet sites.  I tried turning it off as well but haven't noticed anything different.  It sounds like we're on the right track.

Merv's picture

Add your owa external url too. Are you using IE10? Is your EV server running IE10? If not try accessing localhost/enterprisevault/searcho2k.asp via the EV server or owa via the EV server

dgoodyear's picture

I've tried forcing the external url with few IIS application settings: EnterpriseVault_ExternalWebAppUrl and EnterpriseVault_UseExternalWebAppUrl.  

 

I'm running IE 10.  The EV server is running an older version of 2008 (not R2 currently) and is not running IE 10.  I can open the localhost/enterprisevault/searcho2k.asp url from the EV server without a problem.

dgoodyear's picture

This definitely seems to be a browser compatibility problem with the owa extensions.  Playing around with IE settings and leaving browser mode on IE 10 but dropping the standards back to IE 8 the page seems to display correctly.  Starting at standards mode IE9 and up, it stops functioning correctly. 

The OWA extensions that are installed on 2010 are showing at v9.0.2.1061.  Maybe a newer version would help?  We'll be upgrading our EV environment before the end of the year but I will need to get this working in the meantime.

dgoodyear's picture

I tried upgrading the owa extensions on our Exchange 2010 CAS servers to 10.0.4 but that did not seem to make any difference.

Merv's picture

So its workaound now to use IE8 and that is the officially how it works IE only works in compatibility mode for IE 9 or 10 and that is why there is no issue on the EV server which is running IE8. I faced exactly the same issue, so the question is why isnt putting the URLs in there forcing it down to IE 8 compatibility? Probably something we are missing https/http...did you put in your OWA mail url too? I.e https://webmail.domain.com/owa?

dgoodyear's picture

The OWA url seems to work fine.  Even if I run under compatibility mode it still has no effect.  We were looking at an EV 10 upgrade soon, but I wasn't quite ready to expedite it.