Video Screencast Help

Exchange 2010 Transaction logs not deleting

Created: 13 Feb 2014 | 10 comments

BE2012 backing up two member DAG properly (circular logging off.) On job completion VSS on MB server generates log entry saying "VSS copy complete, transaction logs not deleted." VSS copy means logs not deleted. VSS full means logs should delete. I have other sample databases on each DAG server same thing happens. How do I get the trans logs to delete?  I see a way to force VSS copy in the freeze script but not force a full. VSS writer status shows no problems, DAG healthy. Properties of all databases show no Last Full Backup time and date either. Help!

Operating Systems:

Comments 10 CommentsJump to latest comment

sidd3009's picture

Do you have the Advanced Open File Option selected? Please refer to the following link to get details on it: http://www.symantec.com/business/support/index?page=content&id=TECH45295

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

Ananya Bhattacharya's picture

Hello TB342,

Additionally you can check http://www.symantec.com/docs/TECH156654 which also addresses the same issue with BE 2012 and Exchange 2010 DAG. Please let me know if it helps.

Regards,

Ananya Bhattacharya
Technical Support Engineer (Advanced Team)

Laurie_Downey's picture

If you need to flush the logs immediately to prevent the logs from possibly causing the server to crash, and address the root cause once logs have been flushed, then here is what you can do first:

 

  1. Create a new backup job not using any existing selection lists or templates
  2. Expand out the DAG from the selections list and select the DB in question
  3. From the devices tab point it to the device but leave the media set as default (Keep data for 4 weeks)
  4. From the Microsoft Exchange tab within the job properties un-check the option for GRT
  5. Also uncheck the option for consistency check
  6. From the Advanced open file tab select “Use advanced open file”
  7. Select the option for “Microsoft Volume Shadow Copy Service (Windows 2003 and later)
  8. From the drop down box select “System-Use Microsoft Software Shadow Copy Provider”
  9. Go back to the option at the top and un-check “Use advanced open file option”
  10. From the schedule tab select “run now”

Keep in mind this is a backup to be run one time only, as it is not advised to run Exchange backup without GRT selected as you lose the option to restore individual items. This is merely an attempt to immediately flush the logs

When you say the properties of the database do not shoe the date for the last full backup, are you determining that by running a PowerShell command, or by the going into the database properties via Exchange Management tools?

Laurie Downey

Backup Exec

Advanced Tech Support

Symantec Corporation

www.symantec.com

 

 

TB342's picture

Sidd - TECH45295 shows screenshots and options from pre-2012 BE, I do not see the options in 2012 you are referring to. The note says 

"When selecting Exchange data to be backed up: If in Backup Job Properties the Exchange server backup method is set to either Full-Database & Logs (flush committed logs), OR Incremental - Logs (flush committed logs), the Exchange database transaction logs should be flushed following the completion of the Exchange data backup."

This would seem to be my circumstance if these choices were in the 2012 GUI.

Ananya - same thing applies to you. 1566545 says

Even though the Exchange Backup DAG component is correctly selected, the backup job option "Information Store --> Backup Method" is set to Full-Database & Logs (Flush committed logs) or  Incremental Logs (Flush committed logs) and the job finishes with no errors, Exchange 2010 does not flush the logs.

I do not see these options in the 2012 GUI. Am I blind?

Laurie - I am not in that urgent need with circular logging on at this moment thanks. I am seeing the blank backup time using ESM not powershell.

I understand that VSS is supposed to delete the logs, but isn't BE supposed to tell VSS to do it? VSS says it was doing what it was told - make the copy and don't delete the logs.

Standing by for more comments thanks.

 

Laurie_Downey's picture

Go to the event viewer on the DB server and highlight application. scroll down to the time stamp from the backup job. Look for an event generated by ESS/MSExchangeXX for backup completion.

 (Something like: Event ID XXXX; Exchange VSS has successfully completed the full or incremental              backup of the Database )

If Windows has reported the backup as successful you will want to contact Microsoft to address why the logs are not being flushed. If the backup job has not reported  as successful, than I would advise opening a case to work with one of our support agents whom specialize in Exchange backups.

Laurie Downey

Backup Exec

Advanced Tech Support

Symantec Corporation

www.symantec.com

 

 

Ananya Bhattacharya's picture

You are right, BE 2012 does not have those options i.e., the 'Microsoft Exchange' screen does not give the option to choose the type of backup, it can only be chosen from the 'schedule' screen and full, incremental and differential can be chosen from there. In this case both successful Full and the subsequent Incrementals should be able to flush the logs.

 

Regards,

Ananya Bhattacharya
Technical Support Engineer (Advanced Team)

CraigV's picture

...I've never understood the 2 different messages given by Symantec techs, both here on the forum and on the phone. I have been advised NOT to use AOFO when backing up Exchange or SQL (Exchange logs didn't flush when I used it; SQL restores could not be redirected), yet this is advised of late here on Connect.

I'd go with the lesser of 2 evils and say that if AOFO is on, turn it off. I have personally had this issue, and the advice given after an official call was logged was to turn it off. If it isn't turned on, then stop the BE services and run a native Windows backup of Exchange to flush the logs.

Then try the job again.

If it is on, and you have Exchange and files in the same job, then you need to separate the files and folders from Exchange. 1 job uses AOFO, and the other does.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

TB342's picture

Craig

I can't run a native backup of Exchange cuz I'm on a 2TB partition.

I will test as you suggest and as Ananya says use scheduled instead of one time to see how it goes. I dead ended with self-diagnosing things on the VSS side of the house. Would have to get MS involved but there are no error messages generated, only that VSS did it's job so opening a problem report would seem off. Will advise thanks.

TB342's picture

OK I'm making progress. Seems like I was stuck on the strange affect on VSS of one time vs scheduled backups.

I have run two scheduled backups on my test info stores which are not part of the DAG. Each lives on a DAG member.

Both jobs deleted the trans logs thankfully. Of course I do not have circular logging turned on.

Craig I'm not much help in clarifying the AOFO option - I ran one job with and one job without and they both worked. It is confusing that the AOFO screen does not actually have a checkbox  "AOFO on" or "AOFO off" so I used the first checkbox "Use snapshot technology" and did not mess with any other checkboxes.

So now I'm on to backing up the DAG. This will take a while as it's about 450GB. Will report back what happens thanks.

 

 

 

 

 

Laurie_Downey's picture

Just to clarify, the suggested attempt to flush the logs by creating a new backup job would be done by creating a new job without using any existing job settings and selecting “Backup” when creating the job.

I apologize if I was unclear as to not select the option for “one-time backup”, as it will not flush the logs. Please let us know the results of the job when it’s completed.

Laurie Downey

Backup Exec

Advanced Tech Support

Symantec Corporation

www.symantec.com