Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange backup job fails with error '-546 The log file sector size does not match the sector size of the current volume.'

Created: 29 Aug 2013 | 21 comments

Exchange backup job fails with error '-546 The log file sector size does not match the sector size of the current volume.'

Some have posted here but there is no solution yet.  And I need it.

One have posted block size have to be 512 byte emulation instead of 4k.  This can't be true ???  Disk have beend formatted 4k for decades !!!

Stop refering to the registery patch.  It does not work.

Paul Jr

Operating Systems:

Comments 21 CommentsJump to latest comment

Donald Eady's picture

Is this a GRT enabled backup.. If so please try running a NON grt backup and then try running the GRT backup..

 

Please review 

http://www.symantec.com/docs/TECH205082

 

Edit:

If this resolves your current issue it is still suggested that you log an official support case as a permanent fix is still in the works

I hope this posting was helpful

  

Kunal.Mudliyar's picture

Hi Paul,

We at Symantec acknowlege this as an issue as it is mentiond in the :

http://www.symantec.com/docs/TECH205082

I would encourage you to log a support ticket for the case and quote the etrack no 3152688

Thanks.

 

Edit :

Sorry Donald your post was not visible so the information got replicated.

Technical Support

Symantec

Paul Jr's picture

I will do a full without GRT tonight.

I will not log a support ticket with Symantec.  Not a single time in the last 25 years it has been successfull to me.  I was told to do things by techs , wait days, and finally always had to re-install completly from scratch.  AND re-inventory as well 40 tapes each times. I must have done that hundreds of times now :) I had always better luck with forums anyway.  Also, I stopped my subscription with Symantec BUExec recently, since it was only an expense with no value.  Symantec being unable to answer when they will fix the whole "BUExec2012" issue.  Support for windows 2012 and Exchange 2013 being absent for an ethernity, I had no choice but to move elsewhere.

I kept BUExec as a plan "C" (i.e. not even plan B") backup.  I use it only for "relatively easy" granularity recovery since my "reliable" source of backups now is remote snapshots in VMWare via VEEAM, and with backup features found in SQL Server and Exchange 2007.

Back to my topic, I do not do incremental backups.  Only full to disk then duplicate to tape daily.

I recently installed Active Directory Lightweight Services.

I also recently install latest BUExec Service pack.  I strongly think it is the source of my problem. 

Yes, I completely re-install BUExec.  Again.  Same error.

I will do a GRT BU tomorrow.

Paul Jr

Donald Eady's picture

I can understand your frustrations and apologize for your past experiences... I would suggest that if your not going to log a support case you at least subscribe to the email notification of the tech-note that Kunal and I provided so that you are made aware when a permanent fix is released. 

I hope this posting was helpful

  

Paul Jr's picture

Non GRT Backup worked tonite.

I'm performing a GRT BU now and keep you posted if it works afterward.

Paul Jr

Donald Eady's picture

Awesome.. Thanks for the update please do update when the job has completed. 

I hope this posting was helpful

  

Paul Jr's picture

Updates are done by a paranoîd here.  Everything is updated on a daily basis.  Firmware, drivers, OS, et.c.

The last backup with granularity on has failed.

So it is either related with the installation of Active Directory Lightweight Services or the last BUExec service pack.

We have migrated our storage from a 6 TB volumes to a 16 TB volume last week.  Block size are now 8k and were 4k before.  At least for the last decade. 

Paul Jr

Paul Jr's picture

I put the granularity off (non GRT) on our Exchange server again.  Backup to disk was ok.  Duplicate to tape failed with the same -546 error.

Putting granularity to off is consequently not an indefective workaround.

Full BU are scheduled for tonite.  We will see tomorrow.

 

Paul Jr

VJware's picture

Hate to be a stickler, but 4k native sector size support has been only with newer windows os'es (windows 2012 and windows 8)

Pls run the following command against the drives (where the temp staging area is located & the destination disk storage)

fsutil fsinfo ntfsinfo x:

What is the value of bytes per sector field ?

Paul Jr's picture

Hello VJware.

I use Raid level 60 on a 12 disks JBod box.  IBM branded, but manufactured by Engenio that was just purchased from LSI Logic by Netapp. I.e. it is using very standard Velocity SAS splitter.  My adapter is a very recent LSI Logic 9286CV-8e. OS is Windows 2008 R2 Enterprise.

I scratch my head on this one.  When I formatted this disk using windows, I could not use standard 4k cause it would eventualy failed in Windows 2008 r2.  Volume was apparently too large for 4k Allocation Unit. I specified Allocation unit size of 8192.  I remember cause I've done only few days ago. And I stubornly tried many times with "Standard" Allocation Unit.  Maybe I'm confusing things here,  see results of your requested command bellow :

NTFS Volume Serial Number :       0x06969e00969df103
Version :                         3.1
Number Sectors :                  0x00000007467befff
Total Clusters :                  0x00000000e8cf7dff
Free Clusters  :                  0x00000000c96dd24a
Total Reserved :                  0x0000000000000040
Bytes Per Sector  :               512
Bytes Per Physical Sector :       4096
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length :           0x00000000011c0000
Mft Start Lcn  :                  0x00000000000c0000
Mft2 Start Lcn :                  0x0000000000000002
Mft Zone Start :                  0x00000000000c0cc0
Mft Zone End   :                  0x00000000000cc840
RM Identifier:        8A0FF8DF-0E47-11E3-BE8C-001B213C6CB0

Capture.PNG
Paul Jr's picture

Well.  Backups went ok without an error tonite.

If anyone in the crowd has a theory ;) :)

BUT my SQL server backup report that used to be in HTML format is now in plain text which is simply unreadable by human means.  An SQL that normaly has no exception has now the "Transaction Log" infamous mistake eventhough it is not set to keep transaction log.

 

Anyway.  I will keep ypu posted if backups shows error -546 tomorrow.

Paul Jr's picture

NO error -546 this morning.

Ok.  I have a form of full backup for now.  But no granularity recovery.

Next question is:  When that issue will be resolved ???

Paul Jr's picture

Here's something new.

Now Exchange Backups fails with error -546 even if granularity is set to "off" since at least one week ...

So ... No form of Exchange BU from Symantec these days. ;(

 

 

Paul Jr's picture

OK

I received a note this week requesting from Symantec support I install SP3 on BUExec. 

Was supposed to solve the issue.

I installed it on the backup server.  Pushed all updates to all server.  Rebooted them all. And did BU without GRT for the first day.  It worked as expected.  The day after, I enabled GRT.  It failed on Ms Exchange with the same -546 error.

 

Still have the issue. :(

 

Paul Jr

Paul Jr's picture

Ok.  Here is the topo.

Symantec tech says this issue is unresolvable and will never be fixed.

Those who needs granularity backup, look elsewhere than Symantec.

Sorry to write this, but Symantec have become incapable of anything.

Paul Jr

Back-up to the wall's picture

I ran Live Update a few days ago and it told me that Service Pack 3 was available...so I installed it.

My Exchange Backup, with GRT, failed. It had been working fine prior to this Service Pack.

It is inconceivable to me that "this isue is unresolvable and will never be fixed"! If they broke it, they can fix it. After all, they had it working once.

 

I am a consultant and I have 5 clients using Backup Exec. That is 5 renewals that won't happen if this issue doesn't get the attention it deserves.

PJR's picture

I'm not sure how much of the same here ...

I upgraded to SP3, but I also changed the storage to something much bigger.

Since then, I have this GRT error. It has been like this for month now.

My renewal is also on standby since the only workaround is another vendor. Or upgrade evrything to 2008 R2. 2008 R2 licences being the same price as 2012. I have to buy cals too. Very expensive move I would otherwise not need.

I have to backup with no granularity which means I cannot recover a single mail anymore. I will not risk to restore the whole email database just for a single mail.

I have a case open for this.

Good Luck

Paul Jr's picture

Absolutely nothing happening.  I had to create a separate backup job to tape to have the Granularity option.  It has been months since I started to have this issue.

I'm more convince then ever Service Pack 3 is to blame.