Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange database backup is failing from time to time

Created: 30 Jul 2012 • Updated: 27 Aug 2013 | 12 comments
This issue has been solved. See solution.

Environment:
Windows Server 2008 R2 Standard SP1 with Exchange 2010 SP2 UR3
Windows Server 2008 R2 Standard SP1 with Backup Exec 2012 SP1

I ran Exchange database backup twice a day. One full and one incrementel. It's running successful for weeks. Then the full backup jobs fails with following error message:

 

Job Completion Status 
Job ended: Samstag, 28. Juli 2012 at 05:33:57
Completed status: Failed
Final error: 0xe00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.
Final error category: Resource Errors
 
For additional information regarding this error refer to link V-79-57344-759
 
 
Errors 
Click an error below to locate it in the job log
Backup- \\MAIL.AGENTURENNETZ.DE\Microsoft Information Store\esV-79-57344-759 - Unable to complete the operation for the following reason: VFF Open Failure.  This can be caused by low memory or disk resources.

 

I didn't recognized it immediately. So Backup Exec keeps backing up the next days, where all backups were successful. Then an error again:

 

Job Completion Status 
Job ended: Montag, 30. Juli 2012 at 02:31:26
Completed status: Failed
Final error: 0xe00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.
Final error category: Resource Errors
 
For additional information regarding this error refer to link V-79-57344-759
 
 
Errors 
Click an error below to locate it in the job log
Backup- \\MAIL.AGENTURENNETZ.DE\Microsoft Information Store\agenturgruppeV-79-57344-759 - Unable to complete the operation for the following reason: VFF Open Failure.  This can be caused by low memory or disk resources.
 
 
The Exchange server is having enough disk space and has 32 GB RAM. Why did this error occur? And whats the reason, why it's occuring only from time to time?
 
Thanks in advance.

Comments 12 CommentsJump to latest comment

simonk27's picture

Thank you.

I'll try that this night.

Just so you know. I'm backing up System State every day, too. There is no error. It is only the Exchange databases.

pkh's picture

Make sure that AOF is off in your job that backs up Exchange.

simonk27's picture

In Advanced Open File options, I uncheck "Use snapshot technology", "Process logical volumes for backup one at a time" and "Enable checkpoint restart"? All three? Correct?

CraigV's picture

You could just deselect "Use snapshot technology" and "Enable checkpoint restart". The other option is reliant on using AOFO in the job.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

simonk27's picture

Thank you. I'll try that.

Is there some kind of documentation, where it is stated not to use AOFO?

CraigV's picture

...the Admin Guide.

If need be, you can consider splitting your jobs off from each other...use AOFO when backing up normal data, and don't use it when backing up DBs. Follow my article below:

 

https://www-secure.symantec.com/connect/articles/backing-databases-and-files-same-tape-separate-jobs-using-backup-exec

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

David Palmerston's picture

CraigV -

Interesting and thoughtful article...

Can you update your 2010 article for BE2012?

How could we handle the separate selections on the same server with BE2012?

 

CraigV's picture

...I will look into both David, thanks for the compliment!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

simonk27's picture

Thanks for the interesting article, though it is best practise to run database backup and file/system state backup seperately.
In Admin Guide I could't find anything about not using AOFO, when backing up (Exchange)databases.

simonk27's picture

Guys, thanks for your comments.

I re-registered VSS and disabled AOFO yesterday night. The first backup did run successful. I will observe.

mamilo's picture

Thank you Craig for this instructions. Like David said I also do not see a way how to create different selection lists for a single Server in BE2012.

One other question I have: How to deal with the .edb, .stm and log files. Should they be part of the DB-Job or part of the Files- and System State job or should they be excluded?

Thanks for your support