Video Screencast Help

Exchange Mailbox Archiving task not working for any Outlook clients

Created: 03 Oct 2012 • Updated: 03 Oct 2012 | 10 comments
This issue has been solved. See solution.

Hi, we have recently deployed and configured EV 10.0 onto our network, with Outlook 2007 clients and Exchange 2010.  We seem to have everything working fine and are able to get test users to manually archive items into vault successfully, within Outlook 2007.

We are now looking to run the Exchange Mailbox Archiving Task, so that we can have Outlook clients automatically archive items older than 6 months automatically.  My assumption was, to first run the Provisioning Task successfully, followed by the Exchange Mailbox Archiving task.  However, nothing seems to happen when we run the Mailbox archiving task for some reason.  The 2 test clients do not have any of their emails archived from the ran task.  When we try to run the Exchange Mailbox Archiving task in report mode however, it seems to run fine and even gives us a log.  But when we run it in Archive and Shortcut processing mode to all Enabled MAilboxes, nothing seems to happen.

My question is, am I missing something here to get the Exchange Mailbox Archiving task to run correctly and automatically archive the items older than 6 months? I've checked the guides, etc and the steps seem to be correct; however it not working for us successfully.  Any help would be appreciated.  Thanks in advance

Discussion Filed Under:

Comments 10 CommentsJump to latest comment

LCT's picture

The best way to se what is happening is to enable the dtrace and run the archive task by right-click and Run-Now.

Capture the dtrace and post it here. take out private info if need be.

TonySterling's picture

Silly question, did you enable the mailboxes?  In your report that was created what is the mailbox status?  Is it Enabled or New?

If it is New then the mailboxes were not enabled.

belnetsolutions's picture

LCT, Please see attached log file. Hopefully it attached correctly because was recieving error upon upload.

TonySterling, yes we enabled both test mailboxes, which are older mailboxes. When we ran the task in report mode, the user mailbox said "enabled" and the other admin mailbox said "suspended" for some reason. However both mailboxes were indeed enabled when we ran the task in report mode as well as archive and shortcut mode. Thanks

TRACE_LOG_03102012_115301.2.txt 23.07 MB
TonySterling's picture

For the one that is Suspended I would recommend you disable them and then go through the Enable Mailbox Wizard again.  There is an option to enable immediately or suspend the mailbox, make sure you leave enable immediately checked.

Until the mailbox is un-suspended items will not be archived.

Rob.Wilcox's picture

Also as Tony says...  That 'suspended' status means it is suspended from scheduled archiving..  manual archiving within Outlook will still work (which you said in your original post that it does)

LCT's picture

Other than the suspended mailbox that you mentioned. The dtrace shows that none of the messages are eligible for archiving.....

At the end of the trace...

412669 11:53:48.203  [5520] (ArchiveTask) <3068> EV:M {CArchivingAgent::WriteWorkItemsToQueue:#6987} Finished running through archive-eligible items in mbx : [0x0]

Just before the lines above

396438 11:53:46.109  [5520] (ArchiveTask) <3068> EV:L :CArchivingAgent::IsEligibleForArchive(/o=ecbalaw/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Brian Macaluso) |The message titled: Re: Remote Desktop will not be archived as its inactivity period has not expired  |
396439 11:53:46.109  [5520] (ArchiveTask) <3068> EV:M :CArchivingAgent::IsEligibleForArchive() |Exiting routine |

Beginning of the trace

4983 11:53:25.296  [5520] (ArchiveTask) <3068> EV:L {GetCalculatedModifiedDate:#1290} Calculated date (dd/mm/yyyy): [06/04/2012 19:19.40] [PR_MESSAGE_DELIVERY_TIME]
4984 11:53:25.296  [5520] (ArchiveTask) <3068> EV:L :CArchivingAgent::IsEligibleForArchive(/o=ecbalaw/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Brian Macaluso) |The message titled: 3/20  will not be archived as its inactivity period has not expired  |
4985 11:53:25.296  [5520] (ArchiveTask) <3068> EV:M :CArchivingAgent::IsEligibleForArchive() |Exiting routine |

This is the same for all of the users enabled...most of the provisioned users are not enabled because EV can't get to hidden message:

1158 11:53:15.171  [5520] (ArchiveTask) <3144> EV:H {CMailboxHelper::GetMailboxState:#492} Failed to open EV hidden message: [0x8004010f]

So either the dtrace has not completed the entire process but according to the trace you don't have any eligible messages for archiving. When you did a run now did you run on all mailboxes? Try run now for just the two mailboxes that you mentioned.

Those mailboxes that you are testing...are the emails being imported via PSTs or anything like that? if they are then the modified date would been changed therefore they are not eligible for archiving try testing by changing policy to 1 week/day old or something like that, sync the mailboxes and see if that works.

belnetsolutions's picture

TonySterling, thanks for the input. I disabled the Admin box and then re-enabled it.  I then re-ran Exchange task in report mode and log indicated that both the Admin box and Brian box are now "enabled".

LCT, I originally did the task run on just the selected 2 mailboxes.  After I made sure both mailboxes were "enabled" again with TonySterlings suggestion, I tried re-running the task on just the 2 mailboxes.  A prompt came up indicating that the task was run and is now processing, with no failures to launch.   However it looks like it's just sitting there again and no new logs have appeared in the Exchange Mailbox Archiving folder after 15 mins.  Furtheremore, I am not importing any PST's yet, as we are first looking to archive items within the user's current mailboxes first.  I will try changing the policy from 6 months to 1 week in a little bit and see if that makes any difference.  Also, once we run the Exchange Mailbox Archiving Task, is the Status supposed to change from "running" to "processing" or something to that effect right away?  Hopefully will somehow get this working, because at a loss here...thanks again for all your help

Rob.Wilcox's picture

In EV 10 base there isn't really a way to see the progress of the Archiving Task, without resorting to either DTRACE, MSMQ monitoring, or just plain observing the mailbox you've told it to archive.

That being said, 2 mailboxes.. wait 5 minutes or so, and see if anything has been archived.

Or do a run in report mode to see for sure what *should* get touched during a regular archiving run.

Hope that helps,

belnetsolutions's picture

thanks for all the information and help everyone.  I think i finally got it to work, via all the different troubleshooting tasks here.  In all truthfullness, still not sure what finally got it to work, since I got a little frustrated and tried a number of different things..however it looks like the 2 mailboxes are finally archiving via the Exchange task.  Thanks again.