Video Screencast Help

Exchange restore to a different server

Created: 20 Feb 2013 | 5 comments

Hi,

we're running Backup Exec 10d. Used to back up Exchange 2003 SG's. In the meantime, we changed from a physical Exchange server to a Hyper-V virtualized one, also the name of the server has changed (like from Exchange1 to Exchange2), but all the other names (Organization name, SG names) remained the same.

Now a mailbox restore is requested, so I started a restore job. First prepared a RSG, then in Backup Exec selected the proper SG, then entered the new Exchange server name in the "Microsoft Exchange Redirection" part in the "Restore to" server field. Chose the right logon account, then chose the following settings in the Settings / Microsoft Exchange section:

Exchange 2000 or 2003:

"Temporary location for log and patch files": the path set in Exchange RSG (E:\Exchsvr\LOG\RSG), and only "Commit after restore completes" check box is selected.

Soon after the job started it failed with the following error message:

"The job failed with the following error: Unable to attach a resource. Make sure that the selected resources exist and are online, and then try again."

I could not found a proper solution in the knowledge base, so I would appreciate any help.

 

Thanks,
Attila

 

Comments 5 CommentsJump to latest comment

Attila Suveges's picture

Any idea? I'm lost, please suggest something.

 

Thanks,
Attila

Donald Eady's picture

Have you verified that the permissions on the exchange server are as they should be in regard to backup exec please see doc below

http://www.symantec.com/docs/TECH21357

additionally in your restore selections are you restoring just a single mailbox or are you restoring the entire DB to the RSG. if your attempting to restore just a single mailbox to the RSG this may be your issue. 

I hope this posting was helpful

  

Attila Suveges's picture

I'd like to restore a DB to an RSG, not to an individual mailbox, so the cited document doesn't help.

Any other tip?

ZeRoC00L's picture

Did you dismount the RSG and selected "This database can be overwritten by a restore" on the database property page in Exchange System Manager prior to restoring them?

If this response answers your concern, please mark it as a "solution"

Attila Suveges's picture

Yes I did. Recreated several times (see later).

The error message (Restore 00205 -- The job failed with the following error: Unable to attach to a resource.  Make sure that all selected resources exist and are online, and then try again.) suggests me that BE needs to reach the original server, however, it's already decommissioned.

Also, the Resource Credentials tab asks for credentials for the old server, and even I added the proper credentials it failed to check (of course).

I read an article that the organization and the SG names must be identical. They are, only the server name changed.

I tried to recreate even the RSG in the same way it could have been created on the old server - added the old server name in brackets, and he same way for the DB to recover, but it didn't help.

BTW, Exchange lists only the DB's located on the new server when offers selection from DB's to recover; couldn't it be a problem?

 

At last I tried to restore not using Exchange redirection, but file redirection locally on the BE server to a subfolder, but that job failed too with the following error:

"Restore 00207 -- The job failed with the following error: The resource could not be restored because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent.
Make sure that the Remote Agent is installed on the target computer and is running."