Video Screencast Help

Exchange Restore failing

Created: 03 Nov 2009 • Updated: 21 May 2010 | 5 comments

After around 20 attempts to restore a mailbox I need help

Whenever I attempt the restore, it pulls all the EDB files off tape and then fails with the error
Restore 00018 -- The job failed with the following error: Unable to attach to a resource.  Make sure that all selected resources exist and are online, and then try again.  If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource.

I've now duplicated the backup set to disk, so no need for the tape, but still the same error, just 18hours sooner!!

Exchange server is clustered, but it makes no difference if I use the Physical server name or the Virtual name

Resource Credentials test passes, with 'successful - used server credentials'. i've tried the various suggestions that the KB article in the error message suggests (V-79-57344-33932) but still no joy

Version used was originally v12, and I've upgrade to 12.5 in an attempt to get around the 'cluster issue'

Anybody got any thoughts on how I can fix this?

Thanks 

Comments 5 CommentsJump to latest comment

CraigV's picture

Hi there,

Duplicating to disk is a good thing, as it gets around any potential issues with tape. If it had failed with tape, you'd have to run it all again.
however, have you made the change to the temporary location for Exchange? I've seen this as an issue when restoring from tape, but will be honest and say I haven't had it when restoring from disk.

Try changing the path from C:\Temp to another folder on a drive with lots of space. Tools --> Options --> Exchange

Then run it again and see if you get the same error.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

tulipltd's picture

Thanks for reply, unfortunately I've tried that and it fails with the same error

CraigV's picture

OK...is this on a local server, or a remote server? If remote, did you push install the 12.5 RAWS agent?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

tuilpltd's picture

Yes, Exchange is remote to the backup server, and it has the Agent installed, and I've tried using all 3 names that is 'publishes' - 1 physical and 2 cluster names
 

CraigV's picture

Hi,

https://www-secure.symantec.com/connect/articles/restoring-exchange-or-individual-mailboxesitems-using-backup-exec-howto

Go through that article...see if it helps you at all.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...