Video Screencast Help

Exchange Transaction Logs not being flushed after a Full Backup.

Created: 13 Jul 2007 • Updated: 22 May 2010 | 8 comments
Hi,
 
I run an Exchange full backup and although the job completed succesfully, it didn't clear the transaction logs.
The jub is set to do a Full-Database & Logs(flush commited logs).
I have BackupExec ver 11d
The server I am backing up is an Exchange 2003 (service pack2), running on Windows 2003 server.
Any idea?
 
Thsnks,
 
Calin.

Comments 8 CommentsJump to latest comment

D B 5's picture
It's not uncommon for Exchange not to flush logs, or flush only a few.  When Backup Exec is done backing up the database and logs, it sends a message to Exchange saying it is now ok to purge transaction logs.  From there, Exchange determines which logs are to be purged/flushed.  Backup Exec does not purge the logs itself, it is strictly up to Exchange.
 
That being said, watch it for a week or so and make note of the log files. You will probably see some logs get purged, others stay for awhile, etc.  The logs should be in sequential order, regardless. 
 
At this point I wouldn't worry about it, just track it.  If after 5 full backups you have hundreds of logs with none being deleted, I would then be concerned.
Calin's picture
Thanks very much for your reponse.
 
I've run the full backup job again, and I've got the same result. The job was successfull (and the amount of data being backed up it's right) but it still didn't flush the Trn Logs. Looking in Exchange in the Store's Database properties, it shows "This type of backup was never performed" for both Full Backup as well as Incremental Backup. I have 4 stores and none of them seem to know that a Full Backup was performed.
I checked the backup job again and every setting seem to be the way it is supposed to be.
-Full - Database & Logs (flush commited logs)
-Enabel the restore of individual mail messages from Information Store Backups
-Perform consistency check before backup when using Microsoft Volume Shadow Copu Service
-Continue with backup if consistency check fails
 
A little history of the way the job goes. After about 5.8 GB of backup it does the "Consistency Check" then towards of the end of the job it does "Updating Catalogs", then it does the Verify and then job completes successfully.
 
Is it any other setting I should do and I am missing?
 
Thanks again,
 
Calin.
Hywel Mallett's picture
Do you have the entire Information Store selected? I.e. not just the mailbox store and public folder store?
The mailboxes and public folders have separate databases, but share transaction logs, so the whole Information Store needs to be backed up for them to be flushed.
Calin's picture
I double checked the settings, and YES I have both Storage Groups (I have two sorage groups in the organization) and all four Stores (I have four stores two for each Storage Group) selected for backup.
 
Calin.
D B 5's picture
What Hywel is referring to is did you select the Information Store itself, or select each item below it seperately.  (ie: is the full checkmark at the IS levffel, or does the IS have a slash indicating individual items were selected even if all are selected)
 
The other thing you could try doing is just back up one storage group.  It shouldn't matter, but it eliminates a few steps where the job transistions between storage groups.
 
 
 
Calin's picture
Good morning.
 
This is a detail that I've noticed from the beggining. No matter how I do the selection, the entire Store or each Storage Group individually, when I save the settings it shows a full checkmark for the store. Then if I go back to just look at the job's configuration, it shows full checkmarks for the rest of the selections (drive C:, Drive D:,System State, Shadow Copy Components), but it shows ONLY A SLASH for the IS. It's like it doesn't save that selection the right way.  However if I go deeper into the IS, both Storage Groups and all the Stores have full check marks. Very weird.
 
I will take your advice and do a full Backup just for the Second Storage Gropup and see what happens.
 
Thanks for taking the time to respond to this thread.
 
Calin.
Calin's picture
As I was saying in the previous message, I've run a Full Backup for the Second Storeage Goup only.
And I've only selected The System State, The Store and Shadow Copy Components.
I DIDN'T SELECT any of the drives. And now it flushed the Trn. Logs for this IS and also the Database properties for for all the stores in this IS show that Time of the sast full badkup is today.
 
Is this the way I have to setup the jobs for Exchange? Witout the Drives? Sounds a little odd to me.
 
Calin.
D B 5's picture
Calin,
 
Symantec best practices states to always do your Exchange server backups seperately from any other data.  The reasonsing is more for performance (make it as small a backup window as possible since it is mission critical data) and also if something else non-exchange related fails the job, the whole job isn't marked failed. 
 
I have not run jobs with the drives selected, but when I get a chance I will do so and see if it affects my logs the same way.