Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exchange2010 restore

Created: 07 Apr 2013 • Updated: 07 Apr 2013 | 27 comments

Master Server + Media Server :

rehat5.5_64bit

Exchange2010(not DAG):

Windows2008_R2

NetBackup 7.5

using GRT restore with status 5 and status2810

unable to create object for restore ....information store...... ria 6

using nbfsd -d -v 5 -j <job_id> -B <backup_id> is ok

please give me some advices  Thanks
 

 

Operating Systems:

Comments 27 CommentsJump to latest comment

Marianne's picture

Please share all the steps that were taken - especially the restore options in final restore screen.
Please share all the texts in Job Details as well.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

eten's picture

please see attachments,thanks

AttachmentSize
restore exchange210.docx 494.16 KB
eten's picture

Please give me some adivces. Thanks

emret's picture

did you edit the distributed application restore mappin in host properties --> MAster Server --> Properties--> disributed application restore mapping ;

 

 

Example: If the DAG (virtual server name) is "Dag01"; the DAG Mailbox server is "DAG-MBX"; and the CAS server is "CAS1"; the mapping would be:

- Application Host: Dag01 | Component Host: DAG-MBX  <- Mapping for the DAG Mailbox server

- Application Host: Dag01 | Component Host: CAS1  <- Mapping for the CAS server

eten's picture

Hi emet, it is not DAG , it is standalone, i can restore the whole Mailbox, but i can't restore single message. Thanks

eten's picture

this is my restore single message, BAR show log :unable to create object for restore: \\EXCHANGE-SERVER\Microsoft Information Store\test\Database\bkadmin [bkadminc00], rai error = 6 

RLeon's picture

Firstly, I would recommend that you upgrade all master/media and client to version 7.5.0.5., there has been many Exchange related fixes.

Next, just so that everything is configured according to the guide to the T, the NetBackup Legacy Client Service should use the Local System account instead of your custom account.
The guide only said to change the account for NetBackup Client Service and NetBackup Legacy Network Service.

 

Lastly, please follow this mother-of-all unable to create object for restore solutions technote.
The solutions listed are applicable to Nbu versions higher than 7.0 and to standalone Exhange 2010.

I would ask that you check the ncfgre log that logs GRT restore issues, for messages identical to the ones shown in the technote. (May need to set a higher verbose)
If they are identical, then one or more of the solutions A to F should resolve your issue.

Solution F might not be needed because you are already using the UPN format. (By the way, I think the technote got the UPN format the wrong way around as Domain@User Name)

eten's picture

Thanks , i have changed them, and try it again, the same as before

eten's picture

Hi RLeon

"0,51216,158,352,103,1365478264672,5304,6240,0:,50:[!ERROR Wide character string -> character string],20:[fsys\ese] " is in  ncfgre log ..   

eten's picture

Hi everyone

this is lastly log, restore single message

 

AttachmentSize
restore single message with GRT.rar 41.87 KB
Marianne's picture

I had another look at the logs.

In the tar log, we see successful restores between 10:32 and 10:56.
There is no evidence of the 16:03 attempt.

That makes me wonder where this restore attempt was going.
We need the following logs to know this:

On master: bprd log for 7 April
On media server: bpbrm log for 7 April

Please copy to bprd.txt and bpbrm.txt and post as File attachments.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

eten's picture

Hi Marianne

"successful restores between 10:32 and 10:56 "is restore the whole mailbox  is ok, but the tar log isnot  printed when i restore single message

sorry! i had deleted 7 April log , but just send 9 April log , you can find it 

see attach
 

AttachmentSize
0409log.rar 88.96 KB
Marianne's picture

I will have a look at the logs this evening.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

RLeon's picture

I noticed that you backup the client as Exchange-server, and restore it as exchange-server.

It maybe worth a try to match the client name cases in the backup policy with the actual nbu client name, and also with the source and destination client names in the BAR restore interface.

 

The nbu client name can be changed in BAR > File > NetBackup Client Properties > Client name.

The restore source and destination client names can be changed in BAR > File > Specify NetBackup Machines and Policy Type.

 

eten's picture

Hi RLeon

i changed what you said, but the same as before

Mark_Solutions's picture

Where are you running the restore from?

It fails instantly so never even gets going

You are best to run the restore from the client itself.

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

eten's picture

Yes I run the restore from the Client. do you need other logs? 

Marianne's picture

We need bprd log on the master server that will show source client, browse client, destination client, etc.. etc...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

eten's picture

Hi Marianne

Do you need  the bprd log that the bprd created when i had restored single message from master server  ?

what mean???

Mark_Solutions's picture

Have you tried running it from the Master? Just in case the client has something wrong

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

eten's picture

Hi Mark

from the Master, I couldn't find "BB message", do you think wrong "character" ?

see the attachment

AttachmentSize
Exchange2010.docx 146.64 KB
Dyneshia's picture

Please review :

 

https://www-secure.symantec.com/connect/blogs/what-information-and-logs-include-when-creating-grt-exchange-case-support

 

This not only tells you what information is needed to fully troubleshoot the issue, however it gives some good information and links to review.  I recommend you go through the "everything you need to know about exchange GRT "

emert asked before, however did you set up distributed application restore mapping ?

Is NFS installed on the CAS servers ? 

The CAS server and DARM are key components in restores.

captain jack sparrow's picture

Could just review pre-requisites outlined in following. it's silent video for GRT

https://www-secure.symantec.com/connect/videos/exc...

 

It has all permissions listed which are required for GRT

Did you tried with another mailbox? and with redirection? Instead of overwriting message?

 

 Cheers !!!

CJS

 

eten's picture

i tried to restore  "redirection"

Dyneshia's picture

did you set up distributed application restore mapping ?

Is NFS installed on the CAS servers ? 

The CAS server and DARM are key components in restores.

Dyneshia's picture

You may need to open a case with support so they can troubleshoot with you.