Video Screencast Help

Exclude List Is Not Working

Created: 05 Sep 2013 • Updated: 06 Sep 2013 | 8 comments
This issue has been solved. See solution.

Dear All ,

 

Exclude List Is Not Working Perfectly.Our Need Is To Exclude A Drive While Taking A Backup .Even When We Mention That Drive Letter In The Exclude List While Taking The Backup It Takes That Drive Also.We Had Disabled The Multistreaming Options Also Still The Problem Persists .Or Is There Any Work Around To Exclude A Drive From Backup.Kindly Do The Needful 

 

Machine Backup Type Is - VM Backup 

Machine OS - Windows 2008 Server 

Total Number Of Drives - C:\ & D:\  (E:\ Need To Be Excluded)

Netbackup Version - 7.5

 

Regards 

Mothi Prasad.P

 

Operating Systems:

Comments 8 CommentsJump to latest comment

Mark_Solutions's picture

If you are not using multiple data streams they try using E:\* as the exclusion - seems to work better than just E:\

If not give us more details of what is actually going wrong

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Marianne's picture

Do you have NBU agent installed on the client and taking MS-Windows policy backup?

If Policy type is Vmware, then normal exclude list that is used for MS-Windows policy will not work.

For Vmware policy, you need to use the Advanced Attributes dialog that has an option called Virtual disk selection. You can exclude data disks in this section.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

Good spot Marianne (as always) - hadn't noticed that it was being done as a VMWare policy especially as multiistreaming was mentioned!

In that case then you cannot do it - you can exclude C (boot) or you can exclude D and E (data) but not just E

 

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Nick Morris's picture

You could set the disk to be an independent disk within vCenter and this will make it exclude the drive. That's the only way i have got around it previously for a VMWare backup.

Mothi's picture

@Mark : Have Tried E:\* Also But The Result Is The Same 

 

@Marianne : The NBU Client Is Installed In The Client And MS Windows Policy Is Not Used Only Vmware Policy Is Used .The Criteria We Need Is To Take BKP Of  The Data Disk Also But Need To  Discard A Single Data Drive For Example If There Are 4 Data Drive In Want To Take Backup for 3 And Wnat To Exclude One Drive

Marianne's picture

Please understand that "ALL_LOCAL_DRIVES" is determined right in the beginning of the jobs by the master server and that one job per drive letter is generated.

When bpbkar on the client is started, the Exclude List is consulted.

So, it is perfectly normal to see a job for each drive letter, with a small job (+- 32 KB) for the E-drive.

The only other way is to disable multiple streams or to specify drive letters explicitly.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

As it IS a VMware policy then the only workaround is to make the one disk independant so that it does not get picked up

Exclude lists do not apply to VMware backups

The other option is to back it up using a MS-Windows policy in which case your exclude list will work

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
Toddman214's picture

I am experiencing a similar issue to Mothi, but not exactly. I have a policy set as a VMware policy, and I have used the "exclude data disks" under the advanced option, which should work in this case, since this is a VM, and the boot disk is not an independent disk (i.e, it can be snapshot). I am running three other VM's like this for testing, and they worked properly. I have drives C,L,S,T,U,X, and all I want to back up up is C, but all drives are captured in the backup and at full size.

I did notice then I set up the VMWare policy that it stated that the client needed to be running agent version 7.5 or newer, but my four test clients are running 7.0 (yes, I'll have to evenually update them anyway). All but the one did backup up just the boot drive as I wanted, and I have performed a test restore which worked. Has anyone had any issues using a client older than 7.0 with this option?