Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Exclusion lists not working

Created: 20 Aug 2012 • Updated: 21 Aug 2012 | 12 comments
This issue has been solved. See solution.

I've been having problems getting file exclusions to work properly.

This has occured on multiple different OS types, suggesting this is a layer 8 problem :)

Anyway, right now I've setup an exclusion on a RHEL 5.8 machine for one policy RHEL_Dev_Audit

the perms are 644 and there is one direct /var/log/dirsrv

Everytime a manual backup runs it trys to get this directory.

Any ideas.

The backup file selection is specifically enumerated.

e.g.

/var/log/audit

/var/log/dirsrv

Some clients have /var/log/dirsrv and some do not.

Thanks,

Chris

Comments 12 CommentsJump to latest comment

Rajesh_s's picture

The following syntax rules apply only to UNIX clients:

■ Do not use patterns with links in the names. For example, assume /home is a
link to /usr/home and /home/doc is in the exclude list. The file is still backed up in this case because the actual directory path, /usr/home/doc, does not match the exclude list entry, /home/doc.

■ Blank lines or lines which begin with a pound sign (#) are ignored.

Syntax rules for exclude lists

Only one pattern per line is allowed

Spaces are considered legal characters. Do not include extra spaces unless
they are part of the file name.

End a file path with \ to exclude only directories with that path name (for
example, C:\users\test\). If the pattern does not end in \ (for example,C:\users\test), NetBackup excludes both files and directories with that path name.

If you are using a case sensitive exclude list property -- it indicates that the files and directories to exclude are case-sensitive.
 

 Rajesh 
Marianne's picture

Backup Selection is applied first.

Only upon start of bpbkar on client is exclude_list evaluated and applied.

I have learned this when I was first introduced to NBU:

1) Group Clients together in same policy if same OS and same backup selection.

2) Use ALL_LOCAL_DRIVES rather than specific backup selection. Add exclude_list on clients if specific filesystems/folders/files need to be excluded. 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

cgoliver's picture

1. We have special req. for audit data, therefore we've enumerated them seperate from all_local_drives

2. Clients are grouped by OS type and enclave location e.g. DMZ, Prod, Dev

Marianne's picture

Best to also group clients by similar Backup Selections. Exclude List will not work the way you need it to.
 

I don't understand how is ALL_LOCAL_DRIVES not sufficient for audit purposes?
That way you don't run the risk of missed file systems when sysadmin 'forget' to notify backup admin of newly added volumes....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

BTLOMS's picture

/var/log/audit/*

/var/log/dirsrv/*

try adding the star

worked for me.

Nicolai's picture

Netbackup client 7.0 through 7.1.0.1 ignoring the exclude list

http://www.symantec.com/docs/TECH150101

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

cgoliver's picture

Even with the splat. No joy. Still get the error 71.

cgoliver's picture

file name is, exclude_list.RHEL_Dev_Audit

mode is 644

one and only line is, /var/log/dirsrv/*

Douglas_A's picture

So you are excluding the /var/log/dirsrv/ on all RHEL boxes? and you are getting error 71?

I hate to ask this but are you sure you are backing it up? I mean you will still see the filesystem in the BAR there will just be no files in it for recovery.

Can you please elaborate a little more.. this thread is a little confusing.

I mean if you are attempting to backup /var/log/dirsrv and it is excluded an error 71 might be termed as normal since there were no files to backup.. (not sure to be honest) in 7.5 it produces a Status 90.

Can you help me out with a little more detail?

Best of Luck,

Doug

Please remember to mark the most valuable answer to your issue as the solution.

Andy Welburn's picture

With those two backup selections have you actually also got multiple data streams enabled on the policy?

I think Marianne intimated that the backup selection is read first & then the exclude lists - with multiple data streams enabled. therefore, you will get a job created for each backup selection, then the exclude lists are applied, you then end up with a 71 as you are excluding all of one of the backup selections.

SOLUTION
cgoliver's picture

Removing the multi-streaming is the ticket. The reason that all local drives is not sufficient is that our req. is all audit data created must be stored for 12 months.

Some systems generate a few hundred gig a day of audit data.

The daily backup load here can push 40TB on a busy day (thanks Oracle, never heard of a data warehouse)

cgoliver's picture

We have other policies, which will suffer from the lack of multi-streaming.

Now I understand why there were hundreds of policies in the past.