Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Extend WG Protocol Driver / SNAC ?

Created: 07 Oct 2008 • Updated: 21 May 2010 | 16 comments

After upgrading a couple of servers from 11.0.2 to 11.0.3, I got the following error message on reboot:

"The Extend WG Protocol Driver service failed to start due to the following error: The system cannot find the file specified."

and:

"The Symantec Network Access Control service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 10000 milliseconds: Restart the service."

 

I think the "Extend WG Protocol Driver" is a Symantec component, but I'm not 100% sure.  I guess I'll probably call in and open a support case on this, but I thought I'd post it here in case anyone had a clue.  Thanks.

Comments 16 CommentsJump to latest comment

underlig's picture

I recieved the same error on a 2003 SBS server when upgrading from 11.0.2 to 11.0.3.

 

Do not know if it is connected or not but i also had four processes using 25% cpu each, essentially locking up the server completely. One of them seemed to be smcgui.exe though it was hard to see since the system used too much cpu-power to correctly display the taskmanager.

Jordon's picture

I am getting this issue too. One of my servers has high cpu on SMC and SMCgui.  Another server gets service failures on WG Protocol and SNAC.  I've disabled SNAC and this isn't appearing on workstations.

 

Any advise? 

Cliving's picture

Hi,  

After upgrading a couple of servers from 11.0.2 to 11.0.3, I got the following error message on reboot:

"The Extend WG Protocol Driver service failed to start due to the following error: The system cannot find the file specified."

 

I get this message in my Event - System log.

 

Any advise, Dick

gdettmore's picture

Me too.

 

SBS 2003 R2 upgrading from 11.0.2 to 11.0.3, only have Antivirus services installed.

 

We only get this error...

 

"The Extend WG Protocol Driver service failed to start due to the following error: The system cannot find the file specified."

Chris Chapin's picture

So is someone from Symantec going to respond to this thread?  It's only been out there since the beginning of Oct. 08.

 

 

I have the same problem upgrading the from 11.0.2010 to 11.0.3001.2224 on a Windows 2003 R2 x64 system that is running the management console.  The problem did not occur on the 2003 R2 32 bit system used for testing.

 

Searching the registry on the 64 bit system for "Extend WG", I found a reference to this name in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WGX and it includes the key ImagePath = System32\Drivers\WGX64.SYS.  The wgx64.sys file does not exist on the system after the upgrade, but was there before.

 

So---do I restore the missing wgx64.sys file or do I delete the registry key?  The file and registry are not on the 32 bit system...so I removed the WGX registry key and its subkeys (after exporting it first just in case).  Restarted the machine and all services are working properly.  For those of you with this problem, procede at your own risk, but it looks like you can safely delete the key, especially since the wgx64.sys file is removed in the upgrade process.

 

I didn't notice a problem with high CPU utilization with the 32 or 64 bit machines after the upgrade. 

 

 

So Symantec...what is the current rate that you pay developers that do beta testing for your products?  I need to send you a bill for my time doing testing that should have been done before publicly releasing this build....

Message Edited by Chris Chapin on 11-13-2008 08:55 AM
Cliving's picture

 

Success

 

I have 11.0.3001.2224 running on Windows 2003 Standard Edition 32. Since upgrading to this version, I too have been getting this error message on startup.

 

From your message, I noticed the registry entry :ImagePath = System32\Drivers\WGX.SYS.

Doing a search on my C: drive I found WGX.SYS, but not in the directory path C:\windows\System32\Drivers\. 

 

Now, by coping WGX.SYS to "C:\windows\System32\Drivers\", I no longer get this "The Extend WG Protocol Driver Service fail ...." error.

 

Cheers, Dick

 

 

 

 

wrr123's picture

Has anyone else tested what Cliving suggested and had positive results?  Is this a workaround or resolution.  It would be nice if someone from Symantec would chime in and drop their 2 cents.

tramp21's picture

Hi,

the tip from Cliving did help me.

I had these errors  too.

 

dfosbenner's picture

I have the same error, and I'm using MR4.  Cliving's workaround seems like a simple fix for now.  However, when I checked, it seems that the WGX.SYS file is already present in c:windows\system32\drivers, and I still have the error.

 

I really have to wonder what Symantec is doing, and why they aren't more committed to making this product a success...considering we're at MR4 and we're still dealing with stuff like this.

Message Edited by David Fosbenner on 12-23-2008 08:23 AM
M Strong's picture

I too have this same issue, and also have found wgx.sys in all the proper locations:
\system32\drivers
and
\Program Files\Symantec Client Security\Symantec Antivirus (Yes, this machine was the recipient of an in-place upgrade from SAV 10)...
Although, I've verified that every mention of wgx.sys in the registry does coorespond to an actual copy of the file within the file system, and that wgx.sys (in both locations) are the same file version and (as far as I can tell) up to date.
Next thing I'm going to do is a symclean and re-install...  I'll post back if I find that this has made any difinitive difference.

-M

dfosbenner's picture

I just upgraded to MR4 MP1, and now ALL my servers get this error, not just one of them.  NICE GOING GUYS !!!!

How about some info or a fix??

DW1 IT Department's picture

I also upgraded to MR4 MP1 and i have the startup failure (service) on every server!

What about a fix right now??

What doe the error mean --> when i disable it in the device manager, does is affect the endpoint client (what is the WG protocol driver)?

desanctis's picture

I was not receiving this error on reboots of servers until I upgraded to MR4 MP1.  I'm going to try to copy the wgx.sys file in question to system32/drivers as suggested but I hope a fix from Symantec will be forthcoming rapidly.

DW1 IT Department's picture

It seems that the MR4 MP1 update has a failure with the installer (for me only on 64 bit).

You only have to set the service "Symantec Network Access Control" to "Manual" --> the installer seems to set it to "Automatic".
We don't have installed this service and so we get the error due the startup that the service can't start (surprise).

For me this was the solution --> hope it helps someone else!

greetings

Peter

Ken_D's picture

Checked the "Symante Network Access Control" and it is set to manual on our Windows 2000 servers but we are still getting the errors.

John_Prince's picture

Hi everyone,

I just made a post about this issue for Ken_D on the following thread you can check out, please be cautious when editing your registry:

https://www-secure.symantec.com/connect/forums/dom...

Remote Product Specialist, Business Critical Services, Symantec