Video Screencast Help

External OWA Searcho2k.asp Not working

Created: 23 Jan 2013 • Updated: 27 Jan 2013 | 3 comments
EVHolic's picture
This issue has been solved. See solution.

Guys -

We have configured our internal/external OWA on exchange 2010/TMG. We have a rule in TMG which redirects external OWA traffic to EV. We also use "ExternalIPAddress" on the CAS web.config file to identify the "External Traffic" by putting in the IP addresses of the TMG.

What works:

1. Internally OWA goes directly to EV server and both AE and SEarcho2k.asp work.

2. Externally AE works via redirection from TMG.

What does not work:

1. Externally, when I click on "Search Archive - searcho2k.asp", it tries to connect directly to the EV server rather than using the "Https://email.company.com/Enterprisevault/Searcho2k.asp".

This is strange beacuse if AE works, so should Search as its in the same OWA session and AE is being recognized as external traffic and TMG does the appropriate redirection to the EV server, yet Searcho2k.asp tries to use the default webapp url, which is direct connection.

If I try to go directly to "Https://email.company.com/Enterprisevault/Searcho2k.asp" from external, I get a webpage with only below -

V9.0.2.1061 65 0 0 1 1 0 1 16D99C4707C4A1E49B95DBA1577E6FC0E1110000EVSERVER2 EV78 POC 9

 

Also, externally I can go directly to Https://email.company.com/Enterprisevault/Archivee... and they work fine.

Anyone have ideas if its a TMG redirection issue or is something corrupt in the searcho2k.asp.

 

Comments 3 CommentsJump to latest comment

AndrewB's picture

try to go directly to "Https://email.company.com/Enterprisevault/Search.asp" from external

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

Andrew G.'s picture

Check the IIS logs on the EV server to see if the searcho2k request is getting as far as that.

Also check if there any settings in TMG specific for searcho2k.

EVHolic's picture

Guys - thanks for the responses.

After looking closer at the web.config file, we had mistyped the IP addresses of the TMG. After changing the web.config file to the correct IP addresses, it worked perfect.

That being said, its strange that even with the INCORRECT IP addresses, EV was redirecting the external traffic from AE and not OWA. Very strange behavior and thus threw me off the real reason of mistype IP as I assumed that if AE was working, the IPs were correct.

EV OWA works very strange at times.

SOLUTION