Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Failed to access Microsoft Exchange Mailboxes

Created: 19 Jul 2013 • Updated: 26 Jul 2013 | 14 comments
This issue has been solved. See solution.

Just started getting this a little over a week ago. Everything has been working fine, now i cannot select the mailboxes anymore. I know it is a legacy option but i still like using it. I went through the procedure of all the steps just to double check everything was still in place, it's not hidden, all the rights are still there etc. I even reset the password in ad and backup exec and still no luck. The account isnt locked or anything. Any suggestions would be great.

p.s.

using backup exec 11d

Operating Systems:

Comments 14 CommentsJump to latest comment

ZeRoC00L's picture

What is your exchange version ?

Any changes made to the exchange server ?

If this response answers your concern, please mark it as a "solution"

Jaydeep S's picture

If you are talking about legacy mailbox support using Be 11d and Exchange 2000/2003, it needs to be enabled from Tools --> Options --> Microsoft Exchange. For Exchange 2007 and 2010 the legacy mailbox support is discontinued and a new GRT feature is introduced. 

To perform backups using GRT you will be backing up Exchange Information Store with all the permissions and requirements in place and you will only see the mailboxes in the restore view (not backup view)

Could you confirm if the Logon account has all the permissions as mentioned in this technote

1. The account must be an Exchange Full Administrator (Exchange 2003), Exchange Organization Administrator (Exchange 2007), and Organization Management (Exchange 2010) at the top level of Exchange.

2. The account must be a Domain Administrator. (Recommended, ensure that Domain Admins is a member of the Local Administrator's group on the Exchange Server)

3. The account must have an active mailbox on the Exchange Server.

4. The account must have received an e-mail via the mailbox.

5. The account must have sent an e-mail via the mailbox.

6. The account must be named so that it is unique within 5 characters. (Refer to the TechNote below for steps to test this).

7. The account must be visible to the Global Address List, not hidden.

8. Make sure the default system logon account of Backup Exec and Backup Exec Service Account are the same.

How to confirm that an Exchange mailbox name is unique within the Exchange organization when configuring Backup Exec to back up Exchange mailboxes

 http://www.symantec.com/business/support/index?page=content&id=TECH24691

For Exchange 2007

1. Microsoft Exchange Server MAPI Client and Collaboration Data Objects is installed in the Exchange 2007 Server.  http://www.microsoft.com/downloads/details.aspx?FamilyID=e17e7f31-079a-43a9-bff2-0a110307611e&DisplayLang=en

2. Exchange 2007 Management Tools are installed in the Media Server and updated
If the Media server is 64 bit it can be installed from the Exchange 2007 Installation Media. If Media Server is 32 bits use this link - http://www.microsoft.com/downloads/details.aspx?familyid=6BE38633-7248-4532-929B-76E9C677E802&displaylang=en

ZomBieAutopsY's picture

thanks for the replies, im using exchange 2003, no changes to exchange. i am thinking maybe a windows update.

Jaydeep as stated this was working and stopped about a week ago.

mustansir's picture

Hello

Could u please tell us how many exchange related entries you see in backup job....are u selecting microsoft information store in selection list...legacy mailboxes are seen under exchange mailboxes resource in selection list...if that entry in selection list is not showin up then as suggested in above post
Go to tools | options | microsoft exchange
Nd enable the option enable legacy mailbox support
Restart backu exec services
Check it in new job...
If above scenario is not d case than are old exchange backups failing...if successful plz chck in restore view if u are able to see all the mailboxes..

Hope this resolves your issue..plz mark the post as solution if this resolves your issue...

ZomBieAutopsY's picture

individual mailboxes. was working a week ago, stopped all of a sudden. reset credentials to make sure, still nothing. went throught the process again for selecting individual mailboxes. still nothing. keeps telling me my credentials are bad.

MusSeth's picture

Are you getting the error "unable to logon to MAPI with specified credentials " when you are trying to browse it in the selection list, if thats the error make sure account is not hidden in GAL, as you have mentioned that nothing has changed, try creating a new account with unique name (i used zzzzz ) add the account to administartors, domain admins and exchange full administrators group.

create a mailbox for the account activate it by sending an email to it, create a logon account in backup exec for that user in the new selection list when you browse the exchange server in selection list right click on the exchange resource and select connect as option and select the new account

if it does not give an error and you are able to see the mailboxes continue using the new account, i hope this resolves your issue.

ZomBieAutopsY's picture

Hi Seth, no nothing to do with MAPI. i was thinking about creating a new account all together, but didnt want to have to go through the process. But i sm going to give it a try since i do not have any other options at this point. Thanks.

ZomBieAutopsY's picture

So i created a whoe new account and followed the step below and still cannot access the mailboxes.  If anyone has any other suggestions i would most appreciate it. if not im about to say F'it.

  1. The account that is required for this process must have very specific permissions and attributes to allow this complex process to take place:
  1. The account must be an Exchange Full Administrator (Exchange 2003), an Exchange Organization Administrator (Exchange 2007) at the top level of Exchange or a member of Exchange´s Organization Management group (Exchange 2010)
  2. The account must be either a Domain Administrator (Recommended, ensure that Domain Admins is a member of the Local Administrator's group on the Exchange Server), a Local Administrator on the Exchange Server or BOTH (Recommended).
  3. The account must have an active mailbox on the Exchange Server.
  4. The account must have received e-mail via the mailbox.
  5. The account must have sent e-mail via the mailbox.
  6. The account must be named so that it is unique within the first 5 characters. (Refer to the TechNote http://www.symantec.com/docs/TECH24691 to test this).
  7. The account must be visible to the Global Address List, not hidden from it.
  8. Make sure the System logon account in Backup exec and the account assigned to the Backup Exec services are the same.
  9. Confirm that the Backup/Restore job is set to use the system logon account and that it is configured as DOMAIN\USER
  10. Confirm that in Active Directory, that USER´s account has "Account Name", "Logon Account Name" and "Display Name" that match each other. (name and fields may vary according to AD version)
  11. Exchange Management console (Exchange 2010) or Exchange Management Tools (Exchange 2007) have to be installed on BE media server as well as in mail server with the exact same version and upgrades running on each of them. (Full requirements for using the BE Exchange Agent)
  12. Change the Backup Exec System Logon Account (SLA) to be the same ID that is used for the Exchange backup. The SLA should also match the ID used as the Backup Exec services.

 From Backup exec console Click Network -> Logon Account, ensure that a "System Logon Account" is present.  If not create a "System Logon Account" by clicking the System Account button.

MusSeth's picture

zombie could you please upload the pic of your backup job selection list for the server in question, another pic for tools | options | microsoft exchange options

ZomBieAutopsY's picture

Sure thing, here they are. Also i tried to do it with the Granular technology but that isnt working either.

options.jpg selections.jpg
ZomBieAutopsY's picture

Ok weird, it is here but invisible, right under the text.

selections.jpg
lmosla's picture

Has the Exchange server been rebooted recently?

SOLUTION
ZomBieAutopsY's picture

It's funny that you say that because i rebooted it last week and it didnt fix it. There was some windows updates pending yesterday morning so i rebooted it again and it fixed it.