Video Screencast Help

Failed to backup vCenter VMs

Created: 21 Aug 2013 • Updated: 22 Aug 2013 | 7 comments
This issue has been solved. See solution.

Hi all,

I just upgraded my vCenter 5.0 to version 5.1. I am using Symantec BE 12 SP2 for backing up of VMs before the upgrade and it was working well.Now i couldnt backup any of my VMs with error .

Final error: 0xe0009585

V-79-57344-38277 - Unable to open a disk of the virtual machine.

VixDiskLib_Open() reported the error: Invalid connection handle

 

i did disable the GRP option but issue persist. I am using a domain admin account to run this job, i also added this account to my vcenter server local admin group.

 

Please help me. Thanks in advanced.

Operating Systems:

Comments 7 CommentsJump to latest comment

Donald Eady's picture

are you able to backup the machines directly "using the remote agent "??

 

edit: i know that the versioning is different but have a look at the following technote 

 

 http://www.symantec.com/docs/TECH152988

 
It suggests that there is an issue connecting to the vcenter.. please verify that the credintials being supplied are correct
 
edit:
Please verify the the ESX host is still licensed.. i ran across this thread in where there were similar issues and the esx host and vcenter came unlicensed ... 
 

I hope this posting was helpful

  

ahtshun's picture

Hi donald,

All my ESXi and vCenter server are licensed under essential plus.

FYI. i got 3 ESXi host..2 hosts are running on ESXi 4.1.0 and the 3rd one on 5.0.0. Vcenter server is running on version 5.1

i doubt of different version. everything was working before the upgrade of  vcenter server 5.1

 

i did run a test credential. all passed.

ahtshun's picture

Hi Donald,

Yes i can. I got 2 VM machines which are file/print server.

 

I did try to backup power off VM but i still encounter the error.

 

 

VipulK's picture

Hi,

 

Ths is a generic error with VM backups.

You can try the tech note:

 http://www.symantec.com/business/support/index?page=content&id=TECH129572

Regards

 

ahtshun's picture

i did a simple test.

i added one of my ESXi hosts to Backup Exec server selection, create a backup job of VM and it ran successfully.

However if i add my vcenter server to backup exec server selection, create a backup of VM and it failed.

the service account that i use in Backup exc is an administrator of Vcenter, admin of ESXI hosts,  local admin of vcenter server and a domain account as well.

Anyone have any idea to resolve this issue?

 

 

pkh's picture

I would suggest that you open a support case with Symantec for them to take a look at this problem.

ahtshun's picture

Hi all,

I did some changes on my vCenter -> Sign-on & discovery -> Configuration. Add an alias when creating identity source to my AD domain.

Now the backup is working well now.

 

SOLUTION