This issue has been solved.

Failed to connect the database server in SEPM

Created: 11 Dec 2011 • Updated: 18 Dec 2011
Login to vote
-1 1 Vote

I Can't Start "Symantec Embedded Database" service.

I TRIED THE FOLLOWING STEPS  i got "CONNECTION FAILED DATABASE SERVER NOT FOUND# PLS GUIDE ME..............TO SOLVE TIS ISSUE

 

 

  1. Verify that the Symantec Embedded Database service is running and that the dbsrv9.exe process is listening on TCP port 2638
  2. Test the ODBC connection.
  3. Open Control Panel > Administrator Tools
  4. Double click Data Sources (ODBC)
  5. On the System DSN tab, double-click SymantecEndpointSecurityDSN
  6. On the Database tab, type in the Server name (computer name) of your Manager, where the database resides. If computer name does not work, try the IP number or fully qualified domain name. (Version 11.0.5002.333 or newer, add SPC_ to the beginning of the server name. If the SPC_ prefix is not included, you will receive the error: "Database Server Not Found")
  7. On the Login tab, supply the user ID and password for the Symantec Embedded Database (defaults to the first admin password you ever used for the SEPM).

    User ID: dba
    Password: <password>

    Note: If the “Encrypt password” box on the Login tab is not checked, your password will be stored as plain text in the Windows registry.
     

  8. On the Network tab, confirm that TCP/IP is checked and the value has either HOST= or IP= with your server's IP (127.0.0.1 is also acceptable).
  9. Leave the defaults for the rest of the items and return to the ODBC tab
  10. Click Test Connection , it should return "Success"
  11. Click OK
Quick Look Solution

THANKS TO ARVIND KM

IT S STRATED TO WORKING FINE

BY FOLLOWING SOLUTION..........

 

 

 

Verify if there is any running instance of dbsrv9 in the Task Manager > Processes tab. If yes, then end that process

Start the Embedded database service. ( If this does not resolve the issue, then follow the steps listed below )

Go to "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\" and rename sem5.log to sem5.log.old

Click Start, click on Run and Type "CMD" then click OK

In the Command Prompt type: "CD C:\Program Files\Symantec\Symantec Endpoint Protection Manager\ASA\win32\" and press Enter this will change directories to the folder containing dbsrv9.exe.

To force the recreation of sem5.log. Type: "dbsrv9 -f "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\sem5.db" and press Enter

Click Start, click on Run and Type "services.msc" then click OK and start the Symantec Embedded Database Service

Start the Symantec Endpoint Protection Manager service

 

THANKS&REGARS

S.KARTHICK

 

Filed Under

Comments

12
Dec
2011

Good morning,did you use the

Good morning,

did you use the windows embedded database or an external sql database?

When using embedded database, be sure that the service is up and running!

regards,

Marius

17
Dec
2011

GOOD MONING PLS FIND OUR PROBLEM NOW........

GOOD MORNING.... THKS FOR REPLY..

1. We are using windows Embedded database..symantec 11.0 version in windows server 2008 server.Now sym embedded database servie and SEPM services are not running.we are unable to run data base service if try to start it says started and then stopped some services stop automatically if they are not in use by other services or programs.. 

2. We almost done all trouble shooting ..i mentioned already in above ..we are in Reconfiguration stage...In this we get error

3."The server port you used is not used by the database server.you must use the port that the embeded database server use" ( PLS FIND ATTACHMENT ERROR.png) 

4.IF WE START THE DATABASE MANULY BY     C:\Program Files\Symantec\Symantec Endpoint Protection Manager\ASA\win32\DBSRV9...then try to reconfigure the symantec managemer ..WE GET FAILED TO CONNECT TO DATABASE SERVER...PLS MAKE SURE UR USERNAME AND PASSWORD ARE CORRECT ( PLS FIND ATTCHMENT 2 ) instead of first error...

5. PLS GUIDE US.............

 

 

error.png ERROR2.png

Regards

Karthick

Thomas K
Accredited
12
Dec
2011

Can you give us some more

Can you give us some more information? What version of SEP are you running? What OS are you on? Was this an upgrade from another Symantec Product? If so, what product and version?

You might try running a repair install of the Symantec Endpoint Protection Manager via Add or Remove Programs.

http://www.symantec.com/business/support/index?pag...

Ooyala - Check us out!

17
Dec
2011

hi

pls find info abouv

 

we tried repair and also change option but didt work..........?????

 

kindly give any solutonnnnn..

thks

Regards

Karthick

Ashish-Sharma
Accredited
12
Dec
2011

Hi,   Kindly check this

Hi,

 

Kindly check this solution will be help you.

 

Just restart Service.

Symantec Embedded Database..

Symantec Endpoint Protection Manager.

 

Thanks & regards

Ashish Sharma

Thanks In Advance

Ashish Sharma

 

 

17
Dec
2011

Not able to start "Symantec

Not able to start "Symantec Embedded Database

Symantec Embedded Database  " service"      "       Service....

 

Rgds

 

Karthick

Regards

Karthick

pete_4u2002
Symantec Employee
Accredited
17
Dec
2011

can you post the

can you post the scm-server-0.log?

18
Dec
2011

i posted th scm server-o log....

i posted th scm server-o log...

 

pls find the attachment.......kindly guide us

 

Regards'

s. karthick

AttachmentSize
scm-server-0.rar 1.9 KB

Regards

Karthick

pete_4u2002
Symantec Employee
Accredited
18
Dec
2011

2011-12-17 20:32:25.999

2011-12-17 20:32:25.999 SEVERE: Unknown Exception in: java.util.logging.Level
org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (JZ006: Caught IOException: java.net.ConnectException: Connection refused: connect)

 

you may need to restore the old backup.

Ashish-Sharma
Accredited
17
Dec
2011

What error Msg

What error Msg while startup the service

 

Thanks & regards

Ashish Sharma

Thanks In Advance

Ashish Sharma

 

 

18
Dec
2011

good morning Asish

 

we are unable to run symantec embedded data base service

if try to start it says error

"started and then stopped some services stop automatically if they are not in use by other services or program"

 

Regards

Karthick

Ashish-Sharma
Accredited
18
Dec
2011

Have you tried restart the

Have you tried restart the server.

 

Thanks In Advance

Ashish Sharma

 

 

18
Dec
2011

i restarted the server

Restarted the server still the same plm persisting

 

 

kindly help..

Regards

Karthick

18
Dec
2011

this error comes when i 

this error comes when i  reconfigure the mgr using same database sem5

 

"The server port you used is not used by the database server.you must use the port that the embeded database server use"

 

regards

karthick

Regards

Karthick

18
Dec
2011
SOLUTION

THANKS TO ARVIND KM

IT S STRATED TO WORKING FINE

BY FOLLOWING SOLUTION..........

 

 

 

Verify if there is any running instance of dbsrv9 in the Task Manager > Processes tab. If yes, then end that process

Start the Embedded database service. ( If this does not resolve the issue, then follow the steps listed below )

Go to "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\" and rename sem5.log to sem5.log.old

Click Start, click on Run and Type "CMD" then click OK

In the Command Prompt type: "CD C:\Program Files\Symantec\Symantec Endpoint Protection Manager\ASA\win32\" and press Enter this will change directories to the folder containing dbsrv9.exe.

To force the recreation of sem5.log. Type: "dbsrv9 -f "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\sem5.db" and press Enter

Click Start, click on Run and Type "services.msc" then click OK and start the Symantec Embedded Database Service

Start the Symantec Endpoint Protection Manager service

 

THANKS&REGARS

S.KARTHICK

 

Regards

Karthick

06
Jan
2012

Thanks

Thank you for posting your solution.  Those command line procedures got me going again.