Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Failed to determine whether to delete an archived file following the deletion of its placeholder

Created: 22 Jan 2013 | 7 comments

Hi all,

I'm running EV 9.0.3. I'm getting Event ID 20545 very often (Failed to determine whether to delete an archived file following the deletion of its placeholder. The archived item will not be deleted.). As I have seen there's no a clear solution for this in the Symantec web page. Anyone having this problem? Any ideas or suggestions? The problem is that I think that I have a lot of archive files without the corresponding placeholder using too much space I cannot remove. Is there any way lo locate and remove them?

Thanks in advanced.

Juan A.

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

Rob.Wilcox's picture

When is the event being logged?

Randonly throughout the day?

During an archiving run?

After someone deletes a file?

JuanAntonio's picture

Hi Rob,

The error is being logged in the EV server's Event Viewer (under Symantec Enterprise Vault). Not during an archiving run. I think that when a user deletes a file. Sometimes I get a lot of errors, maybe due to a massive deletion of files by a user.

The original files (and the placeholders) are stored in a NetApp file. The archive files are store in a HP Lefthand P4000.

Regards

JuanAntonio's picture

I have tried to reproduce the issue, but with no success. I don't know under wich circumstances it arrives.

I have read that EV updates the DOD caché every hour by default. Does anyone know where can I change this?

On the other hand, I have found a hotfix for EV 9.0.3 (http://www.symantec.com/docs/TECH187900) that apparently resolve something similar ("some items are left in the archive even though the placeholders have been deleted"). I'm going to plan its installation and lets see.

And one final and important question: How can I delete all the archived items that were not deleted when the placeholder was deleted?

Thanks.

Juan A.

JuanAntonio's picture

I could reproduce the issue. I think that the error comes when  EV updates de DOD cache (every hour) and some placeholders have been previously deleted. Some times I get the error and sometimes not. But what I have noticed is that the size of the archive is always the same. It never decrease, even when I don't get the error after deleting archived files.

Any help?

JuanAntonio's picture

Hello again,

I have updated from EV 9.0.3 to EV 9.0.4 and I'm still getting (not everyday but quite often) the Event ID 20545.

Does anoyone know how to find those archived files that don't have a placeholder?

Thanks.

Juan A,