Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Failed to Load Library. Error: 1021. 87 - The Parameter is incorrect

Created: 16 Aug 2011 • Updated: 09 Feb 2012 | 6 comments
This issue has been solved. See solution.

Has anyone ever come across the following error when attempting to import an xpf?  We are having this happen on a few machines after installing 6.1 SP7.

RS

Comments 6 CommentsJump to latest comment

TheSmiz's picture

More information: When I install SvsAdmin and attempt to import a .xpf I get an error message "Error loading XpfInstall.dll".

AngelD's picture

Did you ever restart the computer after installing SWV?

TheSmiz's picture

yep.  And this isn't just one computer.  This is happening on multiple devices in our 20,000+ node environment.

 

I opened a support ticket, now just need to get a VM created so they can see what is going on.

Jordan's picture

This happens if you don't have the correct version of VC runtimes that the XPF library requires.  You should only hit this issue if you're not installing via our EXE (ie using the MSI).

Can I get the installer type and OS as I think I can help you faster then support on this one?

If a forum post solves your problem please flag is as the solution

SOLUTION
TheSmiz's picture

Sorry Jordan, just saw this response as I have been out of town for the last 3 weeks.

I figured this out while on my trip.  we had always been using the .msi to install and I decided to try the .exe and see what was different and came across the VC runtime.

I appreciate your help!

 

RS

EdT's picture

@ Jordan - would it not be sensible to modify the MSI to check for the correct versions of runtimes to avoid this sort of issue?  An appropriate message could be written into the installation log and the event viewer.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.