Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Failed Quick Delivery

Created: 13 Feb 2014 | 1 comment

Good afternoon,

I am trying to find out why my Quick Delivery of Software is failing over and over again but it still manages to install the application.  It takes less than 10 secs to install but at the end of the task it fails.  Anyone have any clue?  Below is a log I extracted from a PC that the task failed on:

<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='SWDAgent' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='2392' tickCount='8300267' >
  <![CDATA[End download for package: {E3FC2F91-FBFF-4E63-A1EB-561A567AE9E1}.]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='MaintenanceWindowMgr' module='PatchMgmtAgents.dll' process='AeXNSAgent.exe' pid='1576' thread='2636' tickCount='8300329' >
  <![CDATA[isAbidingByMaintenanceWindows() - yes]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='SWDAgent' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='2100' tickCount='8300329' >
  <![CDATA[Add SWD task Install {1AEA0A88-80FB-418F-AE8C-F764E97C3801} to run queue]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='MaintenanceWindowMgr' module='PatchMgmtAgents.dll' process='AeXNSAgent.exe' pid='1576' thread='2636' tickCount='8300329' >
  <![CDATA[okayToDoMaintenance() - 2014-02-12 21:09:24 -7:00 yes]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='SWDAgent' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='2316' tickCount='8300345' >
  <![CDATA[Checking if the Windows Installer is busy]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='SWDAgent' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='2316' tickCount='8300345' >
  <![CDATA[Windows Installer is not busy - proceeding with installation.]]>
</event>
<event date='Feb 12 21:09:24' severity='2' hostName='PHA061200027' source='ProgramExec' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='2316' tickCount='8300360' >
  <![CDATA[No interactive session to start interactive task]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='SimpleThread' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='3768' tickCount='8300360' >
  <![CDATA[SWD Program Execution Thread thread 0xEB8 beginning]]>
</event>
<event date='Feb 12 21:09:24' severity='4' hostName='PHA061200027' source='ProgramExec' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='3768' tickCount='8300360' >
  <![CDATA[Starting SWD task: 'Install' command line='"C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{E3FC2F91-FBFF-4E63-A1EB-561A567AE9E1}\cache\Propharm_8_5_2_060.exe" /S']]>
</event>
<event date='Feb 12 21:09:49' severity='4' hostName='PHA061200027' source='ProgramExec' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='3768' tickCount='8325804' >
  <![CDATA[Program 'Install' completed. Exit code=0]]>
</event>
<event date='Feb 12 21:09:49' severity='4' hostName='PHA061200027' source='SimpleThread' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='3768' tickCount='8325804' >
  <![CDATA[SWD Program Execution Thread thread 0xEB8 ending, exit code=0]]>
</event>
<event date='Feb 12 21:09:50' severity='2' hostName='PHA061200027' source='DeliverSoftware_Task::ReportFailureToServer' module='smfagent.dll' process='AeXNSAgent.exe' pid='1576' thread='2100' tickCount='8325882' >
  <![CDATA[Software delivery task failed with exit code: 0]]>
</event>
<event date='Feb 12 21:09:50' severity='4' hostName='PHA061200027' source='Client Task Agent' module='client task agent.dll' process='AeXNSAgent.exe' pid='1576' thread='1780' tickCount='8325898' >
  <![CDATA[CTaskStatusEngine::OnTaskFinished(): Got status for 1a8960b4-5065-4167-b5c2-19976d5d3642]]>
</event>
<event date='Feb 12 21:09:50' severity='4' hostName='PHA061200027' source='Client Task Agent' module='client task agent.dll' process='AeXNSAgent.exe' pid='1576' thread='1780' tickCount='8325913' >
  <![CDATA[CClientTaskStatusCollector::Task: Quick Delivery - Propharm8.5.2build060 has finished]]>
</event>
<event date='Feb 12 21:11:39' severity='4' hostName='PHA061200027' source='ServerSettings' module='AeXNSAgent.exe' process='AeXNSAgent.exe' pid='1576' thread='1624' tickCount='8434989' >
  <![CDATA[Next policy request from server SMP-SRV01.PRIME.TCRHCC.ORG will be at 2014-02-12 22:11:39, in 60 minutes]]>
</event>
<event date='Feb 12 21:14:24' severity='4' hostName='PHA061200027' source='MaintenanceWindowMgr' module='PatchMgmtAgents.dll' process='AeXNSAgent.exe' pid='1576' thread='2636' tickCount='8600350' >
  <![CDATA[isAbidingByMaintenanceWindows() - yes]]>
</event>
<event date='Feb 12 21:14:24' severity='4' hostName='PHA061200027' source='MaintenanceWindowMgr' module='PatchMgmtAgents.dll' process='AeXNSAgent.exe' pid='1576' thread='2636' tickCount='8600350' >
  <![CDATA[okayToDoMaintenance() - 2014-02-12 21:14:24 -7:00 yes]]>

Any solutions would be greatly appreciated!

Thanks!

Operating Systems:

Comments 1 CommentJump to latest comment

Preppietechie's picture

A lot of things can cause this, but I have a suspicion... What success codes did you define in the software package?  By default Altiris expects 0.  Anything else would be a "failed" install.  Take a look at the agent's "task status" tab and click the "task history" button.  Check to see what the return code is for your "failed" install. 

Now go to the software package resource page, click the package tab, and double click the command line you're using for the quick delivery.  Make sure that the success code list includes the code you saw on the agent.