Video Screencast Help

Failed to validate the credentials of vmware

Created: 08 Jun 2012 | 8 comments
AKARAN's picture

Very good morning to all, the issue is as follows:

I installed Backup Exec Server 2012 on Win 2008 R2 updated to date, there is a vmware ESX environment in a cluster, add the server and I have no problem, the problem arises when validating the credentials, it displays two types of messages

1 ° "test failure, recommended test."

2 ° "Unknown, recommended test."

 

The user on windows is Managed, and ESX is root. Help please

Comments 8 CommentsJump to latest comment

AKARAN's picture

The version of Backup Exec is 2012 V-ray Edition

PCC-ICT's picture

Yeah we're having the same issue.

Just can't seem to find the correct credentials to backup our virtual machines successfully.

Symantec please assist!

AshwinApte's picture

Does the REDSISBAQ\backupexec account have permissions on the guest VM's? You may need to provide accounts in the Logon accounts which will have permissions on the individual guest machines and not just on the ESX or the vCenter.

YvieD's picture

Backup Exec should not need to use the ESX host's ROOT credentials. It was designed to authenticate with Active Directory and pass Windows credentials to the vCenter server. In turn, vCenter can then authenticate with ESX on behalf of Backup Exec.  Here is the easiest way to make that work:

1. Take note of the name of the account the Backup Exec Device & Media service is using.

2. In the Backup Exec console, click the BE Button | Configuration & Settings | Logon Accounts.
    a. What is the name of the account listed as the System Logon Account?
    b. What is the name of the account listed as the default account?
(Note: if these three answers are not the same account - change them so that they are)

3. In the vCenter console, highlight the top level -datastore and then open the Permissions tab.  Explicitly add the Backup Exec Service Account with the admin role, then verify that it propagates down to the hosts and to each VM. Now there should be at least two records in that list: "Administrators" and "DOMAIN\YourBEAdminAccount".

Then try again.  

nnsarrdiallo's picture

Hi YvieD,

I'have the same problem with validating the credentials for my VMs.

I've tried to follow your recommandations, and even went further by granting the "DOMAIN\YourBEAdminAccount" Administrator rights on each VM to backup.

Unfortunately, the credentials test is still failing.

OP's picture

I've had the same experience when I needed BE 2012 to use different accounts for different ressources - what helped was:

- modify the settings to the correct account (I've tested the account otherwise)

- save

- leave the window

- renter / retry it.

SCInf's picture

We are currently testing BE 2012 in a replicated testing environment of our production network (so we have the luxury to trash and re-install the product), we are also getting the same issue.

We have tried all the suggestions above, nothing is working, I have opened up a case with Symantec this morning and I am waiting for a technician call back.

We tried the solution that worked for someone in another KB (http://www.symantec.com/connect/forums/be2012-cannot-backup-powered-vmware-vm), removing completly the RAWS agent on our vCenter server and reinstalling it, same issue. We used the following procedure to ensure it was completly removed prior to re-installing (http://www.symantec.com/business/support/index?page=content&id=TECH8798).

This on a fresh installation of BE2012 that we installed this morning, fully updated with LiveUpdate because of multiple other issues that have started occurring over the last day or two on the previous installation. These credentials were working until yesterday the backups started reporting that they could no longer do Incremental/Differential as the VM did not supposedly support it and the jobs were defaulting to full backups (but it had been working with success for about a week).  In addition, we we're having the same issue as described in this post (http://www.symantec.com/connect/forums/grt-file-recovery), all servers were pushed the RAWS agent and were publishing their FQDN to BE but GRT restores were unavailable until we removed and re-added the server manually using the FQDN, but this only worked for 80% of the servers, the remainder could still not get GRT restores going.  Also, one of our DC could not backup the AD with or without GRT despite removing and re-installing the RAWS agent multiple times, removing and re-adding the server to BE using FQDN, NetBIOS, etc...

I can hosnestly say that this is the worst BE version I have ever worked with, and I have been working with Backup Exec since version 10.

 

 

vCenter_Credentials_Failed.PNG
Redha.Hamzah's picture

 

Hi,
 
My workaround;
1. Run LiveUpdate on BE2012 and update to the latest.
2. Reboot SBE2012 host machine.
3. Remove vCenter server from server list.
4. Re-Add vCenter server
5. Specify the backupexec credential login for vCenter server.
 
Note : 
Ensure access right for the credential;
  • Act as part of the operating system
  • allow logon locally
  • Backup files and directories
  • Create a token object
  • Logon as a batch job (Windows 2008 only)
  • Logon as a service
  • Manage auditing and security log
  • Restore files and directories
  • Take ownership of files and other objects
 
And I have made sure it is NOT added under:
  • Deny logon as a service
  • Deny logon as a batch

This work for me.