Video Screencast Help

Failure to add drivers for HP NC373F MultiFunc Gig Server Adapter

Created: 13 Dec 2012 • Updated: 14 Dec 2012 | 4 comments

GSS 2.5 minor version 2113, on Windows 32bit 2K3

As an administrator, I am attempting to build a new bootable CD, with the Ghost app, adding drivers for the above-mentioned NIC to WinPE.

I have not been able to locate Vista drivers, so am attempting to use W2K/W2K3 drivers from HP.

In Boot Wizard, having 'copied' WinPE preOS, I have attempted to Add New Driver.

(The selected directory contains .inf, .cat, .sys files, among others, for W2k and W2K3. The .inf file contains the exact device line, from Device Manager, that I need. It appears that I have properly-formatted .inf files)

From Microsoft's ProcMon, the directory is queried and the .inf files read, but the following messages are returned:

Failed to import driver Friendly

Failed to find any drivers to add.

I have read a number of similar posts and suggestions, on this forum, but to no avail.

What else may Boot Wizard be looking for that it can't find, or is there something else that I am missing?

Thanks, in advance.

Jim

Comments 4 CommentsJump to latest comment

EdT's picture

First of all, the current version of GSS 2.5 is build 2266, which you can get by running LiveUpdate.

I assume the Win 2K3 drivers you are trying to use are 32 bit drivers, which is the requirement.

Have a look at this article: https://www-secure.symantec.com/connect/articles/do-i-have-correct-driver-winpe

It describes the DRVLOAD technique for evaluating candidate drivers which avoids having to keep rebuilding the WinPE disk image.

The INF file should also list any other files that the driver set requires. Check that none are missing.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

J.Watson's picture

Thanks for the response, Ed.

My network is in a closed environment, so I can't LiveUpdate. I am attempting to procure the latest build, but do not expect that for a while and was hoping to perform backups of my system.

Yes, I have 32 bit drivers, for both W2K and W2K3.

I will revisit the INF file to verify nothing was missed and give the suggestions in the article a try.

J.Watson's picture

I have attempted the steps, identified in the document 'do-i-have-correct-driver-winpe', using W2K3 drivers from the HP system installation media, with the following results:

'drvload' was successful

'netsh interface ipv4 set address...' failed with "The filename, directory name, or volume syntax is incorrect"

A 'netsh interface ipv4 show interfaces' resulted in one entry which looked like a loopback.

Any ideas, or suggestions?

Separately, I located a thread which indicated RIS drivers were successful, so I shall give that a try...

 

 

EdT's picture

DRVLOAD indicates that the driver is compatible with the version of WinPE you are running but does not necessarily indicate that it is compatible with the hardware.

The hardware compatibility angle needs the INF file to support the Device ID of the NIC. This article:

https://www-secure.symantec.com/connect/articles/r...

demonstrates a simple utility that will list all plug and play device IDs on a computer, assuming it has a working operating system installed that supports WMI.  Or you can check the device ID of your NIC using Device Manager from control panel.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.