Video Screencast Help
New Company Name and Logo Announced. Learn More.

Failure during backup of Oracle Database on Windows 2008

Created: 06 Oct 2010 • Updated: 19 Oct 2010 | 12 comments
This issue has been solved. See solution.

Hello Backup Exec experts,

We have run into a problem when trying to backup our Oracle database (11g) on our newly installed Windows 2008 R2 32 bits server.
We have gone trough all the configuration settings on the Backup Exec client on the server which we want to backup.
On the media server the Oracle databases are now showing and can be "drilled through".
All the tablespaces show and also the archive logs.
Also the permissions test works OK.

When trying to backup the database we encounter the following error:

<pre>Backup of an Oracle database fails with an error "Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server"</pre>

We also went trough all the suggested options on the support website of Symantec

http://www.symantec.com/business/support/index?pag...

Unfortunately without any luck.

When we take a look at the "Oracle EM Client" we do see our failed attempts.
The details of each attempt show

<blockquote>connected to target database: VGSMTEST (DBID=2855047821)
 
using target database control file instead of recovery catalog
channel ch0: SID=126 device type=SBT_TAPE
allocated channel: ch0
channel ch0: Symantec/BackupExec/1.1.0
 
sent command to channel: ch0
 
 
Starting backup at 06-OCT-10
current log archived
channel ch0: specifying archived log(s) in backup set
channel ch0: starting archived log backup set
input archived log thread=1 sequence=336 RECID=129 STAMP=731670494
channel ch0: starting piece 1 at 06-OCT-10
input archived log thread=1 sequence=339 RECID=132 STAMP=731672223
input archived log thread=1 sequence=338 RECID=131 STAMP=731670495
input archived log thread=1 sequence=337 RECID=130 STAMP=731670494
released channel: ch0
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of backup plus archivelog command at 10/06/2010 10:17:07
 
 
   BEError(0xe0001405) Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine serv
ORA-19511: Error received from media manager layer, error text:
ORA-27028: skgfqcre: sbtbackup returned error
ORA-19506: failed to create sequential file, name="BE_01lporl0_1_1", parms=""
</blockquote>

Anyone got a clue why this is happening?

Thanks for your help,

Regards,

Remko de Koning

Comments 12 CommentsJump to latest comment

CraigV's picture

...check the technote below out and see if it helps you...

http://www.symantec.com/business/support/index?page=content&id=TECH64837

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Remko de Koning's picture

The media server is not installed on the same machine as the Oracle database.

It is installed on a Windows 2003 server. We have also disabled IPV6 on the Windows 2008 server.

Would this change still make a difference?

Remko

Mahesh Roja's picture

The Backup exec job engine service running on media server?

If this Info helps to resolve the issue please Mark as Solution

Thanks

Mahesh Roja's picture

Backup Of an Oracle database fails with an error "Unknown CORBA exception. Unable to contact the media server" if Backup Exec is installed on a Windows Server 2008.

http://www.symantec.com/business/support/index?page=content&id=TECH64837

If this Info helps to resolve the issue please Mark as Solution

Thanks

CraigV's picture

...can you please stop duplicating previous points? I made this point 2 hours before...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Mahesh Roja's picture

IPV6 is the problem

Backup Of an Oracle database fails with an error "Unknown CORBA exception. Unable to contact the media server" if Backup Exec is installed on a Windows Server 2008.

Exact Error Message
Final error: 0xe0001405 - Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server.
Final error category: Resource Errors

The problem is with the failed initialization of the Common Object Request Broker Architecture (CORBA) on the media server.

Ensure that the "::1 localhost" line is present in %Systemroot%\system32\Drivers\etc\hosts file.

Ensure that bit 5 (The 6th bit counting from the right) of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents registry key is not set (if it exists).

In our case the value 0x000000A  (simple A in the regedit) for this key resolved the problem, the port 5633 listen after reboot  and backup executes normally. The sugested value 0x00000FF (FF) dont works for Backup Exec 12.5, as sugested in Microsoft documents about to totally disable IPv6.

For more info refer this discussion its resolved 

http://98.129.119.162/connect/forums/anybody-knows-what-corba-mean

If this Info helps to resolve the issue please Mark as Solution

Thanks

Remko de Koning's picture

Thanks guys, will give this a try tommorow and will let you know the outcome.

Mahesh Roja's picture

Any update?

If this Info helps to resolve the issue please Mark as Solution

Thanks

Remko de Koning's picture

I appologize for my late reply. It has been quite hectic the past week and did not have much time to follow up.
 

The IPv6 entry has been added to the host file and this brought me a step further.

The backup error logs now show a different error.

Error "0xe0001403 - The logon account specified in the Remote Agent Utility cannot be authenticated. Update the entry in the list of authentication credentials on the media server" appears during an Oracle backup job using Symantec Backup Exec for Windows Servers

http://www.symantec.com/business/support/index?page=content&id=TECH54288

I have followed the instructions on above link but also without luck.

I am quite a newbie with Oracle. I am a Windows SysAdmin with limited experience on Oracle. The vendor of the System that has installed Oracle does not have experience with Backup Exec.

This leaves me kind of in the middle of things. Would be great if I could get this stuff working but so far without any luck. 

Any more suggestions I could try?

Thx,

Remko

Mahesh Roja's picture

account should be specified in DOMAINNAME\USERNAME (or SERVERNAME\USERNAME in case the oracle server is part of workgroup and not domain) format under Database Access tab and should match the account specified on the Backup Exec server under Tools-Options-Oracle-Modify List for the Oracle server. 

If this Info helps to resolve the issue please Mark as Solution

Thanks

Mahesh Roja's picture

KB it may help you the above error he has faced after upgrading from 12 to 12.5 and he has resolved 

http://98.129.119.162/connect/forums/be125-win2003-64bit-saving-oracle-10gr2-sles10sp2-fails-e0001403#comment-3609411

If this Info helps to resolve the issue please Mark as Solution

Thanks

Remko de Koning's picture

I am glad to let you know that we have successfully made a backup of our Oracle server.
Using a combination of the tips suggested above we were able to solve the problem.

Thanks so much to all you guys that helped out on this problem. Your help is very much appriciated!

Kind regards,

Remko de Koning

SOLUTION