Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

A failure occurred querying the Writer status.

Created: 22 Jul 2014 • Updated: 20 Aug 2014 | 6 comments
This issue has been solved. See solution.

Dear all,

Since some weeks I have been experiencing this horrible error. I have consulted the Symantec Support pages, but I can find no 'permanent' solution for the environment I am using. Rebooting the server every day is not an option, this is the fileserver that people access remotely almost nearly 24/7. It also doesn't seem to work, the first one or two backups after a reboot work but then it just goes back into the error listen in this threads topic.

There is also a suggestion about freeing more space on C:\, I think there is enough (see below).

My backup server is Windows Server 2008 R2 Standard. It's fully up to date up with the most recent Windows Updates. This is a physical server.

The server I am having trouble with is Windows Server 2012 Standard. It's fully up to date up with the most recent Windows Updates. This is also a physical server.

It has a C:\ drive with 125GB free of 150GB
It has a D:\ drive with 1.6TB free of 1.6TB
It has an E:\ drive with 2.2TB free of 5.5TB

I have attached a screenshot showing the amount of times this server won't backup properly because of the above error. The worst thing about it is because I am backup up such an immense amoutn of data it takes about 25-30 hours to do a full backup. But it doesn't go into error until it's completely done! How can it POSSIBLY give a Writer error status at the very end of the backup process!!

How is that even possible? The writer error is about failing to make a snapshot, why does it not INSTANTLY see that theres a problem and goes into error, why do I have to wait for 30 hours in anticipation to see if the backup software does why I purchased it.

I have 53 servers to backup which takes me over four days, if my fileserver goes into error my entire backup schedule for that week goes out the window. This is becoming increasingly annoying.I don't want to have to come in on weekends because the backup software andomly decides it doesn't want to work.

I'd like to add that my Exchange server also experiences this problem, except not that often. It's just as annoying though as you can understand that if my fileserver gets used 24/7 the Exchange server can't exactly get a daily reboot either. It's even more of a pita to reboot.

All my other servers never have any problems, physical or virtual. Hyper-V or V-Sphere. It just works.

Please advise. Thanks

WriterStatus.jpg

Operating Systems:

Comments 6 CommentsJump to latest comment

VJware's picture

This is a very generic error. Debugging the affected server and checking the event viewer logs on the affected machine at the time of backup failure will help to find out where the issue is.

Are you able to run successful backups repeatedly using the native Windows backup utility ?

Notlupus's picture

I haven't ever used the built-in Backup Software that Windows provides, I would have to set up a schedule and leave that to run for at least a week to check if it works, as the Backup Exec job doesn't ALWAYS fail. Would you recommend this?

Furthermore, at about what time should I check the event logs? Near the start of the backup or when it's nearing completion? We're talking about a 30 hour job so that's a lot of logs to go through!

Thanks for your time.

VJware's picture

I would recommend to expand the job log of the failed backup and check when the VSS error message is being given & correspondingly, you could check those times in the event viewer.

Else, better still, filter the event viewer logs for errors/warnings for that particular day and they should help further.
 

pkh's picture

Disable and then enable shadow copies on the remote server.  If there is a space limit for shadow copies, remove it.

SOLUTION
Notlupus's picture

I have followed your instructions, I will reply to this topic on monday and will report the results. Thanks for the suggestion.

Sorry for the late reply, things have been busy frown

Just wanted to let people here know that this solution right here solved my problems. I've had another server acting up with the same error, and I also fixed that the same way.

Thanks a lot, this problem you may consider solved!

maurijo's picture

"But it doesn't go into error until it's completely done! How can it POSSIBLY give a Writer error status at the very end of the backup process!!"

Snapshotting is freezing and then unfreezinf/commiting the snapshot. Your backups fails at the end meaning that it probably fails to commit the snapshot. Now first I would try if you can snapshot the server using the vcenter (check quiescing) and see if that works consitently and in the hours that your normal backup would run.

Is there anything else accessing the vss writers on the server in your backup window?

Is AOFO checked?

Can you please check the event viewer for further details. It should provide you with some detailed VSS writer errors.