Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

Failure to upgrade from 11.0.7 MP2 to 12.1 RU 1

Created: 20 Jun 2012 • Updated: 21 Jun 2012 | 4 comments
This issue has been solved. See solution.

I have tried to upgrade an 11.0.7 MP2 server to 12.1 RU1 several times now and continue to get the same undesirable results. The installation and configuration wizards finish but the issue I am running into is the SEP Manager Service fails to start. I can manually start it but when I lauch the SEPM console the service stops. If I look at the scm-server-0 log file I see entries stating the Server schema is more recent than the DB schema and I need to rerun the upgrade wizard to bring the DB schema in sync with the server schema. Half the time the wizard will run and say that it's upgrading the schema but I continue to hafve the same issue with the SEP Manager service and see the same entries in the scm-server-0 log file. The other half of the time I cannot even run the wizrd. I get an error saying the schemas are out of sync and it fails. This is a VMware virtual machine so I can roll back to my snapshot, which brings me to 11.0.7 MP2, and try again. Everytime I have the issue with the service failng to start after the upgrade. 

My server is running on Windows 2008 R2. What I did was build a new machine, install, 11.0.7 MP2 and configure replication with my existing 11.0.7 MP2 server so I could replicate all of my policies, groups, and clients. Once I get this working I am going to cut over to the new server then upgrade the original SEPM server. But I can't get past the upgrade of the new server. I am about to kill this server, build a 12.1.x server from scratch and manually recreate all of my policies and slowly migrate all of my clients but I would rather not do that. Can anyone offer an assistance? I have tried upgrading to every version of 12.1 that I can get my hands on through FileConnect.

Thanks all.

 

scm-server-0 log contents after upgrade when trying to lauch SEPM console.

 

2012-06-20 16:49:49.052 THREAD 1 SEVERE: ================== Server Environment ===================
2012-06-20 16:49:49.052 THREAD 1 SEVERE: os.name = Windows Server 2008 R2
2012-06-20 16:49:49.052 THREAD 1 SEVERE: os.version = 6.1
2012-06-20 16:49:49.052 THREAD 1 SEVERE: os.arch = x86
2012-06-20 16:49:49.052 THREAD 1 SEVERE: java.version = 1.6.0_31
2012-06-20 16:49:49.052 THREAD 1 SEVERE: java.vendor = Sun Microsystems Inc.
2012-06-20 16:49:49.052 THREAD 1 SEVERE: java.vm.name = Java HotSpot(TM) Server VM
2012-06-20 16:49:49.052 THREAD 1 SEVERE: java.vm.version = 20.6-b01
2012-06-20 16:49:49.052 THREAD 1 SEVERE: java.home = C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\jre
2012-06-20 16:49:49.052 THREAD 1 SEVERE: catalina.home = C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat
2012-06-20 16:49:49.052 THREAD 1 SEVERE: java.user = null
2012-06-20 16:49:49.052 THREAD 1 SEVERE: user.language = en
2012-06-20 16:49:49.052 THREAD 1 SEVERE: user.country = US
2012-06-20 16:49:49.052 THREAD 1 SEVERE: scm.server.version = 12.1.1101.401
2012-06-20 16:49:49.114 THREAD 1 INFO: Server startup
2012-06-20 16:49:52.645 THREAD 1 SEVERE: The server schema is higher than the database schema. The server will now exit. Run the upgrade wizard to synchronize the schemas.
2012-06-20 16:49:52.692 THREAD 1 SEVERE:  in: com.sygate.scm.server.servlet.StartupServlet
com.sygate.scm.server.util.ScmServerError: The server schema is higher than the database schema. The server will now exit. Run the upgrade wizard to synchronize the schemas.
at com.sygate.scm.server.servlet.StartupServlet.verifySchemaVersion(StartupServlet.java:491)
at com.sygate.scm.server.servlet.StartupServlet.registerServer(StartupServlet.java:357)
at com.sygate.scm.server.servlet.StartupServlet.init(StartupServlet.java:137)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1026)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4421)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4734)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:675)
at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:601)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1317)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1065)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
at org.apache.catalina.core.StandardService.start(StandardService.java:525)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
 
 
I rerun the upgrade wizard and get the following error:
 
Server Schema is newer than database schema. It is recommnded that upgrade wizrds needs to be run to bring schema in sync. Do you want to run the upgrade wizard now?
 
I click Yes and ge the following error:
 
Error 2338560: The Symantec Endpoint Protection Manager 12.1.1101.401 that you are trying to upgrade to does not support your current database. Click this link to view the supported upgrade scenarios.
 
I've already looked at hte upgrade scenarios and am upgrading in a acceptable upgrade path. Any ideas? Screenshots of errors are attached.

Comments 4 CommentsJump to latest comment

Cameron_W's picture

Upgrading from RU7 MP2 to SEP 12.1 RU1 MP1 (12.1.1101.401) is not officially supported. You will want to download and upgrade to 12.1 RU1 first (12.1.1000.157). Then move up to the MP1 build.

If your fileconnect account does not have this build available, please contact support and we can provide FTP information to download this build.

If I was able to help resolve your issue please mark my post as solution.

Mithun Sanghavi's picture

Hello,

EDIT: Check this Article:

Upgrading Symantec Endpoint Protection Manager from SEP 11 RU7 MP2 to SEP 12.1 RU1 or SEP 12.1 RU1 MP1

http://www.symantec.com/docs/TECH189972

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SOLUTION
spasq's picture

Thank you Mithun. I guess I will wait for RU 2 to be released. It's not exactly the solution I was hoping for but I am glad someone was able to shed some light on this for me. At least now I won't be wasting my time trying to get this to work.

SMLatCST's picture

...I don't think this can be done:

http://www.symantec.com/docs/TECH189972

You're gonna have to wait for 12.1RU2 in autumn