Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

A few of my virtual mashines fail.

Created: 17 Sep 2012 • Updated: 10 Oct 2012 | 17 comments
Peter Davidsson's picture
This issue has been solved. See solution.

Donno if this is the place to post but have a virtul mashine that keeps failing with this error.

I have googled for info about this but can't find anything.

2012-09-15 00:57:43 - Info nbjm(pid=5168) starting backup job (jobid=5386) for client H_SEMALFIL01, policy Saturday_0000, schedule Full 
2012-09-15 00:57:43 - Info nbjm(pid=5168) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=5386, request id:{3D38F93F-579F-4B31-8564-259E81DE07C1}) 
2012-09-15 00:57:43 - requesting resource Dedup
2012-09-15 00:57:43 - requesting resource win-netbackup01.sydit.inet.NBU_CLIENT.MAXJOBS.H_SEMALFIL01
2012-09-15 00:57:43 - requesting resource win-netbackup01.sydit.inet.NBU_POLICY.MAXJOBS.Saturday_0000
2012-09-15 00:57:43 - Info nbrb(pid=4260) Limit has been reached for the logical resource win-netbackup01.sydit.inet.NBU_POLICY.MAXJOBS.Saturday_0000   
2012-09-15 00:58:49 - Info bpbrm(pid=6024) H_SEMALFIL01 is the host to backup data from    
2012-09-15 00:58:49 - Info bpbrm(pid=6024) reading file list from client       
2012-09-15 00:58:49 - Info bpbrm(pid=6024) starting bpbkar32 on client        
2012-09-15 00:58:49 - granted resource win-netbackup01.sydit.inet.NBU_CLIENT.MAXJOBS.H_SEMALFIL01
2012-09-15 00:58:49 - granted resource win-netbackup01.sydit.inet.NBU_POLICY.MAXJOBS.Saturday_0000
2012-09-15 00:58:49 - granted resource MediaID=@aaaab;DiskVolume=PureDiskVolume;DiskPool=Dedup;Path=PureDiskVolume;StorageServer=win-netbackup01.sydit.inet;MediaServer=win-netbackup01.sydit.inet
2012-09-15 00:58:49 - granted resource Dedup
2012-09-15 00:58:49 - estimated 0 Kbytes needed
2012-09-15 00:58:49 - Info nbjm(pid=5168) started backup (backupid=H_SEMALFIL01_1347663529) job for client h_SEMALFIL01, policy Saturday_0000, schedule Full on storage unit Dedup
2012-09-15 00:58:49 - started process bpbrm (6024)
2012-09-15 00:58:49 - connecting
2012-09-15 00:58:49 - connected; connect time: 00:00:00
2012-09-15 00:58:53 - Info bpbkar32(pid=8544) Backup started          
2012-09-15 00:58:53 - Info bpbkar32(pid=8544) CONTINUE BACKUP received.         
2012-09-15 00:58:53 - Info bptm(pid=8144) start           
2012-09-15 00:58:53 - Info bptm(pid=8144) using 262144 data buffer size       
2012-09-15 00:58:53 - Info bptm(pid=8144) setting receive network buffer to 1049600 bytes     
2012-09-15 00:58:53 - Info bptm(pid=8144) using 30 data buffers        
2012-09-15 00:58:54 - Info bptm(pid=8144) start backup          
2012-09-15 00:58:55 - begin writing
2012-09-15 01:07:28 - Error bpbrm(pid=6024) socket read failed, An existing connection was forcibly closed by the remote host.  (10054)
2012-09-15 01:07:33 - Info win-netbackup01.sydit.inet(pid=8144) StorageServer=PureDisk:win-netbackup01.sydit.inet; Report=PDDO Stats for (win-netbackup01.sydit.inet): scanned: 1686787 KB, CR sent: 130844 KB, CR sent over FC: 0 KB, dedup: 92.2%
 
2012-09-15 01:07:34 - end writing; write time: 00:08:39
file read failed(13)

Comments 17 CommentsJump to latest comment

Peter Davidsson's picture

That i'm backing from or to?

It's a san i'm backing from and to a san with nbu.

Alex Zn's picture

Look here  http://www.symantec.com/business/support/index?page=content&id=TECH37372

What version of NetBackup do you use?

Is there any VMs that fails to backup hosted on the same datastore as thouse that successfuly backed up?

Alex Zn's picture

Look from side of vCenter what kinde of error messages do you see? Is there some activities like snapshot creation or quiscense?

Peter Davidsson's picture

The version is 7.5.0.3

cant see any problem on my vcenter.

Yes i can see when nbu makes a snapshot and no problem there.

It starts backing up and after a while it stops with this error.

The vm's that are failing are on different Luns on same san.

 

Thanks for trying to help me.

Alex Zn's picture

1. Check if LUN with this virtual maschines are mapped to media server.

2. Check if media server may see this LUNs.

3. Test if behaviour the same for all media servers, you may choose which media server to use via VMware tab in policy.

I had the same problem with my windows media server, windows did not saw mapped lunes till reboot.

 

 

revaroo's picture

NetBackup never makes a snapshot, it requests the VM to make it. 

Peter Davidsson's picture

We only have a Master/media server and this server can see all luns.

For now it's only used for backing up vm's.

We are currently backing about 240 vms and have about 11 vms that fails with this error.

 

Have tested to queze the job as well but get the same result.

Alex Zn's picture

Ok try the next - move your problem VM to another datastore, from which backup perform without problems. If case in some LUN (datastore), then you may unmap this LUN from media and map it again. 

Peter Davidsson's picture

Ok i will give that a try and see what happens.

 

Peter Davidsson's picture

Actually I did move a server from one datastore to another and that did not work either.

Same result this night.

Alex Zn's picture

And if in this new datastore some VMs that backup normaly?

Peter Davidsson's picture

Found this.

http://www.symantec.com/business/support/index?page=content&id=TECH194976&actp=search&viewlocale=en_US&searchid=1348055751523

 

But i can actually not see what to do.

Maybe im just dumb.

I understand that i need to stop the services and copy the dll file but when it comes to replacing the files i get stuck because i don't know with what files.

 

 

Stuart Green's picture

Had a look myself and its not clear...

the above TN states that

Solution

Symantec Bug ID: 2867910 
NetBackup 7.5.0.3  AMD64 

Windows Deliverables: 
-- 
\VxMS\Map\rvp\rvpntfs.dll 

Installation: 
-- 
1) stop the NetBackup services 
2) copy the existing files that is being replaced \VxMS\Map\rvp\rvpntfs.dll and move it to another directory 
3) install the files listed above into the proper destination directory 
NOTE: the newly-installed files must have the same file permissions  and owner as the original files! 
4) start the NetBackup services

 

 

The TN links to a EEB but that deals with a different dll. Certainly strange.

You could review the Late Breaking News for other EEB's for your version

http://www.symantec.com/business/support/index?page=content&id=TECH74904

Contact support if you feel this rvpntfs.dll issue will fix your problem. Doesnt look like a straight replacement if this TN IS the advice to take. But not explained that way.

Tip: Get overview/document your NBU environment. Run 'nbsu' and review the output.

• If this provides help, please vote or mark appropriate solution.

CRZ's picture

This TechNote looks incomplete, and probably should not have been published.  The EEB it mentions - which is NOT the one in TECH191198 - is currently only available from support.

I would recommend opening a support case, providing logs and requesting an escalation to backline to obtain the EEB mentioned (Etrack 2867910).

All of these fixes will be in 7.5.0.4 as well, so when IT is available, you should be able to just upgrade to make all these problems go away.  (He said, while knocking on wood and whistling...)


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
Peter Davidsson's picture

Thanks.

 

I will open a case with support and see what happens.

Thanks so far.

I will post the result later.

Peter Davidsson's picture

Hi 

The patch 7.5.0.4 did solve some of my problems.

 

And after we had to forcerestart a few server they allso worked.