Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

File Archiving task suddenly stops proccessing any folders ?

Created: 02 Jul 2012 • Updated: 02 Jul 2012 | 25 comments

we are running Enterprise Vault version 9.0.2 on 3x Windows server 2003.

we run 5 file archiving tasks, 4 of which run and process files / folders no problem. however, 1 of the tasks has stopped proccessing any folders, when i check the status tab the results are all zero.

any help would be much appreciated,

cheers,

Comments 25 CommentsJump to latest comment

LCT's picture

Check the file server that is not archiving and make sure that EV FSA services are running? Check the event log on this file server too.

Run the FSA task that is not archiving with Run now in report mode, and then run it again in normal mode but use dtrace, check the dtrace to see if it reports any issues.

Rob Brenner's picture

The Archiving Task report log should tell you why it is not processing anything. The EVT logs should also give you a hint.

Are the targets assigned to the Task enabled?

If you cannot find the reason with the suggestions above, you should try to set Dtrace to capture verbose processing from EVFSAArchivingTask process and look for errors or exceptions in the output log.

Rob Brenner's picture

If the targets assigned to the relevant Archiving Task cannot be processed in one schedule window, the Task will continue on the next schedule, following the checkpoint logic for where the last item was processed in the previous run. it may be possible that the previous run did not find any eligible items for processing.

Robbie_Rob's picture

Hi, thanks for your advice, here are the dtrace results:-

151 10:13:52.868  [3424] (StorageOnlineOpns) <8956> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
152 10:13:52.884  [3424] (StorageOnlineOpns) <8956> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
153 10:13:56.087  [3424] (StorageOnlineOpns) <5648> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
154 10:13:56.087  [3424] (StorageOnlineOpns) <5648> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
455 10:17:56.306  [3424] (StorageOnlineOpns) <8612> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
456 10:17:56.321  [3424] (StorageOnlineOpns) <8612> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
457 10:17:56.337  [6636] (ArchiveTask) <5704> EV~W Event ID: 2270 A queued operation exceeded the retry count and has been discarded|m_pIBackgroundArchivingAgent->ProcessMovedItemsInFolder2(ExchangeMailboxDn = "/o=NHS Trent/ou=Laurie House Administrative Group/cn=Recipients/cn=Rachel_Owen",|  ArchiveID = "13DF8A4170F69E341A7D4B1359E2489F11110000DSSEVServer1",|  ArchiveFolderID = "1FECD22F8F6F7944BBC533DFA7037509E1110000DSSEVServer1", |  FolderRetCat = "", |  SourceFolderID = "ID", |  FolderPathName = "�Inbox�Cardinal Moves", |  CompressedItemRequestXML = "some XML", |  EVPMFolder = "FALSE")|HRESULT: 0x80004005 |
458 10:17:56.962  [3424] (StorageOnlineOpns) <9156> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
459 10:17:56.977  [3424] (StorageOnlineOpns) <9156> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
460 10:17:57.290  [6636] (ArchiveTask) <5704> EV~W Event ID: 2270 A queued operation exceeded the retry count and has been discarded|m_pIBackgroundArchivingAgent->ProcessMovedItemsInFolder2(ExchangeMailboxDn = "/o=NHS Trent/ou=Laurie House Administrative Group/cn=Recipients/cn=Jonathon_Rycroft",|  ArchiveID = "1B127C32DAC5B0C498A06B8BA706B93DE1110000DSSEVServer1",|  ArchiveFolderID = "1182561EA6F30DA46BCD10C4D53899A841110000DSSEVServer1", |  FolderRetCat = "", |  SourceFolderID = "ID", |  FolderPathName = "�Inbox�Delivering today�DSIP�QIPP Audit", |  CompressedItemRequestXML = "some XML", |  EVPMFolder = "FALSE")|HRESULT: 0x80004005 |
461 10:20:34.493  [3424] (StorageOnlineOpns) <7564> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
462 10:20:34.509  [3424] (StorageOnlineOpns) <7564> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
463 10:21:43.946  [3424] (StorageOnlineOpns) <3572> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
464 10:21:43.962  [3424] (StorageOnlineOpns) <3572> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
466 10:24:01.321  [3424] (StorageOnlineOpns) <7412> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
467 10:24:01.321  [3424] (StorageOnlineOpns) <7412> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
468 10:24:01.337  [5120] (ArchiveTask) <3452> EV~W Event ID: 2270 A queued operation exceeded the retry count and has been discarded|m_pIBackgroundArchivingAgent->ProcessMovedItemsInFolder2(ExchangeMailboxDn = "/o=NHS Trent/ou=DSS SDERBY AG/cn=Recipients/cn=Rakesh_Marwaha",|  ArchiveID = "1349D9654582E0844AE637DB49C44265C1110000DSSEVServer1",|  ArchiveFolderID = "1A034A4EA6A00794CB6FBCD37DDD833821110000DSSEVServer1", |  FolderRetCat = "", |  SourceFolderID = "ID", |  FolderPathName = "�Inbox�Top Leaders Programme", |  CompressedItemRequestXML = "some XML", |  EVPMFolder = "FALSE")|HRESULT: 0x80004005 |
469 10:25:10.977  [3424] (StorageOnlineOpns) <9856> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: LE/RE |
470 10:25:10.993  [3424] (StorageOnlineOpns) <9856> EV~E Event ID: 6578 Abnormal error occurred | |Object:    CRetentionCategoryCache |Reference: RE(1)/fe |
471 10:25:11.821  [5120] (ArchiveTask) <5516> EV~W Event ID: 2270 A queued operation exceeded the retry count and has been discarded|m_pIBackgroundArchivingAgent->ProcessMovedItemsInFolder2(ExchangeMailboxDn = "/o=NHS Trent/ou=Laurie House Administrative Group/cn=Recipients/cn=Rachel_Owen",|  ArchiveID = "13DF8A4170F69E341A7D4B1359E2489F11110000DSSEVServer1",|  ArchiveFolderID = "1B69993A2D35D2A43A88478F3B04D65471110000DSSEVServer1", |  FolderRetCat = "", |  SourceFolderID = "ID", |  FolderPathName = "�Inbox�Laurie House", |  CompressedItemRequestXML = "some XML", |  EVPMFolder = "FALSE")|HRESULT: 0x80004005 |

**** DTrace exit - log terminated

i have had a quick look on the symantec knowledge base and the result was - fixed in version 10 !

this however is not an option,

your help is much appreciated,

thanks,

LCT's picture

In that case you will need to log a case with Tech Support and request a hotfix for your issue with EV9.0.2. Do you have the knowledge base that says it is fixed in EV10? Rob will be able to look it up in Etrack and let you know if there was a hotfix for EV9?

Robbie_Rob's picture

here is the article http://www.symantec.com/business/support/index?page=content&id=TECH158365

i have EV9.0.4 ready to upgrade too but i need to plan some down time to do that and wanted this issue fixed first.

cheers,

Rob Brenner's picture

Robbie_Rob, you need to dtrace the correct process

Rob Brenner's picture

LCT, I would suggest that the idea of requesting a Hotfix for 9.0.2 could end up setting unrealistic expectations. The process of determining the justification for a Hotfix takes many factors into consideration.

Rob Brenner's picture

Robbie_Rob, I see from your comments that you seem to have the 9.0.4 binaries already. Please note that we recently announced issues with EV 9.0 SP4 and we encourage customers not to upgrade until further notice. New binaries will be made available.

TypoProne's picture

Hey Rob.

Can you provide some insight on why there is discouragement to upgrade and how we can track when it is reccomended again?

Sorry for pinging on a dead thread but I thought it was better than starting a new one for it.

TonySterling's picture

This is an old comment that was that was referring to this.

https://www-secure.symantec.com/connect/forums/ent...

The issue was resolved long ago and the EV 9.0.4 has been re-released as EV 9.0.4 R1 and is good to go.

Robbie_Rob's picture

is '22  - EvFsaArchivingTask' not the correct process ?

cheers,

Rob Brenner's picture

We generally recommend upgrading to the latest build available. With regard to the issue you are reporting, there is no direct indication that 9.0.3 would resolve it. If you have the possibility to upgrade to 9.0.3 i would not discourage you as there have been a few fixes on the FSA side, but I would recommend waiting for 9.0.4 as you would benefit from major FSAUtility fixes and enhancements.

I would still insist that you should dtrace again as the dtrace lines you posted seem to be related to normal e-mail archiving processing. The issue you highlighted in the TECH article relates to e-mail archiving.

For proper identification of why your FSA Archiving Task is not processing anything you should dig a bit further

Rob Brenner's picture

EvFsaArchivingTask yes, indeed, as mentioned before, but you seem to be also capturing under other processes which will only add noise to the dtrace

Robbie_Rob's picture

I stopped all tasks running in EV apart from the task to dtrace, i have attached the resulting log file,

cheers,

AttachmentSize
DCHSArchive.txt 5.82 MB
Rob Brenner's picture

Did you find anything?

As I mentioned on my first response, the Archiving report log would tell you what's happening. Have you looked at the report log?

The dtrace you sent shows that the Task is still trying to locate where it last stopped processing in the previous run.

No issues really. the dtrace ends with:

**** DTrace exit - log terminated

My conclusions here are that the Task may have multiple Volume targets and cannot complete the run in one schedule window.

Either you split the volumes among multiple new FSA Archiving Tasks or you need to wait until the entire set of targets are walked through.

Robbie_Rob's picture

i have split the file archive tasks so only one task runs per night and all tasks run on Sunday, i have given them a week or so to sort them selves out and still one task does nothing. It does not process any files or folders and hasn't since 12/4/12.

where do i access the Archiving report log? i may have already looked at it but wanted to check,

thanks,

Rob.Wilcox's picture

>> Jumping in <<

It is in the REPORTS subfolder of the EV installation folder ..

Hope that helps,

Rob.Wilcox's picture

(Oh) and if you suspect that one task is doing nothing ...  check it's not set to run in report mode, and, check what happens if you run it manually (via the report, and via DTRACE)

Robbie_Rob's picture

Thanks for Jumping in Rob,

i have studied the reports and the line below is from the report of the task that does nothing:-

No items were matched by any rule. Some files may have been ignored because of policy permission settings.

and the results are as follows:-

Total volumes processed:     1
Total folders processed:     0

Total number of files matching an archive rule:               0
Total number of files matching an archive and copy rule:      0
Total number of files matching a do not archive rule:         0
Total number of files matching a delete rule:                 0

Total files that matched a rule and were processed successfully:      0 (0.00 MB)
Total files archived:                                                 0 (0.00 MB)
Total files excluded by a do not archive rule:                        0 (0.00 MB)

Shortcut Creation
Total number of files matching a 'Create Shortcuts Immediately' rule:       0
Total number of files matching a 'Create Shortcuts Later' rule:             0
Total number of files matching a 'None. Archive and Delete File' rule:      0

Total errors reported: 0

Processing of all volumes is complete.

Start time: 25/08/2012 19:00:22
End time:   26/08/2012 12:29:41
Elapsed Time: 17:29:19

your help is much appreciated,

thanks,

Rob.Wilcox's picture

Have a look in your policy then for this:

The permissions tab ...  is set to 'ignore' or 'archive them' ?

Robbie_Rob's picture

The Volume and folder policies are both set to ignore files that have explicit permissions.

Rob.Wilcox's picture

Fairly sure that is what is happening here then... the items in the folders are being ignored because they have explicit permissions set on them. I'd suggest you try it in a lab.