Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Filling up LTO5 Tape for incremental

Created: 15 Mar 2013 • Updated: 16 Apr 2013 | 7 comments
This issue has been solved. See solution.

 

Good Day!!

Just a quick question if any have any thoughts/suggestions on the scenario below:

We have some incremental backup that needs to be send offsite - MWF.  I created an SLP that will do duplication to LTO5 tape. I had the storage unit setup to use one(1) drive of the tape library to make sure that it fills up the whole tape before writing to another but every time I check the jobs, it does not fills up the tape. Like today,the total size of the incremental backup is 92GB which should fit into one(1) LTO5 tape but it uses two tapes.

We use a T950 tape library that has ten(10) drives.

Any settings that I miss to configure?

 

 

Operating Systems:

Comments 7 CommentsJump to latest comment

sazz.'s picture

It seems you are running the backup of multiple retentions and that is reason it is going to different tapes. By default allow multiple media retentions are unchecked and should not be used as it has its own prons and cons.

Trix Lopez's picture

Where can I see that setting  - Allow Multiple media  retention setting - in Netbackup? 

RLeon's picture

Try changing the partially full media property of the offsite pool (right click on it).

 

Sometimes it may appear that the above still would not work, and that would be due to the following:
http://www.symantec.com/business/support/index?pag...

To paraphrase:
The max number of partially full media setting in a pool acts on each of the unique combinations of the following properties associated with a media and the images written inside:
 - Media server (this one was left out in the technote...)
 - Retention level
 - Robot
 - Drive type
Frozen, suspended, and imported media do not count against Maximum number of partially full media.

 

For the two partially full medias (tapes) in your case, check to see if they have the same retention level or media server (media owner, server group, last write host).
If just one of them is different, it is counted as a different combination, and will therefore have its own set of partially full medias.

Trix Lopez's picture

I will review the retention level/media server on the incremental offsite policies. 

How would I determine what number to put on the - maximum number of partially full media ?? Not sure what that field is for?

RLeon's picture

You can try setting the max partially full value to 1, because that is what you said you are aiming to achieve.
By setting it to 1, it forces NetBackup to always use the same tape until it is full, only then, will another new tape be used.
As you can see, there would always be only one partially full tape in the pool at any one time.

 

But as said above, if you have different combinations of the tape properties in the same pool, then the max partially full setting will act on each combination separately.
That means if you are writing backups with different retentions to the pool, then you will see NetBackup use a new tape even when one isn't full - even when the max partially full value is 1.

 

The Allow multiple retentions per media setting can be found in host properties > master > media properties. It is disabled by default, and in most cases should be left that way.

If it is enabled, backups with short retentions in a tape will be held up by backups with longer retentions in the same tape.
Even when the short retention ones have expired, NetBackup cannot reuse the tape unless all backup images in the tape have expired.
This is why enabling this setting may cause more tapes to be used in the long run, because tapes do not get reused as early.

SOLUTION
Trix Lopez's picture

I will look into that max partially full value set to 1 for that volume pool that we are using for the Incremental Offsite and see how it goes. 

Trix Lopez's picture

Rleon - Thank you very much  for the help. Setting  Maximum number of partially full media  to 1  on the Volume Pool we created resolved the issue. I've been testing it for two(2) weeks and it is getting all the incremental offsite to a 1 to 2 tapes as what we calculated.