Video Screencast Help

Fingerprint Database Backup

Created: 17 Apr 2013 • Updated: 21 Jun 2013 | 14 comments
r3v0ke's picture
This issue has been solved. See solution.

Hello again,

I getting an error saying that my Fingerprint database is not backep up, but it is!

Actually the problem is when it checks if the database is backep up or not, the last check was 7 days ago, an even if I re-run the checks, it stays stucked on the last time and date of 7 days ago...

Here is a printscreen

fingerprint.png

 

Any suggestions ? Thanks in advance

Operating Systems:

Comments 14 CommentsJump to latest comment

Rob.Wilcox's picture

The EV System Status screen is getting this information directly from SQL.

Take a look at these links for queries that get this information more directly, and it'll mean something to a SQL DBA, and perhaps help you resolve the issue:

http://havardkristiansen.com/?p=96

http://www.mssqltips.com/sqlservertip/1601/script-to-retrieve-sql-server-database-backup-history-and-no-backups/

r3v0ke's picture

But the EV system isn't updating... It says that the last run was 4/10, when actually I ran one today....

Rob.Wilcox's picture

What do the SQL scripts say? Did you do the steps necessary in the backup to process the transaction log (like the message in the System Status window says)?

r3v0ke's picture

Here it is, as you can see, all updated

databaseUP.png

Rob.Wilcox's picture

And if you re-run the System State checks, what happens?

What happens if you close and re-open the VAC?

r3v0ke's picture

When I re-ran the checks all other status are updated, but those about these fingerprints don't...

Rob.Wilcox's picture

hm, I'm not in front of a SQL db or Vault server at the moment (and won't be until Sunday, unfortunately). Perhaps some others from the forum will offer some help shortly.

r3v0ke's picture

It seens that now it is updating the status, but now I got this problem:

The SQL database transaction log for Vault Store 'Mail Archiving' has used 99% of its allocated space

.The fingerprint database 'EVVSGMailArchiving_1_1' transaction log for Vault Store Group 'Mail Archiving EZSV125' has used 99% of its allocated space.
 

Both recomendations actions are "perform a backup", but the backups are updated ;_;

Rob.Wilcox's picture

Hmm I'd say that the transaction logs need to be made bigger - or truncated - but I'm not a SQL expert.

Nups's picture

Kindly check the following link if you are using BackupExec to backup the EV databases:

http://www.symantec.com/business/support/index?page=content&id=TECH154061

This may help to tackle both the issues.

Thanks and Regards, Backup Exec, BESR, Enterprise Vault

r3v0ke's picture

I'm using NetBackup actually, but thank for the reply

steve_ev's picture

Looking at the backup status in your screenshot, it looks like you're backing up the databases and logs on different days (e.g. MailArchiving DB on 16/04, log on 17/04).  This may account for the inconsistencies you're getting in the EV alerts.

So I'd check your backup job and make sure you backup the database and logs as part of the same backup.  The same goes for SQL maintenance tasks, I have seperate tasks as part of the same job.

Truncate the logs down manually also to give the backup software a chance to keep the transaction logs down to a decent size.  If the EV databases are on SQL 2008 and later, the easiest way is to change the recovery mode to simple, then run DBCC SHRINFILE against the log file, then set it back to full.  If SQL 2005 and earlier, run a BACKUP LOG WITH TRUNCATE_ONLY, then DBCC SHRINKFILE.

Hope this helps.

SOLUTION
Nups's picture

Also check if the Netback job has any errors/warnings for this particular job.

Thanks and Regards, Backup Exec, BESR, Enterprise Vault

Rob.Wilcox's picture

Is this issue now resolved, or is more help needed?