Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Format of input for GetComputerNameByIPAddress

Created: 01 Mar 2011 • Updated: 09 Mar 2011 | 4 comments
This issue has been solved. See solution.

The input of this method is a string but I cannot find the correct format and keep getting the following error:

System.Web.Services.Protocols.SoapException: Server was unable to process request. --> System.FormatException: Input string was not in a correct format.

   at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)

   at System.String.System.IConvertible.ToInt32(IFormatProvider provider)

   at System.Convert.ToInt32(Object value)

   at System.Data.Common.Int32Storage.Set(Int32 record, Object value)

   at System.Data.DataColumn.set_Item(Int32 record, Object value)Couldn't store <> in workitem_managed_object_id Column.  Expected type is Int32.

What is the correct format for the input string. 

Comments 4 CommentsJump to latest comment

coloup's picture

I don't have an answer but I get exactly the same error message (although mine faIls with a toString violation) with the SearchIncident component. It expects a string, i supply a string but it errors

Rob Moore's picture

I'm not sure where the component is pulling the data from, but it appears to be calling a workitem table:

workitem_managed_object_id

I've tried the component, and it takes the IP address in dotted format: 172.31.16.123

it returned the DNS name of the server...

scottwed's picture

When you asked this question before in another thread, my last reply was a working example (at least on WF 7.1).  Have you tried the sample syntax yet?

http://www.symantec.com/connect/forums/format-input-string-getipaddressbycomputername

If you have tried it, have you verified that you aren't accidentally trying to use an empty or null value in the input parameter?  Try tracing the value in debugger, outputting it to a temporary form, or writing it with the  logging component immediately before using it.

Scott Wedekind

SOLUTION