Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Fragmentation issue after upgrade

Created: 17 Mar 2010 • Updated: 14 Aug 2010 | 2 comments
This issue has been solved. See solution.

We recently upgraded, first from 5.x to 6.x, then from 6.x to 6.5.5. Now our vault policy is producing errors (191, 1 and 306) and skipping images, when you look at the error it seems it is a fragmentation issue:

03/16/2010 19:01:42 - Critical bptm (pid=9430) Amount of data read (2488832) does not match the fragment kbytes (4000000) for backup id client_1268388701, copy 1, fragment 2
03/16/2010 19:01:45 - Error bptm (pid=20763) media manager terminated by parent process
03/16/2010 19:01:58 - Error bpduplicate (pid=22899) host florence backup id client_1268388701 read failed, media read error (85).
03/16/2010 19:01:58 - Error bpduplicate (pid=22899) host florence backupid client_1268388701 write process failed, client process aborted (50).
03/16/2010 19:01:59 - Error bpduplicate (pid=22899) Duplicate of backupid client_1268388701 failed, client process aborted (50).

I found this exact error in a tech note that dealt with 5x and said it was a fix in the later packages, but have not found anything that deals with 6.5x. We've tried changing the fragmentation size on all servers so that they match. Also tried to turn on the Preserve Multiplexing feature and vault didnt like that and refused to backup anything. We've shut down the NBU daemons on all the media/master server(s) and still no change.

Currently waiting on symantec and thought I'd try my luck here.

Comments 2 CommentsJump to latest comment

thesanman's picture

I had the same issue way back in 2006, after we upgraded to V5.1 MP5 (Solaris); there was a fix to something but I can't recall and the e-mail trail is missing the important bit about the patch provided.

But my thought here is; when you upgraded from V5.1 through V6 to V6.5.x; did you upgrade the VLT package on your Master server too?  If not you should do so.

Sounds like you still have an old V5.1 image floating around somewhere.

NBU v7.5.0.6 Master and Media servers on RHEL 5/6 & Win2008; SAN based LTO3, 4 and 6 tape libraries
Linux, Solaris, Windows and OpenVMS clients.
PureDisk, SLP, VMware, HyperV, Oracle, Netezza, SQL/Server,

antshippley's picture

Im still not sure what caused it or the why, but turning on the alternate read server and then pointing it to the master fixed the fragmentation issue.

SOLUTION