Video Screencast Help

Fresh CA 9 install - EV binaries install fails with error report

Created: 23 Nov 2010 • Updated: 23 Nov 2010 | 5 comments
This issue has been solved. See solution.

I'm trying to install Compliance Accelerator 9.0 on a server to replace our existing CA server (newer/betterer hardware).  I've looked through the prerequisites and have started the Enterprise Vault 9.0 install to get the binaries on the new server.  Since this is only going to be a CA server, there is no reason I need to install MSMQ or make the suggested registry changes for MSMQ permissions/memory.

*BUT* It currently looks like if I don't install MSMQ I will not be able to install the EV binaries to get CA installed.  When I run EV setup, it checks for the prerequisites, throws up an error report to tell me I don't have MSMQ installed but won't let me continue.  I applaud that setup now checks and won't let me move forward unless things are squared away but there should be a switch or checkbox to tell setup I'm installing it as the base for CA or DA.

I do not want to install components on the server that I don't need for the software to run.  I would be happy to know I am simply missing something but it doesn't seem that way.

Any input would be appreciated, as always!

Comments 5 CommentsJump to latest comment

TonySterling's picture

Install the EV API Runtime instead.

It will be in the install media in the API Runtime folder.

It works great and you don't need to worry with pre-req'a like MSMQ.  :)

SOLUTION
Mohawk Marvin's picture

+1 for Tony, in all the CA and DA installs I now do I always use the API for the exact reason of not having to go thru EV's pre-reqs

BigAnvil's picture

Tony,

Thanks for the blazing-fast response!  Out of curiosity, is that in the documentation somewhere?  I do find it a bit frustrating trying to find information like this outside the forums.

TonySterling's picture

It is in the install guide in the pre-req section for CA and DA

If Discovery Accelerator is installed on a separate
computer from Enterprise Vault, you must install the
Enterprise Vault software on the Discovery Accelerator
computer. You require one of the following:
■ Enterprise Vault 8.0 (or later) Services
■ Enterprise Vault 8.0 (or later) API Runtime

BigAnvil's picture

I just needed that to point out my stupidity (like I was saying earlier!)...  I read over that part of the doc too quickly and just assumed I run the EV setup file - didn't look for an API Runtime install.

Thanks again.