Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

FSAUtility restores files with no placeholder associated

Created: 24 Oct 2013 • Updated: 24 Oct 2013 | 9 comments
This issue has been solved. See solution.

Hi all,

I need to restore completely some folders. I'm using FSAUtility for doing it. But I have a problem: some items are been restored without having a corresponding placeholder. This items are there because some times I get this kind of message:

"Failed to determine whether to delete an archived file following the deletion of its placeholder. The archived item will not be deleted."

So the fact is:

- One day a user delete some files (that were archived)

- For some reason, that I still don't know, the placeholder was deleted but the archived item was not deleted, remaining there.

- Now, when I restore the whole folder, that "ghosts" files appear again and they shouldn't

Whay can I do? How can I restore only the files that have a placeholder in the original location?

Thanks in advanced and best regards.

//JA

Operating Systems:

Comments 9 CommentsJump to latest comment

Rob.Wilcox's picture

Which options are you using with FSAUtility?

You could always consider our FSA Migrator product - that can use the source file system as the 'source' for data extraction rathe than EV (which is what FSAUtility appears to be using)

JuanAntonio's picture

This is the command I'm using:

Fsautility -t -s \\svr-fls-03\hplc$\ID-Bioanalysis -f -l 0

I'll take a look at the product you say. It makes sense to restore based on the source data rather than on the archived data (as FSAUtility does).

Thanks.

JuanAntonio's picture

I don't have "-b" option (at least as far as I can read in the Utilities guide. We're using EV 9.0.4. Maybe is an option of EV 10?

What is that option for exactly?

Rob.Wilcox's picture

Yes you do.

-b, page 163 of the Utilities Guide from 9.0.4 documentation.

GabeV's picture

Hi JuanAntonio,

Take a look at this technote:

Recalling files corresponding to placeholders
http://www.symantec.com/docs/HOWTO37840

You can use FSAUtility with the -b parameter to recall files corresponding to placeholders present in a folder.

As Rob mentioned, the -b parameter will restore the archived file only if the placeholder if present in the folder. However, you might want to troubleshoot the delete-on-delete process. Based on your description, you might want to take a look at this technote:

Delete on Delete (DoD) feature cannot process delete request of all items from the Archive
http://www.symantec.com/docs/TECH182634

This technote states that this issue was fixed in 9.0.4, but since you mentioned that you are running this specific version, you might want to open a ticket with support to assist you further.

I hope this helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

JuanAntonio's picture

Thanks Rob.

There's no "-b" option on that page of my guide. This is what it says about the syntax:

FSAUtility -t -s UNC_path [-D mm-dd-yyyy] -d UNC_path [-e ext_list] [-f] [-l log_level] [-r]

I have tried directly in a command propmt and there it is, the "-b" option. I'm goingto try.

By the way, is it possible to get a trial of your FSA Migrator product? I'd like to test it.

Thanks.

JuanAntonio's picture

Thanks GaveV.

I'm gonna try with that "-b" option (I still don't know why it's not described on my Utilities guide for 9.0.4 version). I think it does really what I need.

I had the problem with the delete-on-delete process since we started with EV 9.03. That' s the reason we did change to 9.0.4, but the problem still remains.

The  file servers were we have the data we're archiving through EV are old NetApp filers (FAS250 and FAS270) running Data ONTAP 7.2.7. Now we have bought two FAS 2240-2. We are just in the process of migrating the data (that's why I want to restore everything before starting to archive again). I hope this problem will be solve in the new environment. 

JuanAntonio's picture

The "FSAUtility -b" works great. It restore files looking at the source placeholders, not at the archived items.

Thanks a lot.

//JA