Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Get VCS WARNING V-16-10031-9509 every 5 seconds

Created: 07 Feb 2013 • Updated: 20 Feb 2013 | 6 comments
This issue has been solved. See solution.

I get the following error every 5 seconds in the /var/VRTSvcs/log/ProcessOnOnly_A.log:

VCS WARNING V-16-10031-9509 ProcessOnOnly:vxatd:monitor:Process(4447) is running with priority:0, requested priority:10

I am running VCS 5.1SP1 on a RHEL 5.5 Dell server.

When I issue the "hares -display vxatd", I see the following regarding Priority:

vxatd        ArgListValues         anp_gmp1   PathName  1       /opt/VRTSat/bin/vxatd   Arguments       1       ""      UserName   1root    Priority        1       10      PidFile 1       ""      IgnoreArgs      1       0
 

vxatd        Priority              global     10
 

The original contents of main.cf for this Resource is the following:

group VxSS (
        SystemList = { anp_gmp1 = 0, anp_gmp2 = 1, anp_gmp3 = 2 }
        PrintTree = 0
        Parallel = 1
        AutoStartList = { anp_gmp1, anp_gmp2, anp_gmp3 }
        OnlineRetryLimit = 3
        OnlineRetryInterval = 30
        )

        Phantom phantom_vxss (
                )

        ProcessOnOnly vxatd (
                PathName = "/opt/VRTSat/bin/vxatd"
                IgnoreArgs = 1
                )

I have tried the following, to no avail:

1). Removed the "IgnoreArgs = 1" setting in the main.cf

2). Added a "Priority = 10" setting in the main.cf

Any ideas on how to correct this? And what is "Priority" in the conext of VCS (doesn't look like a Linux priority/nice value)?

Comments 6 CommentsJump to latest comment

Prasanna Kulkarni's picture

Looks like the running vxatd daemon has a different priority than what the agent is asked to check for (in your case, agent is configured to check for 10).

 

Can you post the output of following command?

ps -elf | egrep "vxatd|PPID"

This should confirm the priority (nice value) of the vxatd daemon. Note that the "Priority" attribute is actualy the adjustment to the shell's default nice value. The agent runs the process with "nice --adjustment <Priority>".

wgphillips's picture

F S UID        PID  PPID  C PRI  NI ADDR SZ WCHAN  STIME TTY          TIME CMD
1 S root      4447        1  0   78   0     - 27825     stext    Jan29 ?         00:02:18 /opt/VRTSat/bin/vxatd

Looks like you are correct. I checked another resource that is of type ProcessOnOnly and its nice value is 10.

wgphillips's picture

I was able to change the nice value on "vxatd" to 10 by using the "renice" command. This stopped the error messages to the log file.

However, I now have another question. I see in the /etc/rc.d/rc5.d directory, there is a S70vxatd startup script. This starts the "vxatd" on boot (and before VCS is started via the S99vcs script). The S70vxatd script does not apply any nice value to the startup of "vxatd", so it's nice value is 0 on boot. When VCS starts up and the HAD reads the main.cf configuration, does it try to "renice" the already running "vxatd"? It's not clear in this situation how the nice value of 10 is applied.

arangari's picture

The ProcessOnOnly agent, upon receiving information about the 'vxatd' resource,  will find the resource state. If it is already ONLINE, it will be informed to HAD.  It will not change any property of existing process. 

Thanks and Warm Regards,

Amit Rangari

If this post helped you resolving the issue, please mark it as solution. _____________________________________________________________________________

wgphillips's picture

Sounds like to fix this then I need to either "renice" the vxatd after boot or set the Priority value in the main.cf to 0. Any recommendation on those choices?

Prasanna Kulkarni's picture

I would discourage renice of vxatd daemon. Please set Priority to zero for the resource. You can do it by editing main.cf (needs VCS restart) or by VCS CLIs (does not need VCS restart).

SOLUTION