Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Getting "credentials already exist" when creating Media Server DeDuplication Pool

Created: 28 Aug 2013 | 10 comments

Hi,

I am getting error "credentials already exist" when creating the MSDP.

I have attached an iSCSI drive on a media server with letter E:\ and created a folder MSDP in there. For the storage path, i am using e:\MSDP.

The error is attached.

Hopefully someone has seen this before.

Thanks,

Sean

Operating Systems:

Comments 10 CommentsJump to latest comment

ls01c's picture

No, i am not recreating MSDP pool. the first time i created it failed, that time i did not receive the "credentials already exist" error.

but after that, i always receive that error.

PeteWall's picture

When the first configuration failed, there's likely some artifacts left over that is causing the second configuration to fail.  revaroo's suggestion to run PDDE_deleteConfig.bat is the best option.  That'll clean up anything on the MSDP side.  That script will *not* remove the actual storage directory that was created.

After you run the script, make sure that you don't have a storage server entry in Credentials --> Storage servers, then run the configuration again.  If it fails, then we'll need to investigate the original failure.

Have you had MSDP working previously?

revaroo's picture

Try running C:\Program File\Veritas\pdde\PDDE_deleteConfig.bat 

This will do a complete cleanup of that media server
 
NOTE: If anything IS configured for MSDP it will destroy it on this media server.
ls01c's picture

that failed as well. i have an attached iscsi drive E:\MSDP. i have a master server and media server. may i know what is the steps to setup a MSDP?

Mark_Solutions's picture

It looks like your first attempt has put in the details somewhere already, even though it did not complete its setup

Does the server show up already under Credentials - Storage Servers?

If it does then you may just be able to continue by adding its disk pool etc. If that does not work then delete the Pure Disk Storage Server shown and start again

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

ls01c's picture

Hi Mark,

unfortunately, it did not show up under storage servers but it seems the credential is saved somewhere else.

Mark_Solutions's picture

Did you try the PDDE_deleteConfig.bat?

Other than that you could try using nbdevconfig -deletests (or -updatests or -creatests) from the command line to try and force things through that way.

nbdevquery -liststs -U -storage_server mediaservername -stype PureDisk may give you a better idea of what is held in EMM for the server as a good starting point to know if you need to remove, update or create it.

See what you can do via the command line - you can always try adding the -force on the end (havent got a system to hand to try that one)

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

ls01c's picture

getting below:

C:\Program Files\Veritas\NetBackup\bin\admincmd>nbdevquery -liststs -U -storage_
server media_server_name
Storage Server      : media_server_name
Storage Server Type : BasicDisk
Storage Type        : Formatted Disk, Direct Attached
State               : UP
Flag                : AdminUp
Flag                : InternalUp
Flag                : SpanImages
Flag                : BasicStaging
Flag                : FragmentImages
Flag                : CatalogBackup
Flag                : Cpr
Flag                : RandomWrites
Flag                : FT-Transfer