Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Getting Error while configuring Oracle RMAN tpl script

Created: 13 Aug 2012 • Updated: 30 Aug 2012 | 7 comments
This issue has been solved. See solution.

Hi,

I am trying to create RMAN HOT Backup tpl script for one of the Database however after the Archived Redo Logs step, I am getting the following errors.

  1. /usr/openv/netbackup/bin/bpdbsbora: Symbol ‘rb_errmsgstr’ has different size in shared object, consider re-linking.
  2. /usr/openv/netbackup/bin/bpdbsbora: Symbol ‘jm_errmsgstr’ has different size in shared object, consider re-linking.

               

As per error "consider re-linking", we re-linked the library files again but received the same error after re-linking also. Did anyone face this issue. Please let me know if anyone has solution for this.

Thanks in advance.

Regards,

Tarun Konduri.

Comments 7 CommentsJump to latest comment

CRZ's picture

I suspect a version mismatch.  What version of NetBackup is installed?  What O/S are you running?

Can you provide contents of /usr/openv/netbackup/version and /usr/openv/share/version_oebu as well as output from:

/usr/openv/netbackup/bin/goodies/support/versioninfo -f /usr/openv/netbackup/bin/bpdbsora

(Assuming UNIX from your paths posted above and spiffy X graphic :) )


bit.ly/76LBN | APPLBN | 75LBN

tarun.konduri's picture

Hi Chris,

Master is 6.5.5 and Client is 6.5.3.1.

Version : NetBackup-RedHat2.6 6.5.3.1
 

I didn't found the other two commands in Netbackup. Please see below..

$ cd /usr/openv/netbackup/bin
$ cat version
NetBackup-RedHat2.6 6.5.3.1
$ cd /usr/openv/share
$ ls     --- > Nothing is present in share
$ pwd
/usr/openv/share
$ cd /usr/openv/netbackup/bin/goodies/
$ ls
nbclient   ---> support folder is not present in goodies
$ pwd
/usr/openv/netbackup/bin/goodies
$

Just to clarify, we have two DB's on this server. We are taking RMAN hot backup from 1 year and we got request to take RMAN for other DB so I tried to configure. First DB which configured last year is working fine. Issue is with second DB. I asked oracle admin to login to RMAN using target DB as second DB with recovery and asked him check to allocate channel. Below is the output.... 

RMAN> allocate channel for maintenance type 'SBT_TAPE';

allocated channel: ORA_MAINT_SBT_TAPE_1
channel ORA_MAINT_SBT_TAPE_1: sid=1079 devtype=SBT_TAPE
channel ORA_MAINT_SBT_TAPE_1: Veritas NetBackup for Oracle - Release 6.5 (2007072323)

I am assuming that linking is proper as allocate channel is able to execute without any issue...

Let me know if you need any further details.

Thanks & Regards,

Tarun Konduri.
 

Nicolai's picture

What Oracle version is the new DB ?. If it 11G r2 you need to be on 6.5.6

See : http://www.symantec.com/business/support/index?page=content&id=TECH129631

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

tarun.konduri's picture

Hi Nicolai,

Both the DB's are on 10G R2 so these are supported....

Thanks for the reply.

Twinkle Sapra's picture

1. Before relinking, it is required to export ORACLE_HOME and ORACE_SID variable for desired database. Have you exported these varaible before relinking.

tarun.konduri's picture

After creating the bpdbsbora log directory, I was able to create the tpl script without any issue. Symantec Tech Support also don't know how it resolved the issue but it worked... Also got update they don't have document regarding this error.

-Tarun

SOLUTION