Video Screencast Help

Ghost Configuration Fails

Created: 18 Jun 2013 | 9 comments

Here's the environment: Ghost Server running on Windows XP. Ghost client running on Windows XP. Trying to deploy/configure Windows 7 to the Windows XP client.

Here's what happens successfully when the task starts: The PC reboots, connects to the Ghost Server, Updates PreOS files, create machine account, prepare configuration, to virtual partition, download DOS client upgrade, run dos client upgrade, clone.  

Here's what fails after the clone: Configuration. Error id: 19 SYSTEM\ControlSet001\Services\ngclient. Error id: 54 SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon. Error id: 53.

The task is running with domain administrator rights. After cloning, the PC should reboot, apply the Sysprep answer file, and then run the configuration. Instead, the target PC just sits there waiting for commands for the Ghost Server.

I couldn't find any solutions or discussions related to these errors. It even looks like the error file is written incorrectly since it says "Error id: 53" without anything else afterwards.

Any help would be appreciated. Interfacing with Symantec tech support hasn't been very helpful.

Operating Systems:

Comments 9 CommentsJump to latest comment

EdT's picture

Are you deploying using a DOS client?  At the very least, try using WinPE as DOS has poor compatibility with modern hardware.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

djweisman's picture

The Ghost Server deploys some flavor of WinPE (Vista?) to the target client before rebooting it and running tasks.

EdT's picture

Did you find this posting when you searched on Error 53?

You may also wish to review this sticky posting in case the 2269 patch is relevant to your problem:

Unfortunately the patches are only available from Tech Support to holders of a maintenance agreement, so you will have to speak with them again if you need this patch.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

djweisman's picture

I checked out the link, but don't think it applies. Both PCs are in the same subnet. The target PC receives the image from the Ghost Server, so they are communicating with each other.

EdT's picture

What happens if you force a reboot manually after cloning? Does the machine then boot into mini setup?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

djweisman's picture

Yes, mini-setup will run, but my Sysprep settings don't get applied, PC doesn't get rename, domain doesn't get joined.

djweisman's picture

The best answer tech support could give me was, "The error numbers 19, 54, 53 refers to an issue with the Service Account", which doesn't help much. When I asked for specifics, I got no reply. Why aren't these error numbers listed and explained on Symantec's website? Maybe Symantec doesn't know how their own software works. Hellloooooooo.............Symantec?!!!!!!!!!!!!!!!

EdT's picture

Ghost was a product that Symantec purchased many years ago, but the team that developed it was laid off a few years ago. What remains of support is based out of India, so your expectation that Symantec support should know their product is sadly incorrect. Of course in an ideal world, documentation should be accurate and complete, but after 35 years in the IT industry, that has yet to happen.

A former Ghost developer, Nigel Bree, occasionally posts in these forums and he is probably the best person to give you chapter and verse on the internal workings of Ghost. His postings are well worth searching for if you want to get to know the product better.

Regarding the service account, this is an internal account in the operating system which runs processes at an elevated level - superior to the Admin account in many cases. It is the account used by many of the services that run in the operating system, and is also the account used by the Ghost client. Unfortunately, there is no single answer to these errors, as any problem with the Service account could cause the issues you are experiencing.

I can't think of any quick way to diagnose the problem, so what I would suggest is a strategy that removes as many variables as possible.  The first thing I would try would be to create a WinPE bootable USB stick or hard disk, and run Ghost manually from the WinPE command line, and restore your image to the test hardware manually, from a local USB device. Then check that it starts up OK.  If it does, then it points the finger at a networking problem. I hope you can see my strategy here - try things one step at a time to narrow down the actual point of failure.

Incidentally, if you are using multicast over your network, you need to have IGMP snooping enabled as otherwise the process will hang at some point.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Swinster's picture

Interesting, I have just come across the same issue. The Symatec Servcie account needs to be gven delegated control agains the AD OUs, but I'm pretty sure I did this.

Did you get a resolution?