Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Ghost Console 11.5 Configuration Warning: Logon Failure

Created: 01 Aug 2013 • Updated: 08 Aug 2013 | 11 comments
This issue has been solved. See solution.

I know this has got to be something simple, but I am having a hard time getting ghost console authenticated in our Domain. I have worked in existing ghost environments before, but this is my first shot at setting one up from scratch. 

Our ghost console is installed on one of our domain controllers, both of which are server 2008r2. I have hacked my way through the network driver-PE issues that im sure accompany many installs, but the congfiguration tasks continually fail. I think I understand the functions and components, but I will discuss what I think I understand, if you are able to ccorrect any please do so.

  • The configuration task is directly related to the configuration tab under each machine in the ghost console.
  • If I right click on the machine I can go to the configuration tab and then edit the default configuration.
  • IF the default configuration includes a domain, and the ghost console has administrative access to that domain, it can join that computer to that domain based on its configuration (computer name etc)
  • When you authorize a domain to the console, it for some reason (security?) does not appropriate the needed administrative rights to allow it to add computers to the domain.

My questions are this:

  • What are the necessary group memberships for the console to properly add things to the domain?
  • Is there an easy domain authentication check?
  • Am I able to specify the password the console uses to authenticate in active directory? (I have tried changing it and Im not sure if that is an option.)

We arent using sysprep

We are using win-PE as a net-boot OS, and all is working fine with regards to imaging.

let me know if anything here is obviously amiss, or what I can do to further troubleshoot this issue that I am having with the config task.

Thanks in advance.

Operating Systems:

Comments 11 CommentsJump to latest comment

theunfrailhale's picture

I forgot to mention that I have it as a member of 

  • Administrators
  • Domain Admins
  • Domain Users

Our computers are broken down into OUs like "Computer Lab" and "Mobile Lab" under the OU "All Computers", do I need to specify *which* computers/OUs the account has access to?

theunfrailhale's picture

In my further attempts to troubleshoot, I assigned the ghost console user all the same membership I have as the primary domain admin, just to see if it was a permissions error, but to no avail.

I have also just used the account to logon to a computer, so I know the username and password are good. 

 When I run a task with only "Configuration" checked, and the "default" box is checked under the configurationtab, and the computer's configuration settings are groomed, it still fails with the error:

Details for: Configuration

Failed to join domain domainname.local: Logon failure: unknown user name or bad password.

again, I have logged in using this user account, so its a good username and password...

theunfrailhale's picture

Not sure Im gunna get any help here, but I figure I'll keep the documentation going for someone else with this problem.

I created a configuration template in Ghost Console and then ran a configuration task on the machine using that template. The computer was already outsitde the domain, and I was hoping it would add it to the domain, which is didn't. It did however, change the name of the computer to the default arbitrary computer name, based on the wildcard operator in the default Configuration template.

so it IS accessing the computer's settings and is changing things, but just not joining it to the domain.

A few things that seem out of order.

When I edit the default configuration of a specific machine, the DNS settings dont match/update on the "Last Known Machine Configuration" summary. It keeps its old DNS and Default gateway settings, which is weird. It also retains its old computer name, not the new one that I just sent to it via configuration template.

Also, since messing with the network settings in the configuration tab, I have gotten a different error on the configuration task failure:

WARNING

Details for: Configuration

Failed to join domain DomainName.local: Logon Failure: account currently disabled.

Again, this doesn't seem to make any sense to me because I can log in personally, using the credentials that Ghost Console has in place, and then add/remove machines manually under that account name. 

Im sure this is going to boil down to something stupid like, asynchronus clocks or something, but until it does is causing me piles of grief.angry

EdT's picture

What exact version of Ghost are you running?

There may be issues with 2008R2 due to increased security in the operating system. Try installing on an XP workstation as a test.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

SOLUTION
theunfrailhale's picture

Our Ghost console is version 11.5.1.226.

Ghost console client version (as listed in add/rem programs) is 115.01.2266

to be sure i understand your suggection clearly, you are recommending that I install the ghost console on an XP machine and try the configuration action from there?

Any thoughts on running ghost console from a VM? performance/ compatibility issues?

thank you for the resoponse! 

also I would be interested in any other options related to reducing the scurity settings in R2 that would allow it to cooperate...

theunfrailhale's picture

fix one problem find ten.

is there any way to manually specify which ghost console manages a client?

I installed GSS on my workstation to test the abovve mentioned theory of 2008r2 security settings interfering. My machine is W7-x64, and I have sucessfully run GSS from this OS in the past.

I uninstalled the Ghost client, then re-installed and specified that I want it to be managed by COMPUTER-B

when the machine fails a test "Configuration" task, it reboots and sits trying and failing to make a connection to COMPUTER-A, on which I have disabled all ghost services for testing. so to test a configuration push I need to uninstall and reinstall the ghost client... angry 

this is preventing a lot of work from getting done. expletives.

Terry BU's picture

theunfailhale, did it ever add machines to the domain correctly?

Next, is the machine you are trying to add already in the domain (does the object exist in AD, or will this be the first time it is being made?)

Under the configuration tab, is the domain listed correct, or is it truncated?

theunfrailhale's picture

I think the issue is as EdT mentioned, a compatibility issue with server2008. I had previously ran my Console off of a server 2003 machine and wanted to keep the same arrangement post-upgrade.

It was a fresh copy of 2008r2 x64, only running services like DHCP, DNS and acting as a DC with limited FSMO responsibilities. I could never get the console to add computers to the domain, it would always give me the errors stated above. After deciding to host the Console on my personal workstation as a troubleshooting measure, and putting a fresh install of W7x64 on, I am relieved to see that my understanding of console configuration is at least a working one. I have the Console properly adding the computers to the domain etc, and all is functional.

I may try installing the console on another server/DC in the network to see if perchance it was something funny with that particular setup, but for the present, I am able to start getting some work done and be relieved that I have some competence with GSS.

Thanks for the input gentlemen. If you do know of working instanced of GSS on Server 2008r2, I would be interested to hear of them. If it is possible its something I will look into arranging later.

Terry BU's picture

we are running our GSS Server on 2008R2, and for some reason i have this itch in my mind that we had to force enable NT4 cryptography on the server.  Sorry the details arent better, i dont remember exactly what steps were involved.  that feature is off by default in 2008R2, since its set to something better

EdT's picture

If I recall correctly, the newest Windows server releases use Kerberos security and netbios protocol is no longer installed by default.  As Terry mentioned above, you need to enable some legacy features on 2008R2 to get it working, but like Terry, I do not recall the details.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

theunfrailhale's picture

That should be enough info to put me in the right direction.

I really appreciate the info, you guys have been a great help. I will have to look into that when I am not so pressed to have things done. Its nice to know that it is workable. It will be a good excersize in Ghost DB backup/restoration.

Seriously gents, my greatest thanks.