Video Screencast Help

Ghost Image Creation Hangs at Adding MFT logfile File to image

Created: 05 Apr 2012 | 15 comments

I am having the very devil of a job creating an image of a Lenovo Thinkcentre Edge PC.

PC is Windows 7 Pro and runs a Realtek 8169 Gbit Ethernet card

in Ghost console i f have tried the various suggestions from other notes where the users have had the same issue.

Pc will only boot into the ghost app if using PCDos. I have tried using the universal packet drivers and the NDIS2 from realtek.

i have succesfully run an inventory of the PC so i am happy that the pc can see the ghost console machine.

when i boot to PCDos the pc recognizes the ghost console machine and then stops after about 12 or 13 seconds when the activity line of Adding MFT Logfile file to image. i have left this overnight in case it was just taking a heck of a long time.

i do not appear to generate a ghosterr.txt file, or at least if i do i cant find it anywhere.

i have 24 machines to ghost by the end of the week and i am struggling.

does anyone have any suggestions? 

Comments 15 CommentsJump to latest comment

EdT's picture

What version of Ghost do you have as with modern hardware, we would always recommend using WinPE rather than PCDOS. PCDOS has no SATA support so unless your system bios is set to a compatibility mode which emulates the older PATA standard, PCDOS will not be able to see the disk.

In addition, what command line switches are you using?  Lenovo have a rather peculiar way of writing their boot sector so if you are imaging their operating system install, I believe you need to add the -ib switch if I recall correctly.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

WestbrookHay's picture

I have only just purchased so it is the latest version.

PCDos does appear to work - i have succesfully done an inventory task. 

I can boot into PC dos and it sees (or at least appears to see!) the disk.

WinPE does not do anything. I run the mage create task and i get a message flashing up in th emachine i want to clone. The error in the ghost console says;

 

Task process listing
W764-MASTER C8-9C-DC-D7-D0-B1 Updating PreOS files 05/04/2012 16:34:15 Success
W764-MASTER C8-9C-DC-D7-D0-B1 To Virtual Partition 05/04/2012 16:34:21 Failed
Details for: To Virtual Partition
Drivers could not be found in the PreOS for the following devices:
 
Manufacturer: "@oem5.inf,%intel%;Intel", Description: "@oem5.inf,%pci\\ven_8086&dev_1c02.devicedesc%;Intel(R) 6 Series/C200 Series Chipset Family 6 Port SATA AHCI Controller - 1C02", PCI Vendor: 0x8086, PCI Device: 0x1c02, PCI Subsystem: 0x307c17aa
 
which suggests it cant see the HD?
How do i solve that?

 

Terry BU's picture

seems to be an issue with your VISTA controller/SATA drivers.  you may need to get the newest intel chipset drivers for that.  Again, VISTA drivers, and make sure you select to enable them after you have added them

WestbrookHay's picture

Yes, sorry, stressed out techie here - should have RTFM first - apologies for being thick!

ICHCB's picture

There are a lot of posts here on how to do that.   Here is one with a link to the 2 needed kbs.

www-secure.symantec.com/connect/forums/resolving-drivers-could-not-be-found-preos-following-devices-error

Dos can't deal with that new hardware you have and windows pe just doesn't have the needed drivers.   Once you add the needed drivers you can run the task again with windows pe and will be off to the races. 

Your version number is still important there are a bunch of updates that you should be using and they may not be included in your new install.   Go to help and about in the console and you can determine what version you have.   If you don't have the 11.5.1 2266 then you don't have the latest version and you will want to run live update so that you can get up to this version. 

cheers.

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

WestbrookHay's picture

Thanks buddy, as above my apologies for being thick - i should have sat back and put a bit more thought into it.

The version is 11.5.1.226 - i religously ran teh live updates on installation.

WestbrookHay's picture

Guys - thanks for the help so far.

i am now getting a stage further but my master machine just will not see the ghost consoe machine after reboot.

i get the 'bound for polling server' message repeating on and on until it times out.

I really thought i had the correct drivers installed - i used the ones from the driver set kept on the machine.

any further thoughts or suggestionsas to how i ensure that i have the right drivers? 

ICHCB's picture

What is the IP of the bound server?   (don't answer that I don't want to know the IP)  Is the ip the ip of your server?  If not then there is a problem with the certificate.    More likely than not the network adapter driver is included in the stock ghost drivers but they are not good enough to fully function.   

If you press ctrl C to cancel I think that will get you back to the command prompt.  In win pe you have the ping command and the ipconfig command at your disposal.   Can you ping the server from the windows pe machine? If not can you pull up your IP using the ipconfig command to see your ip.   If you don't have an ip or it is the generic 169.  address to an ipconfig /release and then ipconfig /renew command and see if you can get a good ip and then ping the server.   

We had a location once that the network switches did a negotiation for link speed and QOS that took so long that the bootup in dos and in winpe would give up on asing for an address.  If once the switch was negotiated and connected we ran the ipconfig /renew we could get an address.   A work around for this is to set the switch to 100 meg half duplex or put in a dumb hub that doesn't do all the cool stuff that the cisco units do just as a test and if it is a delay on the switches then identify if their is an update that will speed them up or set the speed in your lab to 100 half duplex as a workaround.    Also updating the NIC drivers can improve this same issue because it can allow for more efficient negotiation and eliminate the problem.

Cheers.

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

WestbrookHay's picture

Interesting point. never thought to check. Just looked more closely and it looks like it is trying to look for the loopback address.

i am pretty sure i have the most up to date drivers installed into the setup.

Would it help if i ran a static ip? will try this in the morning.

Terry BU's picture

usually when you see this you have no network connection.  

The next question though is this.  Does the network adapter exist in Windows PE?  If you have a 169 address, or even a real address with ipconfig, you may have an issue with the line or your network itself.  Most times i see the polling issue though i am actually missing any network connector at all!  This would be because the network drivers (again, VISTA) are not correct

ICHCB's picture

If it is looking for the loop back I bet the ipconfig would reveil that the machine didn't pull an IP and if it didn't pull an IP it could be that the ipconfig /renew would give an error simular to no adapter in a permissable state or somr thing like that.    If you get that error it is because the driver in windows pe isn't updated enough or 2 simular drivers are listed and you will need to uncheck the old driver so that only the new driver will load.    I have seen this when using an intel or broad com gig nic when you add the latest driver to the ghost boot wizard and the old driver didn't get unchecked.  

cheers.

 

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

ICHCB's picture

Were you able to do an IPCONFIG task to see if you had an IP?  Just wondering if you had come to the root of the issue.

Cheers,

If you find this post helpful please give it a thumbs up!
If you find that this solves your problem please mark it as the solution! 

WestbrookHay's picture

Holiday weekend here so sorry for no response.....

Okay, so here is where i am at.

Using WinPE and a variety of the different drivers that realtek appear to offer for the PCIe Family GBE network card gets me nowhere - all i get is the polling error - doing an ipconfig identifies that the card is not getting set up in WinPE and therefore i have no IP address.

i have tried the NDIS2 variants of the RTL 8168 and 8169 drivers.

Using PCDOS does get me to the ghost task screen on my machine that i want to image but i cant get any further than 'Adding MFT logfile file to image' - the image just seems to hang at this point.

i have browsed this error and everything points to the driver.

i have tried both PCDos and WinPE options and the universal packet drivers including the interupt conflict option.

PCDos does appear to recognise the card and it has an IP address.

i am really at a loss here. any other suggestions?

EdT's picture

Let us reiterate that the drivers needed for the version of WinPE in Ghost Solution Suite 2.5 are the VISTA 32 bit drivers (as this version of WinPE uses the Vista kernel). The drivers need to be in the form of a .SYS .CAT and .INF file as a minimum although it is not uncommon to find other files such as DLL files in the driver set.

When adding drivers to Ghost boot wizard, there is also a requirement to make sure that the drivers are Selected after being added, otherwise they do not get included in the WinPE rebuild.

If you have a working operating system install, go into device manager and note the Device ID of the NIC chipset (also known as the PNP ID).  Then open the INF file of a target driver set and check that the Device ID is present in the list of supported devices for that driver. If it is not, then the driver will not work.

With WinPE, you can also load driver dynamically from the command line. Put the candidate drivers into a folder on a USB stick and load your WinPE boot then get to a WinPE command prompt.

Navigate to the driver folder then type DRVLOAD NAMEOFINFFILE.inf

If the driver is loaded successfully, the command line message will tell you so.  

Once you have a driver successfully loaded, try IPCONFIG /release then IPCONFIG /renew and check that an IP address is obtained correctly.  If the driver does not work, try another using DRVLOAD until you find one that works.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

WestbrookHay's picture

i have no idea how but i think i just solved it!

i added the .sys files to the additional files section and blow me but it has started to work!

Basically i tried following all the instructions and was getting lost.

so i retraced my steps, created the ndis2 setup and then clicked on the advanced tab and added the 32 and 64 bit .sys driver files.

The image now seems to be taking hold!

 

thank you everyone for the help.